Creating a Wire Harness with Harness Design
Contents

Proprietary and restricted rights notice ........................................ 2

Introduction .................................................................................. 1-1

Introduction to Harness Design ...................................................... 2-1

Wire harness design workflow ......................................................... 3-1

Wire harness design workflow ....................................................... 3-2
Using BlueDots to Reposition Conductors and Components (ordered
environment) .............................................................................. 3-4
Connect curves with BlueDot in Wire Harness (ordered modeling) .......... 3-5
Using the Harness Wizard to create harness designs automatically .......... 3-5
Working with nailboards ................................................................. 3-59

Activity: Creating a wire harness with Harness Design .................... 4-1

Creating a wire harness with Harness Design .................................. 4-2
Open activity file ............................................................................. 4-3
Open the Harness Design environment ............................................. 4-4
Activate the parts in the assembly .................................................. 4-5
Hide the console part ...................................................................... 4-6
Start the Harness Wizard .................................................................. 4-7
Specify information for Harness Wizard Step - 1 of 3 ....................... 4-8
Specify information for Harness Wizard Step - 2 of 3 ....................... 4-9
Specify information for Harness Wizard Step - 3 of 3 ....................... 4-11
Assign terminal A ............................................................................ 4-12
Assign terminal B ............................................................................ 4-13
Assign terminal C ............................................................................ 4-14
Fit the view ...................................................................................... 4-15
View PathFinder ............................................................................ 4-16
Create a bundle .............................................................................. 4-17
Re-select the Harness Wizard command ......................................... 4-19
Change the assembly display ....................................................... 4-20
Zoom in on the assembly .............................................................. 4-21
Create a wire .................................................................................. 4-22
Select the first point for the wire ................................................... 4-23
Fit the view ...................................................................................... 4-24
Zoom in on the upper gauge .......................................................... 4-25
Select the end point for the wire .................................................... 4-26
Finish the wire .............................................................................. 4-27
Fit the view ...................................................................................... 4-28
Zoom in on the assembly .............................................................. 4-29
Create another wire ....................................................................... 4-30
Finish the wire .............................................................................. 4-32
Fit the view ...................................................................................... 4-33
Create a cable ................................................................................. 4-34
Contents

Shade the view ................................................................. 4-36
Create a solid body of the wire harness ................................. 4-37
Change the view orientation .............................................. 4-38
Zoom in on the assembly .................................................. 4-39
Move a wire ....................................................................... 4-40
Move two more wires ....................................................... 4-42
Fit the view ....................................................................... 4-44
Change the view orientation .............................................. 4-45
Display a hidden part ....................................................... 4-46
Hide the wires in the harness .............................................. 4-47
Create a Wire Harness Report ............................................ 4-48
Return to the Assembly environment .................................. 4-50
Save the file ....................................................................... 4-51

Lesson review ................................................................. 5-1

Lesson summary ............................................................ 6-1
Lesson

1 Introduction

Welcome to Solid Edge self-paced training. This course is designed to educate you in the use of Solid Edge. The course is self-paced and contains instruction followed by activities.

Solid Edge self-paced courses

- spse01424—Working with Solid Edge Embedded Client
- spse01510—Sketching
- spse01515—Constructing base features
- spse01520—Moving and rotating faces
- spse01525—Working with face relationships
- spse01530—Constructing treatment features
- spse01535—Constructing procedural features
- spse01536—Modeling synchronous and ordered features
- spse01537—Multi-body modeling
- spse01540—Modeling assemblies
- spse01545—Creating detailed drawings
- spse01546—Sheet metal design
- spse01550—Practicing your skills with projects
- spse01560—Modeling a Part Using Surfaces
- spse01610—Solid Edge frame design
- spse01640—Assembly patterning
- spse01645—Assembly systems libraries
- spse01650—Working with large assemblies
- spse01655—Revising assemblies
- spse01660—Assembly reports
Lesson 1  
*Introduction*

- spse01665—Replacing parts in an assembly
- spse01670—Designing in the context of an assembly
- spse01675—Assembly features
- spse01680—Inspecting assemblies
- spse01685—Alternate assemblies
- spse01686—Adjustable parts and assemblies
- spse01690—Virtual components in assemblies
- spse01691—Exploding assemblies
- spse01692—Rendering assemblies
- spse01693—Animating assemblies
- spse01695—XpresRoute (tubing)
- spse01696—Creating a Wire Harness with Harness Design
- spse01697—Working with nailboards
- spse01698—Using a cam relationship

**Solid Edge self-paced modules**

- spse01510—Sketching
- spse01515—Constructing base features
- spse01520—Moving and rotating faces
- spse01525—Working with geometric relationships
- spse01530—Constructing treatment features
- spse01535—Constructing procedural features
- spse01536—Modeling synchronous and ordered features
- spse01537—Multi-body modeling
- spse01540—Modeling assemblies
- spse01545—Creating detailed drawings
- spse01546—Sheet metal design
- spse01550—Practicing your skills with projects
Start with the tutorials

Self-paced training begins where tutorials end. Tutorials are the quickest way for you to become familiar with the basics of using Solid Edge. If you do not have any experience with Solid Edge, please start by working through the tutorials for basic part modeling and editing before starting self-paced training.

Supported Browsers

- Windows:
  - Internet Explorer 8 or 9
  - Firefox 12 or higher
- UNIX/Linux
  - Firefox 9.x or higher*
- Mac: Safari 5.x or higher

Java Plug In Required for search

The search engine requires version 1.6.0 or higher of the Java Plug In installed to your browser. The plug in is available (free) in the Java Runtime Environment (JRE) 6.0. If you need to install the JRE, or an equivalent Java environment, visit the Java download site at http://www.java.sun.com.

Adobe Flash Player required for videos and simulations

To watch videos and simulations, you must have the Adobe Flash Player version 10 or later installed as a plugin to your browser. You can download the Flash Player (free) at the http://get.adobe.com/flashplayer

Adobe Acrobat Reader

Some portions of the help may be delivered as PDF which requires Adobe Acrobat Reader 7.0 or higher. You can download the reader (free) from http://get.adobe.com/reader/

Internet Explorer Caveats

- IE9 Compatibility View. The HTML deliverables are fully supported when launched with the http:// protocol or the file:/// protocol. However, if you are viewing the files from a local installation e.g. D:/, you may need to enable Compatibility View. In IE 9, do the following:
  2. In the Compatibility View Settings dialog box, select the “Display all websites” in Compatibility View check box.
**Firefox Caveats**


- Most customers install and launch our deliverables via http:// protocol which is fully supported. However, Firefox has a default security setting that prevents the help from launching correctly from a UNC path (file:///). To change this setting, you need to change the value of the security.fileuri.strict_origin_policy preference:
  - In the address bar, type about:config.
  - In the Filter field, type security.fileuri, if the value of the security.fileuri.strict_origin_policy preference is set to true, set the value to false. (Double-clicked the value to toggle it.)
  - Restart the browser.
Lesson

2 Introduction to Harness Design

This course provides step-by-step instructions for using the commands in the Harness Design environment to create a harness design that contains several wires, a cable, and a bundle.

Harness Design allows you to easily construct wires, cables, and bundles from one point to another in an assembly. The Harness Design module provides a Harness Wizard that automatically creates a harness design based on information contained in an imported net list. The module also provides a structured workflow that quickly defines a 3D path between parts and define wire, cable, and bundle properties. After defining these properties, the software constructs the wire, cable, or bundle.
Lesson

3  Wire harness design workflow
Wire harness design workflow

Wire harness design overview

You can use the Wire Harness application to work with assemblies containing electrical conductors.

To activate the Wire Harness application, choose Tools tab→Environments group→Harness.

Solid Edge Wire Harness Design is intended to work with round conductors only and does not support ribbon cables.

Note There is no limit on the number of conductors you can use in an assembly.

Generally, there are two design processes used in harness design. In the first design process a 2D electrical schematic is developed first, and the 3D model is derived from the schematic. In the second design process there is no 2D schematic or it is not used in conjunction with the 3D model.

Harness design workflow

Based on the design process you use, there are two workflows for creating your harness design:

• Automatic

• Manual
Creating the harness design automatically workflow

1. Create a new list either manually or with an ECAD system.

2. Use the Harness Wizard command to import the net list file to Solid Edge to assign component, connection, and terminal information for the harness design.

3. Use the Move and Assemble commands to position the automatically placed components if the assembly is not already created.

4. Bundle and route wires and cables as needed.

5. Add any wires or cables that were not included in the net list.

6. Verify all conductors exceed the minimum bend radius and they have the proper slack lengths.

7. Create manufacturing reports and create a 3D representation of the harness.

Creating the harness design manually workflow

1. Build the assembly to include all required components. You can place the components in the Harness Design environment.

2. Create the wires and cables needed for your design.

3. Bundle and route wires and cables as needed.

4. Verify all conductors exceed the minimum bend radius and they have the proper slack lengths.

5. Create manufacturing reports and create a 3D representation of the harness.
Lesson 3  
Wire harness design workflow

Using BlueDots to Reposition Conductors and Components (ordered environment)

**Note** BlueDots are only available in the ordered environment.

After creating a wire harness in the ordered, you may need to reposition conductors and components to clean up the design. When you create a cable or bundle, a BlueDot is created at the point where the wires, cables, and bundles meet.

You can drag the BlueDot to change the path the bundle or cable follows.
Connect curves with BlueDot in Wire Harness (ordered modeling)

**Note** BlueDots are only available in the ordered environment.

1. Choose Home tab→Paths group→BlueDot.
2. Select an endpoint on the first curve.
3. Select an endpoint on the second curve.
4. Continue to select the endpoints until the appropriate curves are connected.

**Tip**
- You can edit the position of a BlueDot using the Select Tool and the BlueDot Edit command bar.
- You can use the OrientXpres control to limit the edit to an axis or plane you select.

Using the Harness Wizard to create harness designs automatically

The **Harness Wizard command**, located on the Tools tab→Harness group, automatically creates a wire harness. The wizard uses information stored in an imported net list file to populate the components and conductors in an assembly.

**Note** Before running the wizard, you should use the **Assign Terminals command** in the Part environment to assign component and terminal names for components that will be used in the harness design.

When you select the command, a series of dialogs takes you through the process of defining information about the wire harness.

To learn how to use the dialog box, see Using step 1 of the Harness Wizard.

To learn how to use the dialog box, see Using step 2 of the Harness Wizard.

To learn how to use the dialog box, see Using step 3 of the Harness Wizard.

**Harness Wizard command**

Automatically creates a wire harness based on component and connection information contained in an imported net list.

Harness Wizard - Step 1 of 3
Harness Wizard - Step 2 of 3
Harness Wizard - Step 3 of 3
Harness Populate Options Dialog Box
Connection Options Dialog Box
Harness Populate Options Dialog Box

Number of Rows
Specifies the number of rows in the dialog box used to populate component parts into the assembly.

Row Spacing
Specifies the spacing for the rows in the dialog box used to populate component parts into the assembly.

Column Spacing
Specifies the spacing for the columns in the dialog box used to populate component parts into the assembly.

Use Simplified Components
Specifies that you want to use the component parts to come into the assembly as simplified components.

Using step 1 of the Harness Wizard

Use the Harness Wizard - Step 1 of 3 dialog box dialog box to specify:

• The format for the ECAD net list file.
• The component document used to create the harness.
• The conductor document used to create the harness.

Specify the format for the ECAD net list file

The Document Format option specifies the format for the net list file used to create the wire harness. Use the menu to display a list of document types found in the SEHarness.txt file.

The SEHarness.txt file, located in the Solid Edge Program folder, defines the data format for the ECAD net list files used to create the wire harness.

The SEHarness.txt file contains three sections:

• The company name, which also represents the format displayed in the menu list.

• The component definition used to define each column in the component file.

• The connection definition used to define each column in the connection file.

Specify the component document used to create the harness

The Component Document option specifies the component document used to create the wire harness. The document can be in .CMP or .CMP_XML format.

The component document contains information such as the component id, component name, and component description.

Specify the conductor document used to create the harness

The Connect Document option specifies the connection document used to create the wire harness. The document can be in .CON or .CON_XML format.
The connection document contains information describing the connections in the wire harness such as the component ID, color, and material, as well as the component from ID and the component to ID.

**Using step 2 of the Harness Wizard**

Use the Harness Wizard - Step 2 of 3 dialog box to specify:

- Assign components to a Component ID
- Assign occurrences of component part files already in the assembly
- Populate components into the assembly

**Assign components**

If you do not use the Assign Terminals command to make your component and terminal assignments before running the wizard, your component file will contain a component that has not been assigned. If your file contains an unassigned component, the component will be displayed in orange in the table. You do not have to exit the wizard to assign components.

To assign a component:

1. Click the component in the Components table.
2. Click the Assign Component command.
3. Click the part you want to assign the component to. The component is populated in the table and the Status and Occurrence Name columns are no longer highlighted.

You can right-click the Occurrences Name column for the component and click Browse on the shortcut menu to search for the part.

**Note** A part can contain only one component.

**Assign occurrences**

When components are imported prior to running the wizard, Solid Edge automatically assigns an instance to all duplicate parts in the assembly based on the order in which the parts are encountered. If the occurrences get out of order, you can use the Assign Occurrence command to change the occurrences for a component.

To assign an occurrence when a component has already been assigned:

1. Click the highlighted row for the component containing the occurrence you want to change.
2. Click the Assign Occurrence button.
3. Click the component you want to assign the occurrence to.

If the same part file is selected, the two part files swap instances. If the selected part is not associated with a component, the part is assigned to the highlighted component.
Lesson 3  Wire harness design workflow

To assign an occurrence when a component has not been assigned:
1. Click the Assign Occurrence button.
2. Click the component you want to assign the occurrence to.

If the selected part is not associated with a component, the part is assigned to the highlighted component. If the part is associated with a component, an error message is displayed.

**Populate components**

If a part listed in the components file is missing from the assembly, you can populate the component while in the harness wizard. All parts must be populated before you can proceed to the next step in the wizard. You can add the parts through the wizard or you can add them manually.

To populate a component:
1. Right-click in the Occurrence column for the highlighted component.
2. On the shortcut menu, click Browse to display the Open dialog box.
3. Select the appropriate part and click the Open button.
4. Click the Populate button.

| Note | You do not have to click the Populate button after each browse. You can browse for all parts and then click the Populate button. |

When populating components in an assembly, click the Populate Options button to display the Harness Populate Options dialog box, which allows you to define information for an array of the components being brought into the assembly.

The array contains information about the components, but it does not know where the parts associated with these components should be placed in the assembly. Since the part position is unknown, the parts are placed on the Top (XY) reference plane. Use the Assemble command to position the parts in the appropriate location after the wizard is complete.

**Using step 3 of the Harness Wizard**

This dialog box displays information about the connections used to create the wire harness. You can use options on this dialog box to:

- Assign terminals on the component parts
- Delete wires from the harness
- Assign Attributes to a wire or cable
- Preview the harness

**Assign terminals**

If your file contains undefined terminals, they highlight in orange. As with components, you do not have to exit the wizard to assign a terminal.

To assign a terminal:
1. Click the terminal in the Connections table.

2. Click the Assign Terminal button.

3. In the graphic window, click the circular edge on the highlighted part you want to assign the terminal to. The terminal is assigned and the cells are no longer highlighted.

- **Delete wires from the harness**
  
  If a wire listed in the connections document is not needed in the wire harness, you can delete it.
  
  To delete a wire from the harness:
  
  1. Right-click the wire you want to delete.
  
  2. On the shortcut menu, click Delete Wire From Harness.

- **Assign attributes to a wire or cable**
  
  You can assign attributes to a wire or cable while working in the wizard.
  
  To assign an attribute to a wire:
  
  1. Click the Solid Edge Attribute column for the wire.
  
  2. Click the menu arrow.

  The list includes attributes for the type of wire selected. For example, if the wire is 16 gage, the list will display only attributes for a 16 gage wire. There is also a Remove Filter entry in the list which allows you to remove the filter and display attributes for other types of wire.

  3. Select an attribute from the list.

  To assign an attribute to a cable:

  1. Click the Cable Attribute column for the cable.
  
  2. Click the menu arrow.

  The list includes attributes for the type of cable selected. There is also a Remove Filter entry in the list which allows you to remove the filter and display attributes for other types of cable.

  3. Select an attribute from the list.

- **Preview the harness**
  
  You can use the Preview button on the wizard to preview the harness. You can preview a single connection or use the Shift and Ctrl keys to preview multiple connections.
  
  To preview the harness:

  1. Select the connection you want to preview.
  
  2. Click the Preview button.
Lesson 3  
*Wire harness design workflow*

A straight line preview of the connection is displayed in the assembly.

After ensuring the information on the wizard is correct, click Finish to create the harness.

Once the harness is complete, you can use the Cable or Bundle command to group the wires or cables in the design.

After creating a wire harness, you may need to reposition conductors and components to clean up the design. When you create a cable or bundle, a bluedot is created at the point where the wires, cables, and bundles meet.
You can drag the bluedot to change the path the bundle or cable follows.

You can also clean up the harness design by using the Move command to drag a component to a new location.

Once you move the component to a new location, the link to the conductors is automatically updated.

Harness Wizard - Step 1 of 3

Document Format
Specifies the format for the net list file used to create the wire harness. Use the drop-down list to display a list of document types found in the SEHarness.txt file.

Component Document
Specifies the component document used to create the wire harness. The document can be in .CMP or .CMP_XML format.

Connection Document
Specifies the connection document used to create the wire harness. The document can be in .CON or .CON_XML format.

Harness Wizard - Step 2 of 3

Allows you to modify the information for the components in the assembly.
Lesson 3  

Wire harness design workflow

Components  
Displays information about the components used to create the wire harness.

Assign Component  
Changes the assignment of a component within the assembly.

Assign Occurrence  
Changes the occurrence of a part within the assembly.

Populate Options  
Displays the Harness Populate Options dialog box.

Populate  
Populates components into the assembly.

Back  
Moves to the previous dialog box of the Harness Wizard.

Next  
Moves to the next dialog box of the Harness Wizard.

Harness Wizard - Step 3 of 3

Allows you to modify connection definitions in the assembly.

Connections  
Displays information about the connections used to create the wire harness.

Preview  
Displays a straight-line preview of the wires used to create the wire harness.

Connection Options  
Displays the Connection Options dialog box which allows you to specify information about the connections in the wire harness.

Assign Terminal  
Changes the from and to terminals for the connection.

Back  
Moves to the previous dialog box of the Harness Wizard.

Finish  
Completes the Harness Wizard.

Use Harness Wizard to Create a Harness Design

This procedure provides the basic steps for using the Harness Wizard command to automatically generate a harness design based on information defined in an imported ECAD net list file. For more information on using the Harness Wizard, see the Working with Harness Design help topic.

Step 1:  
On the Harness Design toolbar, click the Harness Wizard button.
Step 2: On the Harness Wizard - Step 1 of 3 dialog box, specify a document format, component document, and connection document to be used in the harness design.

Step 3: Click the Next button.

Step 4: On the Harness Wizard - Step 2 of 3 dialog box, use the available commands to make component and occurrence assignments, or populate the assembly.

Step 5: Click the Next button.

Step 6: On the Harness Wizard - Step 3 of 3 dialog box, use the available commands to modify connections, delete connections from the harness design, or preview the harness design.

Step 7: Click the Finish button.

Tip

• Use the Assign Component command to assign a component to a part in the assembly. When you use this command the attributes are written to the part files if you have write-access.

• Use the Assign Occurrence command to assign an occurrence to a component or swap existing occurrences.

• Use the Populate command to add a part to the assembly that is listed in the components file, but missing from the assembly.

• Use the Assign Terminal command to assign a terminal to a circular edge on a part in the assembly. When you use this command the attributes are written to the part files if you have write-access.

• Use the Delete Wire From Harness command to delete a wire from the harness design.

• Use the Preview command to preview the harness design. You can preview a single connection, or use the <CTRL> and <SHIFT> keys to preview multiple connections.

Connection Options Dialog Box

Dialog Box Options
Number of Points Per Wire
Specifies the number of edit points that will be included in each wire.

Cable Sheathing Strip Back Length
Specifies the length of insulation that is removed from the bare conductor. Use the Added Length options on the Harness page (Solid Edge Options dialog box) to adjust the strip back length.
Assign Terminals command

Displays the Assign Terminals dialog box, which allows you to specify a component name and makes terminal assignments to a part or sheet metal model. Once you make these assignments, you can include the information in a net list file that is used to automatically generate a harness design.

Assigning terminals consists of two steps:

- Assigning a component name and terminal name.
- Selecting a circular edge for the terminal.

Assigning a component name and terminal

When you click Assign Terminals, the Assign Terminals dialog box is displayed.

To assign a component name, type the name in the Component Name Field.

After assigning a component name, click New, and type a terminal name in the Name field. The terminal name is an attribute that is applied directly to geometry in the part file.

Selecting a circular edge for the terminal

After assigning a terminal name, click the Status field for the terminal, then click Set, and then, in the graphic window click a circular edge you want to assign the terminal to. When you click the circular edge, a balloon containing the name of the terminal is connected to the center point of the circular edge.

A part can contain only one component, but a component can have multiple terminals.

To assign multiple terminals, click New and repeat the process for creating a terminal. Once you finish adding the terminals, click OK to finish the command.

When assigning terminals, you can apply multiple terminals (A) to a single circular edge (B).
If the circular edge used to define the terminal is deleted or becomes elliptical on a recompute, the status of the terminal name in Assign Components dialog box becomes Not Set.

Displaying balloons

A terminal balloon is displayed only when you are working in the Assign Terminals command. When you click OK to finish the command, the balloon is automatically hidden. Like other 2-D objects, you can highlight, select, and edit the properties for the balloon.

You can highlight a balloon when the Set button on the Assign Terminals dialog box is disabled. You can also highlight a balloon that you want to edit if the Set button is enabled. However, you cannot highlight a balloon when attempting to set a terminal after you click the Set button. When you highlight a balloon in the graphic window, it is displayed in the Highlight color and the Assign Terminals dialog box displays a box around the row for the terminal.

When you select the balloon, it is displayed in the Select color and the Assign Terminals dialog box highlights the row for the terminal.

Editing balloons

When you select a balloon, a command bar is displayed that allows you to edit the balloon. You can do such things as add or remove a leader and break lines to the balloon, add a prefix or suffix to the balloon, and change the text, shape and size of
the balloon. If you change the text of the balloon, the terminal name on the dialog box is updated to reflect the change.

You cannot delete a balloon directly. If you want to delete the balloon, highlight the row on the Assign Terminals dialog box and click Delete. Be aware that this deletes the terminal attribute along with the balloon.

**Assign Terminals dialog box**

**Component Name**
Specifications the name of the component containing the terminals being assigned. This is the name that the Harness Wizard will match against the components file to find components in the harness assembly model. It is also the name that will be used for Harness output reports to describe wire and cable terminations.

**Terminals**
Displays the name and status for the terminals being assigned.

**New**
Adds a new row to the Terminals table.

**Delete**
Deletes the selected row from the Terminals table.

**Set**
Allows you to select a circular edge to assign to the terminal. The button is not enabled until you click Enter or click outside the field you are editing. When you click the Set button, you can select a circular edge in the graphics window.

**Clear All**
Deletes the component name and the information from all rows in the Terminals table.

**Assign component and terminal names**

2. On the Assign Terminals Dialog Box, type a name in the Component Name field.
3. Click the New button.
4. Type a terminal name in the Name field.
5. Click the row containing the terminal
6. Click the Set button.
7. In the graphic window, click a circular edge to assign the terminal to.
8. Click the OK button.

**Tip**

- A file can contain only one component.
• A component can contain multiple terminals and you can assign multiple terminals to a single circular edge.

• You can use the Clear All button to remove the component name and all terminal information from the Assign Terminals dialog box.

Command

Assign Terminals command

Harness Design command
Displays the Wire Harness user interface so you can create wire harnesses. To return to the Assembly environment, click the Close Harness button.

If the active document is a Family of Assemblies or Alternate Positions assembly, this command is disabled.

Properties command (Harness Design)
Displays the Properties dialog box, so you can edit the properties or create custom properties for the selected wire harness component.

Properties Dialog Box (Harness Design)

Material
Specifies the material for the harness conductor.

General Properties
Displays property information about the selected wire harness element. For example, if you select a wire, the drop-down menu will list all of the wires found in the SEConductors.txt file.

Custom
Displays the Custom Attributes dialog box which allows you to add custom attributes to a wire, cable, or bundle.

Pre-Defined Properties
Use Default Values
Specifies how you want to define the values for the pre-defined property options. If you select this option, the default value defined on the Harness tab of the Options dialog box is used. If you de-select this option, you can type values for these options.

Slack
Specifies the percentage of slack you want to add to the true length of the harness element when computing the cut length.

Added Length
Specifies the fixed amount of slack you want to add to the true length of the harness element when computing the cut length.
Lesson 3  Wire harness design workflow

Clearance Through Holes
Specifies the percentage to be used when computing the clearance between the harness element and any holes through which it passes. The default is 20 percent, which means the hole diameter must be 1.2 times the harness element diameter.

Clearance Through Bundles
Specifies the percentage to be used when computing the clearance between the bundle and the harness elements making up the bundle. The default is 10 percent, which means the inside diameter of the bundle must be 1.1 times the sum of the diameters of the harness elements.

Computed Properties
True Length
Displays the actual length of the harness element, with no compensation for slack.

Cut Length
Displays the cut length of the harness element, which is computed by taking the true length of the harness element and adding any slack compensation, based on the Percentage and Fixed Amount values.

The calculated cut length of a cable is based on the wires it contains. If the cable contains no wires, the cut length is the same as the path length. If the cable contains wires, the cut length is based on the longest wire it contains, including the slack compensation.

Mass
Displays the mass for the harness element, which is computed by multiplying the cut length by the element’s linear density.

Custom Attributes Dialog Box
Allows you to add or remove custom properties from a wire harness definition.

Name
Specifies the name of the property that you want to add or delete.

Type
Specifies the type for the property. The property type can be:
• Double
• Integer
• String

Add
Adds a property to the wire definition. To add a custom property, type the property name in the Name field, select the property type from the Type list, and then click the Add button.

Remove
Deletes a property from the wire definition. To remove a custom property, select the property in the list of properties and click the Remove button.
Property List
Displays a list of custom properties and the type for each property.

Edit Definition command (Wire Harness)
Edits the path or property definition of the selected wire harness conductor.

Edit Definition command bar
Main Steps
Path Step
Defines the path along which the conductor runs.

Properties Step
Selects the properties used to define the conductor.

Preview/Finish/Cancel
This button changes function as you move through the feature construction process. The Preview button shows what the constructed feature will look like, based on the input provided in the other steps. The Finish button constructs the feature. After previewing or finishing the feature, you can edit it by re-selecting the appropriate step on the command bar. The Cancel button discards all input and exits the command.

Path Step Options
Create Path
Specifies that a new path will be created for the wire to follow.

Use Existing Path
Specifies that the wire will follow an existing path.

Path Tangency
Adjusts the endpoints of the path to control tangency.

Create Path Options
Activate Part
Activates a part for selection by fully loading it into memory and making it editable.

Redefine Points
Allows you to redefine the location of an existing point you select. You can use the Relative/Absolute option on the command bar to redefine its position relative to its current position or with respect to its absolute position in the document. You can type a new coordinate in the X, Y, or Z boxes, select a keypoint, click a point in space.

Deselect (x)
Clears the selection.

Accept (check mark)
Accepts the selection.
Use Existing Path Options
   Select
      Sets the method of selecting the path the wire should follow.
      • Single—Allows you to select one or more individual path.
      • Chain—Allows you to select an endpoint connected set of paths.

   Deselect (x)
      Clears the selection.

   Accept (check mark)
      Accepts the selection.

Set Tangency Options
   Activate Part
      Activates a part for selection by fully loading it into memory and making it editable.

   Start
      Specifies the end condition for the start end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

   End
      Specifies the end condition for the finish end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

   Deselect (x)
      Clears the selection.

   Accept (check mark)
      Accepts the selection.

Property Step Options
   Material
      Specifies the material for the wire.

   Properties
      Displays the Properties dialog box that allows you to make changes to the properties for the wire.

Other command bar Options
   Name
      Displays the feature name. Feature names are assigned automatically. You can edit the name by typing a new name in the box on the command bar or by selecting the feature and using the Rename command on the shortcut menu.
Edit the definition of a wire harness conductor

1. In Assembly PathFinder in the Harness Design environment, right click the conductor you want to edit.

2. On the shortcut menu, click Edit Definition.

3. Do one of the following:
   - If you want to edit the conductor properties, click the Properties Step button on the command bar to display additional options. You can use these options to make changes to the path used to construct the conductor.
   - If you want to edit the conductor path, click the Path Step button on the command bar to display additional options. You can use these options to edit the conductor properties.

4. On the command bar, click Finish.

Path Command

Creates a path along which you can place a wire, cable, bundle, or tube.

When creating a path, you can specify a keypoint, a cylindrical axis,
or a point in space.

The path created with this command is displayed in real time. In other words, the path updates as you move the cursor to define the points of the path.

Once a path is created, it is listed beneath the Paths collector in Assembly PathFinder.

Once you add a conductor the path, it is moved from the Paths collector to the appropriate PathFinder collector. For example, if you use the path to create a wire, it is moved from the Paths collector to the Wires collector.

If you delete the conductor containing the path, the entry is moved from the conductor collector back to the Paths collector.

**Redefining Points**

After placing the second point of a path, the Redefine Point button on the command bar is activated which allows you to redefine any points that make up the path.

To redefine a point, click the Redefine Point button and then click the point you want to redefine.
Wire harness design workflow

Next, click the new point.

Click the Accept (checkmark) button to update the path to include the new point.

You can add or remove points from the path to easily control the routing of the path.

**Editing Points on a Path**

You can use the Edit Definition or Edit Path command to move, add, or remove points from the path to easily control the routing of the path.

**Moving Points along a Path**

To move points along a path, while editing the path, click a point, drag it to a new location, and release the mouse button.
Lesson 3  

*Wire harness design workflow*

**Inserting Points to a Path**

You can add new points along a path or add a point in free space to add a new segment to the end of the path.

To add a point along a path, while editing the path, hold the ALT key and click the location along the path where you want to add the point.

To add a point to the end of the path, while editing the path, hold the ALT key and click a location in free space where you want to add the point.

**Removing Points from a Path**

You can remove a point from a path.

To remove a point, while editing the path, hold the ALT key and click the point you want to remove. When you remove edit points, the control vertex points move and the shape of the path changes.

If you remove the start or end point of a path, the path truncates to the next control on the path and the tangency of the next point remains the same.

**Changing Focus Between Paths**

While editing a path, you can change focus to another path without exiting the edit session.

To change focus between paths, while editing a path, click a second path.
The focus changes to the second path and it is ready to edit.

**Edit Path Command**

Edits the selected wire harness path.

**Path command bar**

Main Steps
Select Points Step
Defines the points used to create the path.

End Conditions Step
Specifies the end conditions for the path.

Preview/Finish/Cancel
This button changes function as you move through the feature construction process. The Preview button shows what the constructed feature will look like, based on the input provided in the other steps. The Finish button constructs the feature. After previewing or finishing the feature, you can edit it by re-selecting the appropriate step on the command bar. The Cancel button discards all input and exits the command.

Activate Part
Activates the selected part.
Selecting a Point Options
Circular Cutout Locate
Allows you to select a circular face on a cutout through which the path can pass.

When using this option, the direction of the path changes based on the side of the cylindrical face that you select. For the start end of the path, you should select the bottom end of the cutout with respect to the path. For the stop end of the path, you select the top end of the cutout with respect to the path.

Keypoint Locate
Allows you to select keypoints through which the path can pass.

Redefine Point
Allows you to redefine the location of an existing point you select. You can use the Relative/Absolute option on the command bar to redefine its position relative to its current position or with respect to its absolute position in the document. You can type a new coordinate in the X, Y, or Z boxes, select a keypoint, or click a point in space.

Keypoints
Sets the type of keypoint on existing geometry you can select to define the path.

1. Selects any keypoint.
2. Selects an end point.
3. Selects a midpoint.
4. Selects the center point of a circle or arc.

Relative/Absolute Position
Specifies whether the value you type is relative to the point’s current position or is based on the global origin of the document. The global origin is the point where the three default reference planes intersect (the exact center of the design space).
X
Sets the position for the x axis.

Y
Sets the position for the y axis.

Z
Sets the position for the z axis.

Deselect (x)
Clears the selection.

Accept (check mark)
Accepts the selection.

End Conditions Options
Start
Specifies the end condition for the start end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. You can define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

End
Specifies the end condition for the finish end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. You can define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

Other command bar Options
Name
Displays the feature name. Feature names are assigned automatically. You can edit the name by typing a new name in the box on the command bar or by selecting the feature and using the Rename command on the shortcut menu.

Edit the path of a wire harness conductor

1. In Assembly PathFinder in the Harness Design environment, right click the conductor you want to edit.

2. On the shortcut menu, click Edit Path.

3. Do one of the following:
   • If you want to edit the conductor properties, click the Properties Step button on the command bar to display additional options. You can use these options to edit the conductor properties.
   • If you want to edit the conductor path, click the Path Step button on the command bar to display additional options. You can use these options to make changes to the path used to construct the conductor.

4. On the command bar, click Finish.
Harness Reports Command

Retrieves and displays lists of the components or connections contained in a wire harness.

Harness Reports Dialog Box

Retrieves and displays information for wire harnesses in the assembly document. Use the Format button to define the report format.

You can display the Report Output dialog box by clicking the OK button.

Note: The actual report output dialog box name is based on the report type you select and the assembly document name.

Components
Specifies that you want the report to display information about components connected to the wire harness. If the component is not used by the wire harness it is not displayed in the report.

Connections
Specifies that you want the report to display information about wires, cables, and bundles in the assembly file.

Among
Defines which components or connections you want to include in the report:
- All components or connections in the assembly
- Components or connections currently selected
- Components or connections currently shown

Format
Displays the Format Report dialog box for the report type you specified.

Create a Harness Report

Step 1: In Harness Design, on the Tools menu, click Harness Reports.

Step 2: On the Harness Reports dialog box, specify which components (or connections) you want to include in the report. You can include all components (or connections) in the assembly, only the components (or connections) you have selected, or only the components (or connections) that are displayed.

Note: To create a report on selected components (or connections), you must select them before selecting the Harness Reports command.

Step 3: Click the Format button.

Step 4: On the <Report Type> Format dialog box, select the formatting options you want. For example, you can choose a font, set the justification, or display a grid around the report.
Step 5: Click the OK button. A report output dialog box is displayed. The dialog box title is based on the report type and document name.

Step 6: On the report output dialog box, select the output option you want. For example, you can print the report, save the report as a document, copy the report to the Clipboard, or create a new report.

Tip You can add and remove column titles based on available properties using the Options button on the Format Report dialog box.

Show All Paths command
Displays all wire paths.

Note In PathFinderl, you can use the Show and Hide commands on the shortcut menu to display or hide an individual wire paths.

Construct a path through selected keypoints
1. Choose Home tab→Paths group→Path button.

2. Specify the points you want to use to define the path and then click the Accept (checkmark) button on the command bar.

3. Using the options on the command bar, define conditions for the endpoints on the path.

4. On the command bar, click the Preview button.

5. On the command bar, click the Finish button.

Tip
- You can construct the path using keypoints on existing elements, a cylindrical axis, or points in free space.
- You can use the Edit Definition and Edit Path commands to move points on the path, add points to the path, or remove points from the path.

Wire command
Defines attributes for a wire.
Workflow for creating wires

Using the Wire command to create a wire consists of two steps:

• Defining the wire path.

• Applying properties to the wire.

Defining the wire path

When you select the Wire command, the Wire command bar is displayed in the Path step.

When defining the wire path, you may define points to create a new path or select an existing path, created with the Path command.
When creating the 3-D path, you can specify a key point,

a cylindrical axis,
or a point in space.
By default, the Circular Cutout option is selected on the command bar. When using this option, be aware that the direction of the path changes based on the side of the cylindrical face that you select.

Note Once you define the first point, the Relative/Absolute Position option becomes active to allow you to specify if a point is relative to the point’s current position or is based on the global origin of the document.

When defining points for the path, you can switch between the Circular Cutout and the Keypoint Locate options.
Continue to use these options to define the points for the path.

After defining the final point, click the Accept (checkmark) button to complete the path definition.

Applying properties to the wire
Once you finish defining the path, the command bar moves to the Properties step.
You can select the Material property from a list that contains values found in the wires portion of the SEConductors.txt file located in the Solid Edge Program folder. You can also click the Properties button to display the Properties dialog box, which
Wire harness design workflow

allows you to change the properties for the wire. For pre-defined properties such as Slack and Clearance Through Holes, you can use the default values that are specified on the Harness tab of the Options dialog box, or you can type in a value. After defining the properties for the wire, click the Preview button to accept the input and move to the Finish step where the default wire name is displayed. At this point you can change the wire name, return to the previous step to make changes, or click Finish to complete the command.

After creating the wire, it is listed in Assembly PathFinder in the Wires section.

Wire command bar

Main Steps
Return
Returns you to the Assembly environment.
Path Step
Defines the path along which the wire runs. You can define a new path or select an existing path created with the Path command.
Path Tangency
Adjusts the endpoints of the path to control tangency.
Properties Step
Defines the properties for the wire.
Preview/Finish/Cancel
This button changes function as you move through the feature construction process. The Preview button shows what the constructed feature will look like, based on the input provided in the other steps. The Finish button constructs the feature. After previewing the feature, you can edit it by re-selecting the appropriate step on the command bar. The Cancel button discards all input and exits the command.
Lesson 3  Wire harness design workflow

Path Step Options

Create Path
Specifies that a new path will be created for the wire to follow.

Use Existing Path
Specifies that the wire will follow an existing path.

Activate Part
Activates an inactive part for selection by fully loading it into memory and making it editable.

Circular Cutout Locate
Allows you to select a cylindrical face on a cutout through which the path can run.

Keypoint Locate
Allows you to select keypoints through which the path can run.

Redefine Point
Allows you to redefine the location of an existing point you select. You can use the Relative/Absolute option on the command bar to redefine its position relative to its current position or with respect to its absolute position in the document. You can type a new coordinate in the X, Y, or Z boxes, select a keypoint, click a point in space.

Keypoints
Sets the type of keypoint on existing geometry you can select when defining the path.

- Allows you to select any keypoint.
- Allows you to select an x,y,z point in free space.
- Allows you to select an end point.
- Allows you to select a midpoint.
- Allows you to select the center point of a circle or arc.

Relative/Absolute Position
Specifies whether the value you type is relative to the point’s current position or is based on the global origin of the document. The global origin is the point where the three default reference planes intersect (the exact center of the design space).

X
Sets the position for the x axis.

Y
Sets the position for the y axis.

Z
Sets the position for the z axis.
Deselect (x)  
Clears the selection.  
Accept (checkmark)  
Accepts the selection.

Setting Tangency Options
  Start  
Specifies the end condition for the start end of the curve. You can specify whether or not the start point of the curve is tangent to the element used to define the keypoint, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse, or you can type a value.  
End  
Specifies the end condition for the finish end of the curve. You can specify whether or not the end point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

Selecting an Existing Path
  Select  
Sets the method of selecting the path the wire should follow.  
  • Single—Allows you to select one or more individual paths.  
  • Chain—Allows you to select an endpoint connected set of paths.

Property Step Options
  Material  
Specifies the material for the wire.  
  Properties  
Displays the Properties dialog box that allows you to make changes to the properties for the wire.

Other command bar Options
  Name  
Displays the feature name. Feature names are assigned automatically. You can edit the name by typing a new name in the box on the command bar or by selecting the feature and using the Rename command on the shortcut menu.

Show All Wires command
Displays all wires.  
Note In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual wire.

Hide All Wires command
Hides all wires.
Lesson 3  
**Wire harness design workflow**

**Note**  In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual wire.

**Wire Properties Command**
Displays the Wire Properties dialog box.
- **File Name**
  - Specifies the file name for the wire.
- **Maximum Bend Radius**
  - Specifies the maximum bend radius value for the wire you are constructing.
- **Minimum Straight Length**
  - Specifies the maximum length of the wire that remains after fillets are automatically applied to sharp path corners.

**Display Properties for a Harness Element**

**Step 1:**  Click the right mouse button on a wire, cable, or bundle.

**Step 2:**  On the shortcut menu, click Properties.

**Create a wire**
When creating a wire, there are two workflows for defining the path that the wire follows. The wire can be created along:
- a new path you define.
- an exiting path.

**To create a wire along a new path you define:**

1. Choose Home tab→Harness group→Wire [ ]

2. Specify the keypoints or points in space you want to use to define the path and then click the Accept (checkmark) button on the command bar.

3. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the wire.

4. On the Properties dialog box, check the property values and make any needed changes.

5. On the Properties dialog box, click the OK button.

6. On the command bar, click the Preview button.

7. On the command bar, click the Finish button.

**Tip**
- You can construct the curve using keypoints on existing elements or points in free space.
To create a wire along an existing path:

1. Choose Home tab→Harness group→Wire.
2. On the Wire command bar, click the Use Existing Path button.
3. Set the method of selection to either Single or Chain.
4. Click the path near the end you want to be the starting point.
5. On the command bar, click the Accept (checkmark) button.
6. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the wire.
7. On the Properties dialog box, check the property values and make any needed changes.
8. On the Properties dialog box, click the OK button.
9. On the command bar, click the Preview button.
10. On the command bar, click the Finish button.

Cable command

Defines attributes for a cable that consists of a collection of wires created along a 3-D path.

When defining the cable path, you may select an existing path or define points to create a new path.

Workflow for creating cables

The workflow used by the Cable command to create a cable consists of three steps:

1. Collecting the wires to be included in the cable.
2. Defining the cable path.
3. Applying properties to the cable.
Lesson 3  Wire harness design workflow

Collecting wires to be included in the cable

When you select the Cable command, the Cable command bar is displayed in the Conductor step. This step allows you to select the attributed wires you want to include in the cable. The point that you click specifies the starting point for the cable.

![Image](image1.png)

Note: You can click the Create Path button without selecting any wires to create a cable that does not contain wires. Later, you can edit the cable to include wires.

Defining the cable path

After selecting the wires to include, click the Accept (checkmark) button to accept the input and move to the Path step.

When defining the path, you can click points to create the path,

![Image](image2.png)

or you can select an existing path created with the Path command.

![Image](image3.png)

Applying properties to the cable

Once you accept the path, the command bar moves to the Properties step.

You can select the Material property from a list that contains values found in the cables portion of the SEConductors.txt file located in the Solid Edge Program folder.

You can also click the Properties button to display the Properties dialog box, which allows you to change the properties for the cable. For pre-defined properties such as Slack and Clearance Through Holes, you can use the default values that are specified on the Harness tab of the Options dialog box, or you can type in a value.

After defining the properties for the cable, click the Preview button to accept the input and move to the Finish step where the default cable name is displayed. At this
point you can change the cable name, return to the previous step to make changes, or click Finish to complete the command.

After creating the cable, any wires included in the collection used to create the cable are listed in Assembly PathFinder beneath the new cable.

![Diagram showing cable components]

**Editing cables**

After creating a cable, you can make changes to either the path or cable attributes.

The Edit Definition command displays the Edit Definition command bar that allows you to change the wires in the cable, the path or attributes. To access the command, right-click the mouse button on the wire and click Edit Definition on the shortcut menu.

Clicking the Path Step option on the command bar displays additional options that allow you to change the selection of wires included in the cable, redefine the points for the path, select a new path for the wire to follow, and adjust the endpoints to control tangency of the path.

Clicking the Properties Step option displays additional options that allow you to make changes to the attributes associated with the wire.

The **Edit Path command** displays the Edit Path command bar that allows you to change the path. To access the command, right-click the mouse button on the wire and click Edit Path on the shortcut menu.

Clicking the Select Points Step option on the command bar displays additional options that allow you to redefine the points for the path.

Clicking the End Conditions Step option displays additional options that allow you to set the end tangent conditions for the path.

The Delete command deletes the cable, along with any wires and paths used to create the cable. Use the **Remove command** on the Assembly PathFinder shortcut menu to remove only the cable and preserve the cable path and associated wires.
Minimum bend radius and hole diameter clearance

The Cable command follows the same guidelines for checking minimum bend radius and hole diameter clearance as the Wire command. For more information on minimum bend radius violations and hole diameter clearance, see the Wire Command help topic.

Cable command bar

- Dialog Box Options
- Return
  Returns you to the Assembly environment.
- Conductor Step
  Selects the conductors to be included in the cable.
- Path Step
  Defines the path along which the cable runs.
- Properties Step
  Selects the properties used to define the cable.
- Preview/Finish/Cancel
  This button changes function as you move through the feature construction process. The Preview button shows what the constructed feature will look like, based on the input provided in the other steps. The Finish button constructs the feature. After previewing or finishing the feature, you can edit it by re-selecting the appropriate step on the command bar. The Cancel button discards all input and exits the command.

Path Step Options
- Create Path
  Specifies that a new path will be created for the cable to follow.
- Use Existing Path
  Specifies that the cable will follow an existing path.
- Path Tangency
  Adjusts the endpoints of the path to control tangency.
- Activate Part
  Activates a part for selection by fully loading it into memory and making it editable.
- Circular Cutout Locate
  Allows you to select a cylindrical face on a cutout through which the path can run.
- Keypoint Locate
  Allows you to select keypoints through which the path can run.
- Redefine Point
  Allows you to redefine the location of an existing point you select. You can use the Relative/Absolute option on the command bar to redefine its position relative to its current position or with respect to its absolute position in the document.
You can type a new coordinate in the X, Y, or Z boxes, select a keypoint, click a point in space.

**Keypoints**
Sets the type of keypoint on existing geometry you can select when defining the path.

- ![Keypoint](image)
  - Allows you to select any keypoint.
- ![Keypoint](image)
  - Allows you to select an x,y,z point in free space.
- ![Keypoint](image)
  - Allows you to select an end point.
- ![Keypoint](image)
  - Allows you to select a midpoint.
- ![Keypoint](image)
  - Allows you to select the center point of a circle or arc.

**Relative/Absolute Position**
Specifies whether the value you type is relative to the point’s current position or is based on the global origin of the document. The global origin is the point where the three default reference planes intersect (the exact center of the design space).

**X**
Sets the position for the x axis.

**Y**
Sets the position for the y axis.

**Z**
Sets the position for the z axis.

**Deselect (x)**
Clears the selection.

**Accept (check mark)**
Accepts the selection.

**Selecting an Existing Path**
Select
Sets the method of selecting the path the cable should follow.

- Single—Allows you to select one or more individual paths.
- Chain—Allows you to select an endpoint connected set of paths.

**Setting Tangency Options**
**Start**
Specifies the end condition for the start end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

**End**
Specifies the end condition for the finish end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select,
and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

Setting Wire Properties

Material
Specifies the material for the cable.

Properties
Displays the Properties dialog box that allows you to make changes to the properties for the cable.

Other command bar Options

Name
Displays the feature name. Feature names are assigned automatically. You can edit the name by typing a new name in the box on the command bar or by selecting the feature and using the Rename command on the shortcut menu.

Create a cable

When creating a cable, there are two workflows for defining the path that the cable follows. The cable can be created along:

- a new path you define.
- an existing path.

To create a cable path you define:

1. Choose Home tab→Harness group→Cable.
2. Click an endpoint on the wires you want to include in the cable and then click the Accept (checkmark) button on the command bar. The endpoint that you click defines the starting point for the cable.
3. Specify the points you want to use to define the path and then click the Accept (checkmark) button on the command bar.
4. Using the options on the command bar, define conditions for the endpoints on the path.

5. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the cable.

6. On the Properties dialog box, check the property values and make any needed changes.

7. On the Properties dialog box, click the OK button.

8. On the command bar, click the Preview button.

9. On the command bar, click the Finish button.

- **Tip**
  - You can construct the curve using keypoints on existing elements or points in free space.
  - The Delete command deletes the cable, along with any wires and paths used to create the cable. Use the Remove command on the Assembly PathFinder shortcut menu to remove only the cable and preserve the cable path and associated wires.

**To create a cable along an existing path:**

1. Choose Home tab→Harness group→Cable.

2. Click an endpoint on the wires you want to include in the cable and then click the Accept (checkmark) button on the command bar. The endpoint that you click defines the starting point for the cable.

3. On the Cable command bar, click the Use Existing Path button.

4. Set the method of selection to either Single or Chain.
5. Click an existing path for the cable to follow.

6. On the command bar, click the Accept (checkmark) button.

7. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the cable.

8. On the Properties dialog box, check the property values and make any needed changes.

9. On the Properties dialog box, click the OK button.

10. On the command bar, click the Preview button.

11. On the command bar, click the Finish button.

Show All Cables command
Displays all cables.

Note On PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual cable.

Hide All Cables command
Hides all wire cables.

Note In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual cable.

Bundle command
Creates a harness bundle from a set of wires and cables. The result is a single path that can be created across several components within the harness assembly.
**Bundle command bar**

Return
Returns you to the Assembly environment.

Conductor Step
Selects the conductors to be included in the bundle.

Path Step
Defines the path along which the bundle runs.

Path Tangency
Adjusts the endpoints of the path to control tangency.

Properties Step
Selects the properties used to define the bundle.

Preview/Finish/Cancel
This button changes function as you move through the feature construction process. The Preview button shows what the constructed feature will look like, based on the input provided in the other steps. The Finish button constructs the feature. After previewing or finishing the feature, you can edit it by re-selecting the appropriate step on the command bar. The Cancel button discards all input and exits the command.

Path Step Options
Create Path
Specifies that a new path will be created for the bundle to follow.

Use Existing Path
Specifies that the bundle will follow an existing path.

Path Tangency
Adjusts the endpoints of the path to control tangency.

Activate Part
Activates a part for selection by fully loading it into memory and making it editable.
Circular Cutout Locate
Allows you to select a cylindrical face on a cutout through which the path can run.

Keypoint Locate
Allows you to select keypoints through which the path can run.

Redefine Point
Allows you to redefine the location of an existing point you select. You can use the Relative/Absolute option on the command bar to redefine its position relative to its current position or with respect to its absolute position in the document. You can type a new coordinate in the X, Y, or Z boxes, select a keypoint, click a point in space.

Keypoints
Sets the type of keypoint on existing geometry you can select when defining the path.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Allows you to select any keypoint.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to select an x,y,z point in free space.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to select an end point.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to select a midpoint.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to select the center point of a circle or arc.</td>
</tr>
</tbody>
</table>

Relative/Absolute Position
Specifies whether the value you type is relative to the point’s current position or is based on the global origin of the document. The global origin is the point where the three default reference planes intersect (the exact center of the design space).

X
Sets the position for the x axis.

Y
Sets the position for the y axis.

Z
Sets the position for the z axis.

Deselect (x)
Clears the selection.

Accept (check mark)
Accepts the selection.

Selecting an Existing Path
Select
Sets the method of selecting the path the bundle should follow.
- **Single**—Allows you to select one or more individual paths.
- **Chain**—Allows you to select an endpoint connected set of paths.
Setting Tangency Options

Start
Specifies the end condition for the start end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

End
Specifies the end condition for the finish end of the curve. You can specify whether or not the start point of the curve is tangent to an element you select, and the length of the tangent vector. Define the length of the tangent vector by dragging the tangent vector handle using the mouse or you can type a value.

Setting Bundle Properties

Material
Specifies the material for the bundle.

Properties
Displays the Properties dialog box that allows you to make changes to the properties for the bundle.

Other command bar Options

Name
Displays the feature name. Feature names are assigned automatically. You can edit the name by typing a new name in the box on the command bar or by selecting the feature and using the Rename command on the shortcut menu.

Show All Bundles command
Displays all wire bundles.

Note In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual wire bundle.

Hide All Bundles command
Hides all wire bundles.

Note In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual bundle.

Create a wire harness bundle

When creating a bundle, there are two workflows for defining the path that the wire harness bundle follows. The bundle can be created along:

- a new path you define.
- an existing path.

To create a bundle along a path you define:

1. Choose Home tab→Harness group→Bundle
2. Click an endpoint on the conductors (wires or cables) you want to include in the bundle and then click the Accept (checkmark) button on the command bar. The endpoint that you click defines the starting point for the bundle.

3. Specify the points you want to use to define the path and then click the Accept (checkmark) button on the command bar.

4. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the bundle.

5. On the Properties dialog box, check the property values and make any needed changes.

6. On the Properties dialog box, click the OK button.

7. On the command bar, click the Preview button.

8. On the command bar, click the Finish button.
Tip

- You can construct the path using keypoints on existing elements or points in free space.

To create a bundle along an existing path:

1. Choose Home tab→Harness group→Bundle

2. On the Bundle command bar, click the Use Existing Path button.

3. Click an endpoint on the conductors (wires or cables) you want to include in the bundle and then click the Accept (checkmark) button on the command bar. The endpoint that you click defines the starting point for the bundle.

4. Set the method of selection to either Single or Chain.

5. Click an existing path for the bundle to follow.
6. On the command bar, click the Properties button to display the Properties dialog box, which allows you to set the properties for the bundle.

7. On the Properties dialog box, check the property values and make any needed changes.

8. On the Properties dialog box, click the OK button.

9. On the command bar, click the Preview button.

10. On the command bar, click the Finish button.

---

**Display Harness Elements**

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display all harnesses.</td>
<td>On the shortcut menu, point to Show All, then click Harnesses.</td>
</tr>
<tr>
<td>Turn off the display of all</td>
<td>On the shortcut menu, point to Hide All, then click Harnesses.</td>
</tr>
<tr>
<td>harnesses. Display all bundles.</td>
<td>On the shortcut menu, point to Show All, then click Bundles.</td>
</tr>
<tr>
<td>Turn off the display of all</td>
<td>On the shortcut menu, point to Hide All, then click Bundles.</td>
</tr>
<tr>
<td>bundles. Display all cables.</td>
<td>On the shortcut menu, point to Show All, then click Cables.</td>
</tr>
</tbody>
</table>
Creating wire harness solid bodies

You can use the Create Physical Conductor command to create a solid body of the wires, cables, and bundles that make up the harness design. This is useful when you need a rendering or detailed drawing of your harness design,

To access the command, right-click on a conductor in PathFinder. The solid body that is created is only for the selected conductor. In other words, if you select a cable, the command does not create solid bodies for the wires contained in the cable. You can right-click on the Harness node in Assembly PathFinder to create all of the solids at once. The solid bodies are embedded in the assembly and no new documents are added to the assembly.

Note: Any paths found in the harness design that do not contain attributes will not be included in the creation of the solid body.

When you create a solid body for a conductor, the symbol adjacent to the conductor in PathFinder is updated to indicate that a solid body has been created for the conductor.
Lesson 3  Wire harness design workflow

**Note** To select multiple conductors, you can hold down the Ctrl key, and then click the conductors you want. To select a list of conductors, click on the first conductor in the list, hold down the Shift key, and then click the last conductor in the list.

After you create a solid body for a conductor, additional shortcut menu commands are available to manipulate the solid bodies.

You can use the Show Physical Conductor and Hide Physical Conductor commands to control the display of the solid bodies. The solid body is automatically shown on creation, so you can use the Hide Physical Conductor command to conceal the newly created body. Changes made to the display of the physical body do not affect the display state of the conductor used to create the body.

You can use the Delete Physical Conductor command to delete the solid body without deleting the conductor.

**Create Physical Conductor command**

Creates a 3-D representation of a conductor.

When selecting the conductors to include, you can select a single conductor or multiple conductors. To select multiple conductors, you can hold down the CTRL key, and then click the conductors you want. To select a list of conductors, click on the first element in the list, hold down the SHIFT key, and then click the last conductor in the list.

**Create a Wire Harness Solid Body**

**Step 1:** In Pathfinder, right-click the wire harness component you want to use to create the solid body to display the shortcut menu.

**Step 2:** On the shortcut menu, click Create Physical Conductor.

**Tip**

- The wire harness component can be a wire, cable, or bundle.
- You can use the Show Physical Conductor and Hide Physical Conductor commands to control the display of the solid body.
- You can use the Delete Physical Conductor command to delete the solid body.

**Delete Physical Conductor Command**

Deletes the 3-D representation of the conductor, but leaves the wire path.

When selecting the conductors to delete, you can select a single conductor or multiple conductors. To select multiple conductors, you can hold down the CTRL key, and then click the elements you want. To select a list of conductors, click on the first element in the list, hold down the SHIFT key, and then click the last element in the list.
**Show Physical Conductor Command**
Displays the selected physical conductor.

**Show All Physical Conductors command**
Displays all physical conductors.

*Note* In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual physical conductor.

**Removing conductors**
You can use the **Remove command** to remove a conductor from its parent. To access the command, right-click the mouse button on a conductor and on the shortcut menu, click Remove.

When you remove a conductor from a higher level object, it is removed from the definition of all higher level objects. The existing to and from points of the conductor are maintained. The path segment(s) shared between the selected conductor and its higher level is removed from the conductor's definition. A new segment is generated to replace the segment that was removed.

**Hide Physical Conductor Command**
Hides the selected physical conductor.

**Hide All Physical Conductors command**
Hides all physical conductors.

*Note* In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual physical conductor.

**Delete a Wire Harness Solid Body**

**Step 1:** In PathFinder, right-click the harness element containing the solid body.

**Step 2:** On the shortcut menu, click Delete Physical Conductor.

*Tip*
- Deleting the solid body does not delete the wire path.

**Show All Harnesses command**
Displays all wire harnesses.

*Note* In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual wire harness.

**Hide All Harnesses command**
Hides all wire harnesses.

*Note* In PathFinder, you can use the Show and Hide commands on the shortcut menu to display or hide an individual harness.
Remove command (Harness Design)

Detaches the selected wire harness component from its parent.

Outputting wire harnesses to other formats

You can use the Save As ECAD command to save your wire harness component and connection information so that it can be used by other ECAD software systems. You can export the information to ECAD system-specific format or to .XML format.

Note: The command will only export information for conductors that have been attributed. Any paths that do not contain attributes will not be included in the file.

When you select the command, the Save As ECAD dialog box is displayed. You can use this dialog box to specify the format to which you want to save the information. You can also specify the name, location, and format of the components and connections files.

The components file contains information about the components in the wire harness such as the unique id, component name, and component description. You can save the components file to .CMP or .CMP_XML format.

The connection file contains information about the connections in the wire harness such as the wire id, from component id, and the to component id. You can save the components file to .CON or .CON_XML format.

Save As ECAD Command

Saves the wire harness component and connection information so that it can be imported into an ECAD system. You can save the component information to .CMP or CMP_XML format. You can save then connect information to .CON or .CON_XML format.

Save As ECAD dialog box

Save As (Components or Connections) dialog box

Save As ECAD Dialog Box

  Document Format
  Specifies the export format for the document.

  Component Document
  Displays the location and name for the component document. You can click the Save As button to display the Save as Components dialog box, which allows you to specify the location and document name. You can save the document to .CMP or .CMP_XML format.

  Connection Document
  Displays the location and name for the connection document. You can click the Save As button to display the Save as Connections dialog box, which allows you to specify the location and document name. You can save the document to .CON or .CON_XML format.
Save As (Components or Connections) dialog box

Specifies the name and folder information for the component (*.CMP or .CMP_XML or connection (*.CON or .CON_XML) being saved.

Save In
Specifies the folder to which you want to save the document. The system stores the last location you browsed in the Save In box.

Go to Last Folder Visited
Returns to the last folder that you visited.

Up One Level
Accesses the parent folder.

Create New Folder
Creates a new folder named "New Folder" in the list and places you in in-place editing mode, so that you can rename the folder.

View Menu
Controls the display method for the listed documents.

  Large Icons
  Displays large icons for the documents.

  Small Icons
  Displays small icons for the documents.

  List
  Lists the names of the documents in columns.

  Details
  Displays a detailed view of the folder contents. The columns displayed include Name, Size, Type, and Modified.

  Thumbnails
  Displays thumbnails for the documents.

File Name
Specifies the name of the document.

Save As Type
Specifies which document type you want to use to save the document. In addition to the default format, you can also save the component and connection information to .XML format.

Save Component and Connection Information to ECAD Format

1. On the Application menu, point to Save As, then choose Save As ECAD.

2. In the Document Format box, select the document format you want to use.

3. In the Component Document box, specify a name for the component document.

4. In the Connection Document box, specify a name for the connection document.
Tip You can click Save As to specify the name, location, and format for the component and connection documents.

**PathFinder in harness design**

As you create paths and conductors, they are added to PathFinder.
If you move the cursor over a conductor in PathFinder, all occurrences of the conductor are outlined with a red box,

and they are highlighted in the graphics window.
Lesson 3  

Wire harness design workflow

Notice that the wire you highlighted is displayed in a solid color until the point it becomes part of a cable. At that point, the display becomes a dashed line. Also notice that the color of the dashed line changes at the point the cable and wires become part of a bundle.

If you position the cursor over a cable in PathFinder, all occurrences of the cable are outlined and the cable highlights in a solid color and the bundle containing the cable highlights as a dashed line. Notice that the wires included in the cable do not highlight.

If you position the cursor over a bundle in PathFinder, all occurrences of the bundle are outlined and the bundle highlights in a solid color. Notice that the wires and cables included in the bundle do not highlight.

You can right-click on a conductor in PathFinder to display a list of shortcut commands that allow you to manipulate the conductors.
Working with nailboards

Nailboards document the manufacturing process of wire harnesses by flattening the 3D harness onto a 2D board to create a nailboard drawing view. The flattened geometry is placed at a 1:1 scale and you can edit the geometry to make it properly fit on the board. Once you have the flattened geometry placed correctly, you can print the nailboard view.

From the nailboard drawing view, you can create a connector drawing view based on information associated with the harness. You can then use the information in the connector drawing view to create a connector table.

You can also create a conductor table, also known as a net wire list, which is basically a parts list of the wire harness.

Dimensions, annotations, and blocks in nailboards

Much of the draft functionality, such as dimensions, annotations, and blocks is available when working with nailboards.

You can place driven dimensions on the flattened geometry in a nailboard. However, you cannot edit the dimensions to make changes to the flattened geometry.

You can place annotations, such as callouts, based on all information associated with the flattened geometry.

You can place blocks on a nailboard view and associate it with the flattened geometry. However, you cannot use the nailboard view geometry to create blocks.
Creating nailboard views

You can use the Nailboard View command to flatten the 3D harness onto a 2D nailboard. The nailboard view is a rectangular object that contains linear segments that represent the branches in the harness.

Attributes, such as line length, line color, and line thickness, match the information stored for the harness design.

When placing the nailboard view, you can use the Nailboard Options dialog box to define how the view is placed. You can define such things as the view name, view width and height, and line style and fill style. You can also define the basis for the selection of the main run.

When placed, the flattened geometry is centered on the nailboard rectangle. If the geometry does not fit correctly, you can edit the geometry to fit within the rectangle. You can move the flattened geometry and the nailboard independent of one another. If you reposition the flattened geometry, the nailboard rectangle does not move. However, if you reposition the rectangle, the flattened geometry moves with the rectangle.

Many times an assembly contains disjoint harnesses. For example, the following illustration shows an assembly with two disjoint harnesses, labeled (A) and (B).

When placed in a nailboard view, the harnesses are spaced out vertically.
You can move or edit each disjoint harness independent from the other.

If you edit an assembly and add or subtract disjoint harnesses, the nailboard view changes. If you add a disjoint harness to the assembly, it is added to the nailboard view. If you merge disjoint harnesses in the assembly, they are merged in the nailboard view.

Nailboard View command

Creates a flattened nailboard view of a wire harness.

Note If the drawing view contains conductor with invalid segments, an warning message is displayed in both the nailboard view and conductor tooltips.

Nailboard View command bar

Select Model
Displays the Select Model dialog box.

Drawing View Style Mapping
Specifies that the drawing view uses a predefined style, which is set on the Drawing View Style tab of the Solid Edge Options dialog box.

When the Drawing View Style Mapping button is cleared, you can select and apply individual styles. Choose the style from the Drawing View Style list.

Drawing View Style
Selects a style for the drawing view. This option is not available when Drawing View Style Mapping is enabled.
Lesson 3  

*Wire harness design workflow*

Show Caption
Selects the captions to display for the currently selected drawing view or view annotation, according to the currently selected Drawing View Style.

  - **Show Primary Caption**
    Displays the content defined for the Primary caption in the Caption tab (Drawing View Style dialog box).

  - **Show Secondary Caption**
    Displays the content defined for the Secondary caption in the Caption tab (Drawing View Style dialog box).

You also can choose whether to show the following information, if it is defined in the caption text on the Caption tab (Drawing View Style dialog box) for the currently selected drawing view style:

  - **Show Suffix**
    When a section view, detail view, or auxiliary view is selected, displays the caption suffix.

    The suffix is displayed in the caption when %AS is added to the primary or secondary caption text, and when the View Annotation Name property text code (%VA) is added to the Suffix Property box.

  - **Show Annotation Sheet Number**
    Displays the sheet number of the view annotation—the cutting plane, viewing plane, or detail envelope—when %LN is added to the primary or secondary caption text, and when the appropriate property text string is added to the Annotation Sheet Number (%LN) Property box.

  - **Show View Scale**
    Displays the view scale in the caption when %VS is added to the primary or secondary caption text, and when the appropriate property text string is added to the View Scale (%VS) Property box.

  - **Show Angle of Rotation**
    Displays the view rotation angle in the caption when %VR is added to the primary or secondary caption text, and when the appropriate property text string is added to the Angle of Rotation (%VR) Property box.

**Note**  
Primary captions, secondary captions, and view annotation captions are defined in the Drawing View Style dialog box. To learn how to create captions for selection on the drawing, see these Help topics:

- Define drawing view captions using property text
- Drawing view captions
- Drawing view styles

This option is available when editing a nailboard view.

**Nailboard Properties**
Displays the Nailboard Properties dialog box.
Lock drawing view position
Prevents the selected drawing views from being moved accidentally. When this box is checked, and the drawing view is highlighted, a lock symbol is displayed within the drawing view boundary to indicate its position is fixed.

A locked drawing view still can be moved using explicit commands. To learn more, see Drawing view manipulation.

This option is available when editing a nailboard view.

Nailboard Options dialog box

Main Run
Specifies the basis for the selection of the main run. The main run is based on the top level conductor for the selected element. For example, if you select Wire_1 with the Main Run option set to Longest Conductor, Solid Edge identifies any cables or bundles that contain Wire_1 and uses the top level cable or bundle that contains Wire_1 as the main run.

- Largest Diameter
  Creates the main run for the nailboard view based on the largest wire diameter in the wire harness.

- Longest Conductor
  Creates the main run for the nailboard view based on the length of the longest conductor in the wire harness.

User Selected
Enables the Select Conductor option, which displays the Select Conductor dialog box.

- Select Conductor
  Displays the Select Conductor dialog box.

Board
Specifies information about the nailboard view.
Lesson 3  
*Wire harness design workflow*

Name
Specifies the name of the nailboard view. The name you provide is the caption for %NN property text.

Width
Specifies the width of the nailboard.

Height
Specifies the height of the nailboard.

Line Style
Specifies the rectangular line style for the view border.

Fill Style
Specifies the fill style for the view.

**Select Conductor dialog box**

This window displays the wire harness you select for the nailboard drawing view creation. You can use the view manipulation options in this window to reorient the wire harness before you place the nailboard drawing view. When you finish reorienting the part, click Close to continue with the command.

Shaded with VHL Overlay
Specifies if the view will be simply shaded or shaded with VHL overlay. Using the Shaded with VHL Overlay may decrease your performance when working with large assemblies.

Rotate
Rotates a view freely about one of the following:

- The center of the view
- Any one of three principal axes
- Any edge of the model

**Note** You also can press the Home key to rotate the model to the default isometric view.

Spin About
Rotates a view normal to a face. Spin About is not available for assemblies.

Common Views
Selects one of six principal views or eight isometric views. You can use the arrows on the displayed dialog box to select the view.

Look At Face
Defines a view using any planar face.

Align Edge
Aligns a view to a linear edge. In cases where Look At Face does not align the view the way you want, you can use this option to select a linear edge of the model and specify a new x or y axis.
Zoom Area
Zooms into an area in the window. The two points you place define the view.

Zoom
Reduces or enlarges the display of geometry around a specified point in the window.

Fit
Fits all elements to the window.

Pan
Enables you to move in any direction from a specific point on the model to see other areas of the model.

Perspective
Applies perspective to, or removes perspective from, the view in the Custom Orientation window. A perspective view appears more realistic than an isometric view. When perspective is applied, objects that are farther away appear smaller.

When you select the Perspective option, you can choose a predefined angle from the Perspective Angle list, or you can define a custom perspective angle using Shift+Ctrl while rotating the mouse wheel.

Close
Closes the Custom Orientation window and continues the drawing view creation process.

General tab (Nailboard Drawing View)

Description
Describes a drawing view. You can type any additional notes or documentation you need.

Sheet
Displays the drawing sheet name the drawing view exists on in the document. You can edit this value to move the drawing view to another working sheet in your document.

Using this option is similar to cutting and pasting drawing views to a new working sheet. All dimensions and annotations connected to geometry inside the view also move to the selected sheet.

Nailboard Options
Sets the view options for the nailboard view.

Name
Specifies the name of the nailboard view

Width
Specifies the width of the nailboard.

Height
Specifies the height of the nailboard.

Line Style
Specifies the rectangular line style for the nailboard.
Lesson 3  Wire harness design workflow

Fill Style
Specifies the fill style for the nailboard.

Main Run
Displays the main run defined for the nailboard.

_lock drawing view position
Prevents the selected drawing views from being moved accidentally when dragging the cursor. When this box is checked, and the drawing view is highlighted, a lock symbol is displayed within the drawing view boundary to indicate its position is fixed.

A locked drawing view still can be moved using explicit commands. To learn more, see Drawing view manipulation.

_rotation angle
Specifies the rotation angle of the drawing view. The selected drawing view rotates about its center according to the angle you specify.

When a view is selected, one of these drawing view status messages is displayed at the bottom of the General tab:

- This drawing view is Out-of-Date with respect to the model geometry.
- This drawing view is Up-to-Date with respect to the model geometry.

You can update an out-of-date view using the Update command from the view shortcut menu. You can update all out-of-date views in the drawing using the Home tab→Drawing Views group→Update Views command on the ribbon.

Create a nailboard view

1. Choose Diagram tab→Views group→Nailboard.

2. On the Select Model dialog box, select an assembly document that contains a wire harness.
3. Click Open.

4. On the **Nailboard Options** dialog box set options as needed, and then click OK.

5. Click to place the nailboard view.

**Editing the flattened geometry in the nailboard view**

In some cases, the flattened geometry may not fit inside the boundaries of the drawing view.

In these cases, you can edit the flattened geometry to fit inside the drawing board.

You can use the **Insert Bend command** to create a bend on the flattened geometry so that it fits in the nailboard drawing view. You can define the radius and sweep angle for the bend. Solid Edge inserts the bend based on this information, while maintaining the overall length of the branch.
Lesson 3  
Wire harness design workflow

If you select the main trunk line of the harness, you have four choices for the bend direction,

but only have two choices if your selection is not the main trunk line.

You can use the Flip option on the Insert Bend command bar to flip the direction of the bend.
After placing a bend, you may need to edit it. You can select the bend,

and edit the radius or sweep angle values on the command bar.

**Note** You can also drag the handles to edit the selected bend.
You can rotate the segment by clicking and dragging the segment (A) to fit in the view (B).

**Note** Rotating the segment does not change the overall length of the segment.
**Insert Bend command**

Inserts a bend on the flattened geometry in the nailboard drawing view. Solid Edge inserts the bend by editing the radius and sweep angle, while maintaining the overall length of the branch.

You can use the Flip option on the Insert Bend command bar to flip the direction of the bend.

**Insert Bend command bar**

- **Bend Location Step**
  Specifies a point on a linear element at which you want to place the bend.

- **Radius and Direction Step**
  Specifies the radius and direction for the bend.

- **Radius**
  Specifies the radius for the bend.

- **Sweep**
  Specifies the sweep angle for the bend.
Flip
Flips the direction of the bend.

Insert a bend in a nailboard
1. Choose Diagram tab→Modify group→Insert Bend.

2. Select a point on a linear segment to specify the start point for the bend.

3. Edit the radius or sweep angle or click in the direction you want to bend the segment.
Note If the selection is the main run, you have four choices for the bend direction, but you only have two choices if your selection is not the main run.

4. Click to place the bend.

Note You can use the Flip option on the Insert Bend command bar to flip the direction of the bend.

**Edit a nailboard bend**

1. Select the bend you want to edit.
2. On the command bar, edit the radius or sweep angle for the bend.

3. Click to complete the edit.

**Tip**
- You can also drag the handles to edit the selected bend.

- You can use the Flip option on the Insert Bend command bar to flip the direction of the bend.
Printing nailboard views

As with other drawing views, you can print nailboard views. You can use the Print or Print Drawings commands to print a single nailboard view to a single sheet of paper. However, for larger views that require you to print a single view at a 1:1 scale to multiple sheets in sections, we suggest you save the view to PDF format and print the PDF file. For more information, see the topic Print a nailboard view from Adobe Reader.

Print a nailboard view with Adobe Reader

1. Save the nailboard draft file as Adobe PDF.
2. Open the PDF file in Adobe Reader (version 10 or later).
3. Choose File→Print.
4. On the Print dialog box, do the following:
   a. Select the desired printer and paper size.
   b. In the Paper Size and Handling section, select Poster.
   c. Ensure the scale is set to 100%.
   d. Set the Overlap as desired.
   e. Turn on or off Cut marks, Labels, and Tile only large pages as desired.

Creating connector views

You can use the Connector Drawing View command to place a drawing view of the connector associated with the selected branch of the wire harness. The connector drawing view is a regular drawing view with all drawing view options available. By default, auto caption is on and defaults to the component name. As with other drawing views, you can display and edit drawing view properties for the connector drawing view.
Lesson 3  

*Wire harness design workflow*

When created, the connector view is positioned associatively to the branch used to create the view.

The connector view tracks edits that change the position of the branch and maintains the position relative to the branch.

### Connector Drawing View command

Places a drawing view of the connector associated with a branch of the wire harness.

### Creating connector tables

You can use the **Connector Table command** to create a connector table based on the harness information from the connector drawing view. The harness information includes key attributes such as component name, terminal name, and wire id.

The table contains a default set of columns, which you customize by adding and reordering columns or rows. If you do customize the table, you can use the Save Settings option on the General tab of the Connector Table Properties dialog box to save the customized setting. You can use the Save Settings option on the command bar to select settings you have saved.

The connector table is associative to the connector drawing view and assembly. If the connector part or referenced assembly is updated, the connector table becomes out-of-date. You can use the Update command to update the table.

### Create a connector drawing view

1. Choose Diagram tab→Views group→Connector Drawing View.
2. Select a conductor.
3. Set options on the Drawing View Wizard Options tab as needed, and then click Next.

4. In the Drawing View Wizard, on the Drawing View Orientation tab, do one of the following:
   - Select a named view as the principal view for the drawing, and then click Finish.
   - Click Custom to access the Custom Orientation dialog box. Use the options at the top of the Custom Orientation window to orient the part or assembly, and then click Close.

5. In the Drawing View Wizard, on the Drawing View Layout tab, select any additional views you want to generate, and then click Finish.

6. Use the command bar options to adjust how the view or views are placed on the drawing sheet.
   
   **Note** By default, the scale is always is 1:1.

7. Click to specify the location of the view or views on the sheet.
**Connector Table command**

Uses harness information from the connector drawing view to create a connector table. The table contains a default set of columns, which you can customize by adding and reordering columns or rows. If you customize the table, you can use the Save Settings option on the General tab of the Connector Table Properties dialog box to save the customized setting. You can use the Save Settings option on the command bar to select settings you have saved.

The connector table is associative to the connector drawing view and assembly. If the referenced assembly is updated, the connector table becomes out-of-date. You can use the Update command to update the table.

**Connector Table command bar**

- **Table Style**
  Lists and applies the available table styles.
  See the Help topic, Table styles.
- **Auto-Callout**
  Automatically creates callouts for the selected connector drawing view. By default, Auto-Callout and leaders with breaklines are on. You can edit a callout after placing it. If you chose not to create a callout during the command, you can go back later and use the command to create callouts.
- **Place Table**
  Places the connector table on the drawing sheet.
- **Properties**
  Displays the Connector Table Properties dialog box.

- **Saved Settings**
  Lists and applies the names of table formats you have saved.

**Connector Table Properties dialog box**

Defines properties for the connector table.

**Tabs**

- **General**
- **Location**
- **Title**
- **Columns**
- **Data**
- **Sorting**
- **Groups**
- **Options**
Options tab (Connector Table Properties dialog box)

- Exclude connector terminals without conductors
- Excludes any connector terminals that do not contain conductors from the connector table.

Create a connector table

1. Choose Diagram tab→Tables group→Connector Table.
2. Click a connector drawing view.
3. To show connector callouts, on the Connector Table command bar, click Auto-Callout.
4. Click the Properties button to edit the table properties or click to place the table.

Update a connector table

1. Right-click the out-of-date connector table.
2. On the shortcut menu, click Update.

Creating conductor tables

You can use the Conductor Table command to create a conductor table based on the harness information. The conductor table is much like a parts list of the wire harness and shows the parent/child relationship of the conductors in the harness.

The table contains a default set of columns, which you can customize by adding and reordering columns or rows. If you do customize the table, you can use the Save Settings option on the General tab of the Conductor Table Properties dialog box to save the customized setting. You can use the Save Settings option on the command bar to select settings you have saved.

If the conductor table becomes out-of-date, you can use the Update command to update the table.

Conductor Table command

Uses harness information from the conductor drawing view to create a conductor table. The table contains a default set of columns, which you can customize by adding or reordering columns. If you customize the table, you can use the Save Settings option on the General tab of the Conductor Table Properties dialog box to save the customized setting. You can use the Save Settings option on the command bar to select settings you have saved.

The conductor table is associative to the conductor drawing view and assembly. If the referenced assembly is updated, the table becomes out-of-date. You can use the Update command to update the table.

Conductor Table command bar

- Table Style
  - Lists and applies the available table styles.
  - See the Help topic, Table styles.
Properties
Displays the Conductor Table Properties dialog box.

Saved Settings
Lists and applies the names of table formats you have saved.

Conductor Table Properties dialog box
Defines properties for the connector table.

Tabs
General
Location
Title
Columns
Data
Sorting
Groups

Create a conductor table
1. Choose Diagram tab→Tables group→Conductor Table
2. Click a nailboard drawing view.
3. Click the Properties button to edit the properties or click to place the table.

Update a conductor table
1. Right-click the out-of-date conductor table.
2. On the shortcut menu, click Update.
Lesson

4  Activity: Creating a wire harness with Harness Design
Creating a wire harness with Harness Design

This activity guides you through the creation of a harness design that contains several wires, a cable, and a bundle.
Open activity file

- Open the assembly *harness.asm*.
Open the Harness Design environment

- Click Tools tab→Environs group→Harness Design.

The system displays the Wire Harness environment. The ribbon contains the commands you use to create wire harness conductors (wires, cables, or bundles).

You will use PathFinder for most of this activity.
Activate the parts in the assembly

This activity requires that the parts in the assembly are active. Several factors determine whether or not all parts within the assembly are active on your computer.

- To ensure that the parts are active, in PathFinder, right-click the harness.asm entry, and click Activate on the shortcut menu.
Hide the console part

- In PathFinder, position the cursor over the Console1.par entry, and then right-click to display the shortcut menu.

- On the shortcut menu, click Hide to hide the console part.
Start the Harness Wizard

The Harness Wizard consists of three dialog boxes that create a harness design automatically based on information contained in an imported net list file.

- On the ribbon, click Home tab→Wizard group→Harness Wizard.
Specify information for Harness Wizard Step - 1 of 3

The Harness Wizard - Step 1 of 3 dialog box specifies:

- The format for the eCAD net list file.
- The component document used to create the harness.
- The conductor document used to create the harness.
  - From the Document list, select Sample.
  - In the Component document box, use the Browse button to select `harness1.cmp` in the folder containing the activity files.
  - In the Connection document box, use the Browse button to select `harness1.con` in the folder containing the activity files.
  - Click the Next button.
Specify information for Harness Wizard Step - 2 of 3

The Harness Wizard - Step 2 of 3 dialog box displays information about the components used to create the wire harness. The dialog box contains commands and options that allow you to:

- Assign components.
- Assign occurrences.
- Populate components.

Notice that the status for component Volume1 is Not Populated. This indicates that the component has not been assigned to a part. Normally, you would use the Assign Terminals command to assign components and terminals before running the wizard. However, if this has not been done, you can make these assignments within the wizard.

- Right click the row containing Volume1 and click Assign Component.
- In the graphics window, click Potentiometer2.par, as shown in the illustration.
Notice that the dialog box updates to indicate the status of Volume1 is now populated.

- Click the Next button.
Specify information for Harness Wizard Step - 3 of 3

The Harness Wizard - Step 3 of 3 dialog box displays information about the conductors used to create the wire harness. The dialog box contains commands that allow you to:

- Assign terminals.
- Delete wires from the harness.
- Assign attributes to a wire or cable.
- Preview the harness.

Notice that there are three From Terminals highlighted in orange and the status for these terminals is Not Defined. These represent terminals on the Volume1 component that need to be defined.
Assign terminal A

- Right click From Terminal a and click Assign Terminal.

- On the status bar at the bottom of the window, click the Zoom Area button.

- Click above and to the left of Potitionmeter2.par, and then again below and to the right as shown in the illustration. This defines a rectangle that becomes the view area.

- Right-click to end the Zoom Area command.

- Click the circular edge to assign terminal a.
Assign terminal B

- Right click From Terminal b and click Assign Terminal.
- Click the circular edge to assign the terminal.
Assign terminal C

- Right click From Terminal c and click Assign Terminal.
- Click the circular edge to assign the terminal.
- Click the Finish button to complete the wizard.
Fit the view

- Click the View tab→Orient Group→Fit command to fit the assembly in the window.
View PathFinder

- In PathFinder, click the + symbol adjacent to the Wires entry.

Notice entries have been added for every wire created with the Harness Wizard.
Create a bundle

The Bundle command creates a harness bundle from a set of wires and cables. The result is a single path that can be created across several components within the harness assembly. When defining the path, you can define points to create the path or you can select an existing path created with the Path command. For this bundle, a path has already been created.

- In PathFinder, click the arrow next to the Paths entry.
- Right-click Path_1 and click Show on the shortcut menu.
- Click the Home tab→Harness group→Bundle command.
- Press the Alt button while you click and drag a box around plug14.par, as shown in the illustration, to select the wires to include in the bundle.
- Click the Accept button.
- Select the Use Existing Path button on the command bar.
- Click the existing path shown in the illustration.
Lesson 4  Activity: Creating a wire harness with Harness Design

- Click the Accept button.
- Click Preview and then click Finish.
Re-select the Harness Wizard command

You need to use the Harness Wizard to place another set of wires in the assembly.

- Click the Home tab→Wizard group→Harness Wizard button.
- In the Harness Wizard - Step 1 of 3 dialog box:
  - From the Document list, select Sample.
  - In the Component document box, use the Browse button to select harness2.cmp.
  - In the Connection document box, use the Browse button to select harness2.con.
- Click the Next button.
- In the Harness Wizard - Step 2 of 3 dialog box, click the Next button.
- In the Harness Wizard - Step 3 of 3 dialog box, click the Finish button.
Lesson 4  Activity: Creating a wire harness with Harness Design

Change the assembly display

- On the status bar at the bottom of the window, click the Visible and Hidden Edges button.
Zoom in on the assembly

- On the status bar at the bottom of the window, click the Zoom Area button.
- Drag a box around plug4.par, as shown in the illustration. This defines a rectangle that becomes the view area.
- Right-click to end the Zoom Area command.
Create a wire

- Click the Home tab→Harness group→Wire command.
Select the first point for the wire

- Make sure the Create Path button is selected
- Click the Keypoint Locate button
- Click the Keypoints button. From the Keypoints list, select Center Point
- Locate the center point shown in the illustration, and when it highlights, click to select it.
Fit the view

- Click View tab→Orient Group→Fit to fit the assembly in the window.
Zoom in on the upper gauge

> Use the Zoom Area command to zoom in on the area shown.
> Right-click to end the Zoom Area command.
Select the end point for the wire

- Locate the center point shown in the illustration, and when it highlights, click to select it.

- Position the cursor above and beyond the terminal as shown in the illustration, and right-click to accept the end point.

- Set the Material as shown in the illustration.

- Click the Preview button.
Finish the wire

- Click the Finish button to complete the wire.
Fit the view

- Click View tab→Orient Group→Fit to fit the assembly in the window.
Zoom in on the assembly

- Select the Zoom Area command.
- Zoom in on `plug4.par`. Right-click to end the command.
Create another wire

- Click Home tab→Harness group→Wire
  Use the same options you used to create the first wire.

- Select the circular edge shown in the illustration to define the first point for the wire.

- Select the circular edge shown in the illustration to define the end point for the wire.

- Position the wire as shown in the illustration and click the Accept button.
Activity: Creating a wire harness with Harness Design

- Set the Material as shown in the illustration.

- Click the Preview button.
Finish the wire

- Click the Finish button to complete the wire.
Fit the view

- Click View tab→Orient Group→Fit to fit the assembly in the window.
Create a cable

▸ Click the Home tab→Harness group→Cable command.

▸ Drag a box around plug4.par, as shown in the illustration, to select the wires to include in the cable.

▸ Click the Accept button.

▸ Make sure the Create Path button is selected.

▸ Create the path as shown in the illustration.

▸ Set the Material to 22/15-gage Stranded Copper Gray as shown in the illustration.
> Click Preview and then click Finish.
Shade the view

- On the status bar at the bottom of the window, click Shade with Visible Edges

![Image of a wire harness with shaded view]
Create a solid body of the wire harness

- Click the Home tab→Select group→Select Tool button
- In PathFinder, right-click the Harness entry to display the shortcut menu.
- On the shortcut menu, click Create Physical Conductor.

The system processes for a few seconds, then solid bodies are created for the harness conductors.
Lesson 4  Activity: Creating a wire harness with Harness Design

Change the view orientation

- Press Ctrl+R to align the view with the Right view.
Zoom in on the assembly

- Use the Zoom Area command to zoom in on rocker1.par, as shown in the illustration.
Lesson 4  Activity: Creating a wire harness with Harness Design

Move a wire

- Position the cursor over the path shown highlighted in the illustration above, stop moving the mouse for a moment, and notice that the cursor image changes to indicate that multiple selections are available. Also notice that the cursor image indicates which button you must click to display the QuickPick list. In this case, the right mouse button.

- Click the right mouse button, and the QuickPick list is displayed. Move the cursor over the different entries in QuickPick, and notice that different elements of the model highlight. QuickPick allows you to select exactly the element you want, the first time, without having to reject unwanted elements.

- Use QuickPick to highlight the path used to define Wire 9 and then click the right mouse button. In this example, it is Path_25, but your path may have a different name. If multiple paths are displayed in QuickPick, select the path closest to the occurrence in Rocker1.par.

- On the shortcut menu, click Edit Definition.

- Click the point shown in the illustration.
Drag the point to the approximate location shown in the illustration, and then right-click to place the wire.
Move two more wires

- Use the method described in the previous step to move the path used to define wire 7.

- and the path used to define wire 8.
After you have moved these wires, the wire harness should look similar to the illustration above.
Fit the view

- Click View tab→Orient Group→Fit to fit the assembly in the window.
Change the view orientation

- Press Ctrl+I to align the view with the Isometric view.
Display a hidden part

- In PathFinder, right-click the Console1.par entry, and then click Show. This displays the hidden part.
Hide the wires in the harness

- In PathFinder, right-click the Wires entry, and then click Hide to hide the wires.
Create a Wire Harness Report

You can create a report that lists the components and connections contained in an assembly.

▸ Click Tools tab→Assistants group→Harness Reports.

In the Harness Report dialog box:

▸

▸ Select the Connections option.

▸ Select All harness connections in the assembly.

▸ Click OK to generate the report.

A report dialog box displays a list of cables expanded into an indented list of the wire paths.
You can generate a report based on all components or connections in the assembly, the components or connections that are currently shown in the assembly, or the components or connections that are currently selected in the assembly. You can save reports, print reports, and copy reports to the clipboard.

- Click the Close button to dismiss the report.
Return to the Assembly environment

- Click the Tools tab → Close group → Close Harness button.
Save the file

- On the Quick Access toolbar, click the Save button to save the document.

Activity complete. Try modifying the wires using the Properties dialog box.
Lesson

5 Lesson review

Answer the following questions:

1. What two design processes are used in harness design?

2. What type of wires can be created using wiring harness design?

3. When using ECAD net list files, where is the data format defined?

4. In the Harness Wizard, which option specifies the component document used to create the wire harness?

5. In the Harness Wizard, which option specifies the connection document used to create the wire harness?
In this lesson, you learned how to use the wire harness wizard to open an ECAD component document and a connection document and define wires, bundles, cables and group them accordingly. A harness report was generated defining the source and destination of each wire and their associated properties.