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Chapter 2:  Introduction to What's New 

The What's New Guide briefly summarizes the new features in each release.   

This guide highlights what each function does, why it should be used, and where it can be found in the 

user interface. This guide also conveys the benefit of each new capability.   

New features are also introduced in NX Maintenance Releases between major releases. To review 

subsequent enhancements that were introduced after the initial release of NX 6, click on the entry in the 

Table of Contents titled Enhancements in NX 6.0.x Maintenance Releases. You can also access 

the What's New Guide for each maintenance release from the What's New Guide launch page.  
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Chapter 3:  HD3D 

HD3D overview 

What is it? 

Use the HD3D tools in NX to display and interact with information directly on the 3D model. 

You can: 

• Access the HD3D tools from the HD3D Tool Manager on the Resource bar. Currently, Visual 
Reporting and Check-Mate HD3D tools are available. 

 

• View and interact with tags in the graphics window.  

Tags identify objects for which an HD3D tool has information. Check-Mate tags identify areas 

with problems or check result information. Visual Reporting tags appear as color wheels. 
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• Control how you view tags and other information inside the 3D model using the See-Thru 

display styles. 

 

• Use visual reporting to get a visual report of information on the model.  

For example, you can color code components to display their load state. In the following graphic, 

   components are partially loaded and    components are fully loaded. 
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• Display information in different styles in the HD3D dialog box. 

For example, to scroll through thumbnails to find the items you want, use the Flow List+Tree 

view style in the Check-Mate tool. 

 

When you first activate an HD3D tool, the view styles are shown in the tool's dialog box. You 

can also display the tool's results in its own separate window. 

• Set preferences for the HD3D tools using the HD3D Tools dialog box. 

Why should I use it? 

You can use the HD3D tools to interact visually with information presented in the graphics window that 

may previously have been presented in dialog box lists and information reports. 

Where do I find it? 

HD3D Tool Manager 

Resource bar 
HD3D Tools tab    

 

See-Thru option 

Toolbar 
View→See-Thru    
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HD3D Tool Manager 

What is it? 

The HD3D Tool Manager provides access to HD3D tools. The Visual Reporting tool helps you 

visualize product information. The Check-Mate tool helps you validate product information. 

 

# Component 

 HD3D Tool Manager 

 Return to HD3D Tool Manager button 

 Deactivate button 

 Visual Reporting tool 

 Check-Mate tool 

 

 

From the HD3D Tool Manager, you can: 

• View the status of each tool.  

• Activate or deactivate a tool.  

When you activate an HD3D tool, the tool's dialog box replaces the HD3D Tool Manager. 

• Refresh a report after you make changes to your model. 

• Deactivate an HD3D tool so that no report information appears in the tool's button. 

• Access the HD3D Tool Properties dialog box where you can select the applications in which 

you want to access the HD3D tool. 
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Where do I find it? 

Resource bar 
HD3D Tools tab    

 

HD3D view styles 

What is it? 

View styles let you view and navigate the information made available by an HD3D tool.  

In the Visual Reporting tool, view styles are called legend styles. 

The following styles are available: 

• Flow List+Tree: Displays results in a list of thumbnail images that you can scroll through. 

 Note 

This style is not available in the Visual Reporting tool. 

 

 

 View Style list 

 Highlighted thumbnail of a tagged object 

 

You can: 

– Scan the images using the scroll bar. You can also scroll the list by clicking any of the 

images to the right or left of the centered image.  

– Display the tool's results outside of the tool dialog box, in a separate window. 

– Stretch the size of the list to make it tall and narrow. The tiles are then arranged 

vertically. 

– Expand and collapse the results for thumbnails that have the + plus sign. 

– Focus the view on the selected tag in the graphics window. 

– Select objects associated with the tag. 
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• Tile List: Displays results in a tile format that includes a thumbnail and a summary of the result. 

 

• Tree List: Displays results in columns. You can click on a column heading to sort results by the 

values in that column. For example, you can sort results by name, category, part name, profile 

name, or result status. 

 

• Info View: Displays details about one result or piece of information at a time.  

When you first activate an HD3D tool, the view styles are shown in the tool's dialog box. When 

you double-click a tag or list item, or right-click and select Show Info View, an info view 

window displays the information for that tag or list item. 

You can click the More Detail button to see a complete description of the test. 
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Where do I find it? 

Resource bar Any active HD3D tool. 

 

HD3D tags 

What is it? 

HD3D tags displayed in the graphics window are a new visual way to interact with information on the 3D 

model.  

Tags identify objects for which an HD3D tool has information. They present a subset of the results and 

information that is shown in the HD3D tool dialog box. 

Check-Mate tags identify areas with problems or check result information. Visual Reporting tags appear 

as color wheels. 

You can: 

• Display tags from every active HD3D tool together in the graphics window. 

In the following graphic, both Visual Reporting tags and Check-Mate tags are displayed on the 

model. 

 

• Access detailed information and options from the tags. 

• Open the Info View window for the result or the information the tag represents. 

• Remove the tags temporarily from the graphics window. You can restore the tags at any time. 

Why should I use it? 

Tags help you quickly find and access information about an area of your design. 
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Where do I find it? 

Tags are displayed in the graphics window whenever an HD3D tool that uses them is active. 

   See-Thru display 

What is it? 

See-Thru is a new rendering option that displays unimportant facet geometry with translucency. It uses 

de-emphasis colors to deemphasize unimportant faceted geometry so that important faceted geometry 

stands out better. 

 

When you apply a visual report that has unmatched components, the See-Thru option is automatically 

selected and applied to the unmatched components. 

You can manually change the See-Thru settings (style or color preferences) while a visual report is active. 

When you deactivate the report, the See-Thru options return to their default settings. 

There are three styles of See-Thru rendering: 

 See-Thru 
Shell  

Displays less important shaded geometry as a translucent shell with a specified 

color. Hidden unimportant facet geometry is not displayed. This is the default See-

Thru style. 

 See-Thru 
Original Color 
Shell  

Displays less important shaded geometry as a translucent shell, preserving the 

original shaded geometry colors. Hidden unimportant facet geometry is not 

displayed. 

 See-Thru 
Layers  

Displays less important shaded geometry as translucent layers with a specified 

color. 

 

You can change the default edge color and translucency for each style in the Visualization 
Preferences dialog box. You can change the default color only for the See-Thru Shell and See-Thru 
Layers styles. 
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 Note 

• Only sheet and solid bodies are affected by the See-Thru options. 

• The translucency percentage is hard-coded for each style. 

• When you enable the See-Thru rendering option , if shaded edges are displayed, that is 

the shaded edges have some color other than none, then the edges are displayed only for 

the topmost visible layer of unimportant facet geometry, regardless of the See-Thru style. 

 

Why should I use it? 

Use the See-Thru option to provide for displays that make it easier to see tags or other information 

inside the 3D model. 

Where do I find it? 

See-Thru options 

Toolbar 
View→See-Thru    

View→See-Thru Style list   →See-Thru Shell /See-Thru 
Original Color Shell /See-Thru Layers 

 

Visualization preferences for See-Thru options 

Menu Preferences→Visualization 

Location in dialog box Visualization Preferences dialog box→Faceting 

page→Session Settings group→See-Thru Settings subgroup 

Visualization Preferences dialog box→Color Settings 

page→Part Settings group→De-emphasis Settings subgroup 

 

HD3D preferences 

What is it? 

Use the HD3D Tools dialog box to set preferences for the HD3D tools. 

You can: 

• Turn on or off one, or all HD3D tools. When you turn off all HD3D tools, the HD3D tools tab is 

also removed from the Resource bar. 

• Reorder the HD3D tools. 

• Select the NX applications in which you want the HD3D tools to appear. You can select the tool 

or tools you want in the HD3D Tools dialog box and then select the applications you want in the 
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HD3D Tool Properties dialog box. For example, you can have the Check-Mate tool show up 

only in the Modeling application. 

 Note 

The HD3D tools remain active even after you close the HD3D Tools tab    in the Resource 

bar. 

 

Where do I find it? 

HD3D Tools dialog box 

Menu Preferences→HD3D Tools 

 

HD3D Tool Properties dialog box 

Menu 
Preferences→HD3D Tools dialog box→Properties    

Shortcut menu In the HD3D Tool Manager, right-click an HD3D tool→Properties 

   

 

HD3D Visual Reporting 

What is it? 

Use the Visual Reporting tool to display components according to the results of a report that you specify. 

The report consists of the following: 

• A report property, which is used to color or tag the part. 

• A report scope, which lets you specify the components used in the report. The visual report is 

applied to all components in the displayed part, unless the scope specifies differently. 

A legend in the Visual Reporting dialog box lets you interpret the results and perform actions on 

groups of components that are displayed with the same color. You can open the legend in a separate 

window. 

When you use a visual report, you can: 

• Retrieve and activate an existing visual report. 

• Define and activate a new report. Some example reports are included with NX. 

• Change the value of any user-defined terms of the scope. 

• Specify whether the results are shown as colors, tags, or both on your components. 

• Work with NX functions as usual. If you make changes that affect the visual report, you can click 

Refresh    to update the results. 
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You can use the following properties to build your report: 

• Component properties that can be shown as Assembly Navigator columns 

• Part attributes 

• Teamcenter properties that can be retrieved from the Item, Item Revision, or dataset 

When you define a visual report, you can: 

• Specify the report property and scope. 

• Specify the groups that appear in the legend, or you can let the software automatically determine 

the groups. For example, you can create a visual report based on the Status the components have 

in Teamcenter. You can define a scope term that specifies you are only interested in seeing the 

status for part files you own. 

• Save the visual report as a VPX file for later use. 

Results appear in the graphics window, as shown in the following figure. 

 

 

Visual report with colors only 

In the figure above, the visual report displays each component based on the Position column in the 

Assembly Navigator. Red components are partially constrained, yellow components are fully 

constrained, and blue components are fixed. 

Why should I use it? 

You can use the Visual Reporting tool to quickly visualize information about the design you are working 

on. 

• Coloring components helps you quickly interpret large amounts of information, such as overall 

trends in the assembly. In the example, you can quickly see that most of the components are 

partially constrained. If you activate a visual report based on weight, you can easily see if one 

area is significantly heavier than the others. 

• Tagging components provides you with more information than is possible with colors by 

themselves. For example, when your visual report uses tags to report on weight, you can move 

your cursor over a tag to see the exact weight of the component. 
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Where do I find it? 

Activate a visual report 

Resource Bar HD3D Tools→double-click Visual Reporting 

 

Define a visual report 

Menu File→Utilities→Define Visual Report 

 

Define a visual report (alternate options) 

Location in dialog box Visual Reporting dialog box→Report group→Define New 

Report    

Visual Reporting dialog box→Report group→Edit    the 

active report, and save under a new name 

 

Open the legend in a separate window 

Prerequisite Reporting Style must be set to Color Objects or Color and Tag 
Objects. 

Shortcut menu In the Visual Reporting dialog box, right-click the legend 

background→Send to Window 
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Check-Mate 

HD3D Check-Mate tool overview 

What is it? 

Use the HD3D Check-Mate tool to interactively check parts, assemblies, and drawings to ensure that 

they: 

• Follow company design standards. 

• Use best practices. 

• Meet modeling quality standards. 

Check-Mate uses the HD3D visualization tools to graphically tag results directly on the model. 

 

When you use this tool, you can: 

• Execute Check-Mate tests interactively as you design your models. 

• Display results in a graphical tree list, or using tags on the 3D model. 

See tags clearly on the 3D model using the new See-Thru display commands. Hide tags from the 

display temporarily by pressing Ctrl+3. 

• Access actions from the results list or from the graphic tags. For example, right-click the list item 

to make the listed part the work part and to select associated features to edit. 

 Tip 

Make the best use of the graphical displays in the HD3D Check-Mate tool by using the full screen 

display mode. Place the floating information windows on the secondary monitor, if you use dual 

monitors. 

 

Why should I use it? 

You can use the HD3D Check-Mate tool to quickly locate, diagnose, and fix problems.  
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Where do I find it? 

Resource bar 

HD3D Tools tab    →double-click 

Check-Mate. 

 

  Set up Check-Mate tests 

What is it? 

The Set Up Tests command is now available in the HD3D Check-Mate Tool dialog box. This button 

opens the Check-Mate dialog box where you can define product validation tests to run. 

    

 

# Component Description 

 Parts tab Lets you select which parts to test, and how many levels of 

an assembly to include. 

 Tests tab Lets you select tests to perform from lists of provided tests 

and user-defined profiles. 

 Run Options tab Lets you control log files and other checking options. 
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# Component Description 

 Customize button Lets you define parameters and settings for each test. 

 Create Temporary Profile 

button 

Lets you store profiles to save a list of tests with parameters 

and options already defined. 

 

 

Why should I use it? 

You can set up tests from the same HD3D Tools tab that you use to display results. 

Where do I find it? 

 

HD3DCheck-Mate Tool dialog box 

Resource bar 

HD3D Tools tab    →double-click Check-Mate 

Location in dialog box 
Settings group→Set Up Tests    

 

 

Toolbar and menu locations 

Toolbar 
Check-Mate→Set up Tests    

Menu Analysis→Check-Mate→Set Up Tests 

 

Execute HD3D Check-Mate tests 

What is it? 

The Execute Check-Mate Tests command is now available in the HD3D Check-Mate Tool dialog 

box. 

 You can now: 

• Define, run, and review results on the same HD3D Tools tab. 

• Interact with test results as you create your design. 

• Keep the tests active and reuse them on other parts. 

• Deactivate Check-Mate with the Deactivate button on the HD3D Tools Manager. 
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Why should I use it? 

You can execute tests from the same tab on which you set up tests and review results using the HD3D 

Check-Mate tool. 

Where do I find it? 

Resource bar 

HD3D Tools tab   →double-click Check-Mate 

Location in dialog box 
Controls group→Execute Check-Mate Tests    

 

Display Check-Mate results 

What is it? 

You can now display Check-Mate results graphically to more easily scan for design problems. 

You can: 

• Display results as a tree list to scan the columns of the results. Click on a column heading to sort 

results by the values in that column. For example, sort results by name, category, part name, 

profile name, or result status. 

 

• Display results as tiles to view a thumbnail image and summary information. 
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• Display results as a flow list to graphically scan through the thumbnail images at the top of the 

tree list. 

 

Graphical icons are used to help sort the results in each of the results listings. These icons show a 

category of result, the pass or fail status, and a priority. 

 

• Locate problems graphically with tags placed on the 3D model in the graphics window. 

 

• Use the See-Thru display types to make tags more visible on a 3D model. 

 



22    What's New in NX 7   whatsnew7 0  

• Double-click a graphical tag or an item in the results list to display the Check-Mate Result 

window which gives summary information on the test. Click the More Detail button to see a 

complete description of the test. 

   

   

 

Why should I use it? 

You can graphically scan Check-Mate results using HD3D displays and tags to identify and locate 

problem areas more quickly than sorting through lists. 

Where do I find it? 

 

HD3D Check-Mate Tool dialog box 

Resource bar 

HD3D Tools tab    →double-click Check-Mate 

Location in dialog box Results group 

 

 

Toolbar and menu locations 

Menu Analysis→Check-Mate→View Check-Mate Results 

Toolbar 
Check-Mate→View Check-Mate Results    
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Filter Check-Mate results 

What is it? 

Use the Settings group in the options in the HD3D Check-Mate Tool dialog box to filter Check-Mate 

results.  

   

For example, the options shown indicate that the software will display failed tests without showing the 

passed tests, and will filter out tests on parts in your assemblies for which you do not have write 

permission. 

 Tip 

You can also sort results in the table by clicking on a column heading to sort by that column. 

 

 

Why should I use it? 

You can filter and sort your test results in the order that you want to fix problems. The results remain 

available on the HD3D Tools tab as you work with other commands. 

Where do I find it? 

Resource bar 

HD3D Tools tab    →double-click Check-Mate 

Location in dialog box Settings group 

 

Check-Mate customization 

What is it? 

There are new ways to customize Check-Mate, depending on the role of the user, and the amount of 

customization required. 
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From the HD3D Check-Mate Tool dialog box users can: 

• Choose from a list of supplied tests as the simplest level of customization. 

 

• Edit each test to modify test parameters. 

•   Store a list of chosen tests as a temporary profile. Users can edit a profile to modify the 

list of tests, or to modify parameters from each test. 

Test authors can customize Check-Mate tests to do the following: 

• Create and store global profiles from the Check-Mate Author Tools dialog box. 

• Use Knowledge Fusion Interactive Class Editor to author tests to create a company profile to 

enforce company standards. 

• Customize the bit-mapped image used to show the result category.  

 

• Modify the test information in the Check-Mate Result window.  

 

• Modify the description, which is used for the node’s tooltip and for the text in the Tile results 

view list. 
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Why should I use it? 

You can customize Check-Mate test profiles to efficiently reuse the same sets of tests on multiple parts 

and to enforce company standards. 

Where do I find it? 

HD3D Check-Mate Tool dialog box 

Resource bar 

HD3D Tools tab   →double-click Check-Mate 

Location in dialog box 
Settings group, Set Up Tests    

 

  

Check-Mate Author Tools  dialog box 

Menu Analysis→Check-Mate→Author Tests 

Toolbar 
Check-Mate→Author Tests    

 

 

For documentation on customizing, find the instructions distributed with the Check-Mate software. 

HD3D Check-Mate workflow 

What is it? 

Depending on your work role, there are different ways to use Check-Mate. 

A typical designer workflow is shown below. 

 

 Start with an open part, assembly, or drawing 

being designed. 

 

   On the HD3D Tools tab, double-click 

Check-Mate. 
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 In the Settings group, click Set Up Tests 

  .  

On the Parts tab, select the part file and the 

levels of the assembly to check. 

Select the tests to run in the Categories list. 

Select from standard tests or from your local 

company profiles. 

Click Add To Selected to move the selected 

tests to the Chosen Tests list. 

Click Close. 

 

 

 To run the chosen tests, in the Controls 

group, click Execute Check-Mate Tests 

   . 
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 To sort by the result status, in the Results 

group, click on the Result column heading. 

To filter results, use the options in the 

Settings group. 

 

 

 To review any problem areas, click on the 

result objects in the Results group. Double-

click to see information in the Check-Mate 

Result window. 

 

 

 To edit a feature in an assembly component 

follow these steps. 

1. Right-click on an error and select 

Make Work Part. 

2. Right-click and select Select 
Associated Objects. 

3. Edit the feature using the Part 
Navigator. 

 

 

 Continue to work with the model and review 

tests. 

Press Ctrl+3 to temporarily hide graphic tags. 

Open other parts to run the same tests. 
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  Deactivate Check-Mate when finished using 

Deactivate at the top of the HD3D Tools 
Manager. 
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Chapter 4:  Gateway 

   Curve Continuity 

What is it? 

Use the Curve Continuity command to evaluate the continuity between a curve and a reference object. 

A reference object can be a face, an edge, a curve, or a datum plane. 

You can calculate G0, G1, G2, and G3 continuity values between the end point of the curve and the 

nearest point on the reference object.  

An associative curve continuity analysis object is created with a label at the end point of the curve. 

How the continuity constraints are displayed depends on the continuity types specified in the Curve 
Continuity dialog box. If the deviation for a continuity type exceeds the modeling tolerances, the 

continuity type is shown in red. 

 

Curve continuity analysis between a curve and a face 

 

Curve continuity analysis between two curves 
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The associative curve continuity analysis objects are listed in the main panel of the Part Navigator. You 

can select or clear the check boxes to show or hide the labels in the graphics window. 

   Analysis 

   Curve Continuity Analysis 

   Curve Continuity Analysis 

   Curve Continuity Analysis 

 

Why should I use it? 

You can check curve deviations, such as variation in position, tangency, curvature, and acceleration 

between faces, curves, edges, or the normal of a datum plane. 

This command is useful in the surfacing workflow, where you must verify the continuity between curves 

that are used as inputs to create surfaces. 

Where do I find it? 

Application Modeling 

Toolbar 
Analyze Shape→Curve Continuity Analysis    

Menu Analysis→Curve→Continuity 

 

   Curve Analysis 

What is it? 

Use the Curve Analysis commands to analyze the shape of an edge or a curve. 

For a selected curve or edge, you can: 

• Display the curvature comb. You can specify the curvature comb parameters such as the number 

of needles, needle scale, scale factor, and so on. 

• Create and display curvature peak points and curvature inflection points. 

Curve analysis objects dynamically update as you change the curves on which they are based, or when 

you change the analysis parameters. 



whatsnew7 0   What's New in NX 7    31 

 

 

   Curve 

   Curvature comb  

   Peak point  

   Inflection point 

 

The associative curve analysis objects are listed in the main panel of the Part Navigator. You can select 

or clear the check boxes to show or hide the curvature comb, peak point, and inflection point symbols in 

the graphics window as required. 

   Analysis 

   Curve Analysis 

   Curve Analysis 

 

You can specify the color and line fonts for the needle and cap line of the curve analysis objects in the 

Edit Object Display and Object Preferences dialog box. For more information, see Curve Analysis 

Display options. 

Why should I use it? 

You can analyze and display the curve curvature, and verify that the curve is smooth and does not include 

unintended inflections. 

Where do I find it? 

Application Modeling 

Toolbar 
Analyze Shape→Curve Analysis   →Curve Analysis – 

Combs    / Curve Analysis – Peaks    / Curve Analysis 

– Inflections    

Menu Analysis→Curve→Curve Analysis  
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Curve Analysis Display options 

What is it? 

The following options are available in the Edit Object Display and Object Preferences dialog box: 

Needle 

A color swatch lets you specify the color of the needles. 

The line font list lets you specify the line font of the needles. 

Cap 

Select this check box to display the cap line. 

A color swatch lets you specify the color of the cap line. 

The line font list lets you specify the line font of the cap line. 

Why should I use it? 

Use these options to specify the color and line fonts for the needles and cap lines of curve analysis 

objects. 

Where do I find it? 

Toolbar 
Utility→Edit Object Display    

Menu Edit→Object Display 

Preferences→Object 

Location in dialog box Edit Object Display dialog box→Analysis tab→Curve 
Analysis Display group 

Object Preferences dialog box→Analysis tab→Curve 
Analysis Display group 
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Combs Options, Peaks Options, and Inflections Options 

What is it? 

The following commands are no longer available in the Analysis menu: 

• Combs Options 

• Peaks Options 

• Inflections Options 

The parameters for controlling curvature combs, curvature peak points, and curvature inflection points are 

available in the Curve Analysis dialog box. For more information, see Curve Analysis. 
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Chapter 5:  Design 

Modeling 

Synchronous Modeling with synchronous technology 

  Resize Chamfer 

What is it? 

Use the Resize Chamfer command to change the size of a chamfered edge regardless of its feature 

history. 

 

 

Why should I use it? 

You can edit the size of an angled face so that it has the one of the following parameters: 

• Symmetric Offset 

• Asymmetric Offset 

• Offset and Angle 

Where do I find it? 

Application Modeling 

Prerequisite A face must be labeled as a chamfer using the Label Chamfer 

command if it cannot be recognized as a chamfer. 



36    What's New in NX 7   whatsnew7 0  

Toolbar 
Synchronous Modeling→Resize Chamfer    

Menu Insert→Synchronous Modeling→Chamfer→Resize 
Chamfer 

 

  Label Chamfer 

What is it? 

Use the Label Chamfer command to label an angled face as a chamfer. The angled face can be on the 

NX model or on an imported solid. 

Use this command when you want the following commands to recognize an angled face as a chamfer: 

• Resize Chamfer 

• Move Face 

In the model on the left the highlighted face is labeled as a chamfer. 

 

 

Where do I find it? 

Application Modeling 

Toolbar 
Synchronous Modeling→Label Chamfer    

Menu Insert→Synchronous Modeling→Chamfer→Label Chamfer 

 

  Optimize Face 

What is it? 

Use the Optimize Face command to simplify surface types, merging faces, improving edge accuracy, 

and recognizing blends. 
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Why should I use it? 

Use this command on models imported into NX to convert B-surface faces to analytic faces. 

Where do I find it? 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar 
Synchronous Modeling→Optimize Face    

Menu Insert→Synchronous Modeling→Optimize→Optimize Face 

 

  Replace Blend 

What is it? 

Use the Replace Blend command to convert B-surface faces that appear like blends to a replace blend 

feature. 

 

 

Why should I use it? 

Use this command on models imported into NX to convert B-surface faces to rolling ball type blend 

faces. 

You can inherit the blend radius from the selected face, or you can enter a radius. 

  



38    What's New in NX 7   whatsnew7 0  

Where do I find it? 

Application Modeling 

Toolbar 
Synchronous Modeling→Replace Blend    

Menu Insert→Synchronous Modeling→Optimize→Replace Blend 

 

Create Feature – enhancement 

What is it? 

You can now turn on or off creating features when you select or clear the Create Feature option while 

working in History-free mode. 

You can use this option with the Hole, Edge Blend, and Chamfer commands. 

 

Why should I use it? 

Use this option to edit the feature parameters later. 

With the Hole command, the parameters of the hole are maintained in relation to the planar face when 

you select the Create Feature option. For example, if the planar face is moved, the bottom of the hole 

also moves. 

Where do I find it? 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar 
Feature→Hole    

Feature Operation→Edge Blend    

Feature Operation→Chamfer    

Menu Insert→Design Feature→Hole 

Insert→Detail Feature→Edge Blend 

Insert→Detail Feature→Chamfer 

Location in dialog box Settings group→Create Feature 
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  Move Face – enhancement 

What is it? 

When you use the Move Face command, you can select faces in components other than the work part 

within an assembly. 

 

 

Why should I use it? 

You can move multiple component faces of an assembly at the same time. 

Where do I find it? 

Entire Assembly selection option 

Application Modeling 

Prerequisite All parts must be in History-free mode 

Selection bar Selection Scope→Entire Assembly 

 

 

Move Face command 

Application Modeling 
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Toolbar 
Synchronous Modeling→Move Face    

Menu Insert→Synchronous Modeling→Move Face 

 

   Pattern Face – enhancement 

What is it? 

When you use the Pattern Face command while in History-free mode, a feature that you can edit is 

created in the Part Navigator. 

When you use the Move Face, Pull Face, or Offset Region commands on any instance of the pattern, 

all instances of the pattern are updated. 

Other features, for example, Edge Blend, Chamfer, and Hole, that are listed in the Part Navigator, and 

applied to individual edges or faces in an instance of the pattern, are also updated when you edit the 

pattern. 

 

Why should I use it? 

You can maintain the pattern behavior in history-free modeling. 

Where do I find it? 

Application Modeling 

Prerequisite You must be in History-free mode 

The pattern must be created in NX 7.0 or later 

Toolbar 
Synchronous Modeling→Pattern Face   . 

Menu Insert→Synchronous Modeling→Pattern Face 
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  Make Fixed 

What is it? 

Use the Make Fixed command to add a fixed constraint to selected faces. 

The constraint is also listed in the Part Navigator. 

The fixed constraint appears in the Saved list in all Relate command dialog boxes. When you create a 

relation between a face with a fixed constraint and another face, you can turn off the fixed constraint. 

 

Why should I use it? 

Use Make Fixed on a face if you want to prevent the face from changing its position when surrounding 

faces are changed by other synchronous modeling commands. 

Where do I find it? 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar 
Synchronous Modeling→Make Fixed    

Menu Insert→Synchronous Modeling→Relate→Make Fixed 

 

 

Saved list 

Application Modeling 

Prerequisite You must be in History-free mode, in one of the Relate command 

dialog boxes 

Menu Insert→Synchronous Modeling→Relate 

Location in dialog box [Relate command dialog box]→Motion  group→Results 

tab→Saved list 

 

Dimension to Virtual Edge – enhancement 

What is it? 

You can now use either the Linear Dimension or the Angular Dimension command to create a 

dimension to the virtual edge at the intersection of two faces separated by a blend. 
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The virtual edge is highlighted as you move the cursor over an edge blend, to indicate that the virtual edge 

can be selected. 

 

 

Angular dimension 

Where do I find it? 

Dimension commands 

Application Modeling 

Toolbar 
Synchronous Modeling→Linear Dimension    

Synchronous Modeling→Angular Dimension    

Menu Insert→Synchronous Modeling→Dimension→Linear 
Dimension 

Insert→Synchronous Modeling→Dimension→Angular 
Dimension 

 

Dimension – enhancement 

What is it? 

You can use the Lock Dimension option to define a static relationship between edges and faces when 

you create linear, angular, or radial dimensions. 

The locked dimension appears in the Saved list in all Relate command dialog boxes. When you create a 

relation between a face with a locked dimension and another face, you can turn off the locked dimension. 
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Why should I use it? 

Use the Lock Dimension option to prevent the face from changing its position when surrounding faces 

are changed by other synchronous modeling commands. 

Where do I find it? 

Lock Dimension option 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar 
Synchronous Modeling→Linear Dimension    

Synchronous Modeling→Angular Dimension    

Synchronous Modeling→Radial Dimension    

Menu Insert→Synchronous Modeling→Dimension→Linear 
Dimension 

Insert→Synchronous Modeling→Dimension→Angular 
Dimension 

Insert→Synchronous Modeling→Dimension→Radial 
Dimension 

Location in dialog box Settings group→Lock Dimension 

 

 

Saved list 

Application Modeling 

Prerequisite You must be in History-free mode, in one of the Relate command 

dialog boxes 

Menu Insert→Synchronous Modeling→Relate 

Location in dialog box [Relate command dialog box]→Motion  group→Results 

tab→Saved list 
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  Show Related Face 

What is it? 

Use the Show Related Face command to highlight and review relations that exist on faces. 

Use this command to show faces with the following relations: 

• Fixed 

• Linear Dimension 

• Angular Dimension 

• Radial Dimension 

• Offset Relations 

For the three dimension commands this relation is saved when the Lock Dimensions option is selected. 

 

 

Why should I use it? 

You can:  

• Highlight relations that will not change when surrounding faces are changed by other 

synchronous modeling commands. 

• Delete the highlighted relations. 

Where do I find it? 

Application Modeling 

Toolbar 
Synchronous Modeling→Show Related Face    

Menu Insert→Synchronous Modeling→Relate→Show Related 
Face 
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Region Boundary Faces – enhancement 

What is it? 

When using the Pull Face and Offset Region commands, you can select the portion of a face using the 

Region Boundary Faces selection option. These regions are determined by existing edges and curves 

that lie on the face. 

 

 

Why should I use it? 

This selection option helps you select portions of a face without using the Divide Face command. 

Where do I find it? 

Region Boundary Faces selection option 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar Selection Bar→Face Rule→Region Boundary Faces 

 

 

Pull Face and Offset Region commands 

Application Modeling 

Toolbar 
Synchronous Modeling→Pull Face    

Synchronous Modeling→Offset Region    
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Menu Insert→Synchronous Modeling→Pull Face 

Insert→Synchronous Modeling→Offset Region 

 

Face Finder – enhancement 

What is it? 

You can use the Select Offset option in the Face Finder group to select faces that appear to be offset 

from each other. 

This option is also available in the dialog boxes for the following commands: 

• Move Face 

• Offset Region 

• Resize Face 

• Cut Face 

• Copy Face 

• Mirror Face 

• Relate commands 

• Dimension commands 

• Change Shell Thickness 

• Group Face 

 

Why should I use it? 

You can use the Select Offset option to simplify the selection of faces that appear to be offset from each 

other. 

Where do I find it? 

Application Modeling 

Toolbar Synchronous Modeling→[command button] 

Menu Insert→Synchronous Modeling→[command] 

Location in dialog box [command dialog box]→Face Finder group→Settings 

tab→Select Offset 
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  Cross Section Edit – enhancement 

What is it? 

You can move the center of a hole by dragging just one of its cross section curves created by the Cross 
Section Edit command. 

 

 

Why should I use it? 

This allows you to change the center position of a hole while maintaining its original diameter. 

Where do I find it? 

Application Modeling 

Prerequisite You must be in History-free mode 

Toolbar 
Synchronous Modeling→Cross Section Edit    

Menu Insert→Synchronous Modeling→Cross Section Edit 

 

Snap to an object without associativity 

What is it? 

For the Extrude and Revolve commands, the new Snap to Object option lets you define a Start or 

End distance value by selecting a point, a planar face, or a datum plane. The software calculates the 

distance along the extrude vector or the revolve arc, and sets the value. There is no associativity to the 

point, face, or datum plane. 
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The Snap to Object option works in the context of an assembly. For example, in the following 

assembly, you can use the Snap to Object option to extrude the profile to the center point of the dimple.  

 

 Note 

• For an extrude operation, if you use a planar face or datum plane as the ―Snap to‖ object, 

Siemens PLM Software recommends that the face or datum be normal to the extrude 

vector. 

• For a revolve operation, if you use a planar face or datum plane as the ―Snap to‖ object, 

Siemens PLM Software recommends that the face or datum be normal to the revolve arc 

where the face or plane intersects the arc. 

 

Why should I use it? 

The Snap to Object option makes it easy to calculate the Start or End distance to a point, planar face, 

or datum plane. Use this option when associativity to the limiting point, face, or plane is not important. 

Where do I find it? 

Application Modeling 

Prerequisite For the Extrude or Revolve commands, the Start or End limit 

must be set to Value. 

Graphics window Right-click a Start or End handle and choose Snap to Object. 
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Automatically make datums and sketches internal 

What is it? 

You can set two new Modeling preferences or customer defaults that automatically make 

• Datums internal to their child sketches. 

• Sketches internal to their child features. 

The software automatically internalizes datums or sketches only when you create a child sketch or a child 

feature. You can still make datums or sketches external using the existing Part Navigator commands. 

The new settings will not cause datums and sketches to be internalized again when you edit the feature. 

Why should I use it? 

Internal datums and sketches do not appear in the Part Navigator, so you can use these settings to 

shorten the Model history for a part.  

Where do I find it? 

Modeling preference 

Application Modeling 

Menu Preferences→Modeling 

Location in dialog box Modeling Preferences→General tab→Automatically Make 
Datums Internal to Child Sketch/Automatically Make 
Sketch Internal to Child Feature 

 

Customer Default 

Menu File→Utilities→Customer Defaults 

Location in dialog box Modeling→General→Miscellaneous→Automatically Make 
Datums Internal to Child Sketch/Automatically Make 
Sketch Internal to Child Feature 

 

Modeling Preferences 

What is it? 

The following options are removed from the Modeling Preferences dialog box→Analysis 

tab→Curve Curvature Display group: 

• Display: Curvature, Radius of Curvature 

Style: Linear, Logarithmic 

Inside , Outside  
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These options are now available in the Curve Analysis dialog box. For more information, see 

Curve Analysis. 

• Show Cap Line 

This option is now available in the Edit Object Display and Object Preferences dialog box. 

For more information, see Curve Analysis Display options. 

Where do I find it? 

Curve Analysis options 

Menu Analysis→Curve→Curve Analysis 

Toolbar 
Analyze Shape→Curve Analysis    

Location in dialog box Curve Analysis dialog box→Settings group→Needle 
Direction, Calculation Method, Scaling Method 

 

Curve Analysis Display options 

Toolbar 
Utility→Edit Object Display    

Menu Edit→Object Display 

Preferences→Object 

Location in dialog box Edit Object Display dialog box→Analysis tab→Curve 
Analysis Display group→Cap 

Object Preferences dialog box→Analysis tab→Curve 
Analysis Display group→Cap 
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Shape Studio 

Specify editor to edit a spline 

What is it? 

You can specify to use either X-Form or Studio Spline as the default editor when you double-click a 

spline.  

 

Why should I use it? 

If you want to control degrees or segments, use X-Form as the editor when you double-click a spline.  

If you want to edit spline constraints, use Studio Spline.  

Where do I find it? 

Application Modeling, Shape Studio 

Prerequisite The setting is effective only in Shape Studio 

Menu Preferences→Modeling 

Files→Utilities→Customer Defaults 

Location in dialog box Modeling Preferences→Freeform tab→Default Action on 
Spline 

Customer Defaults→Modeling→FreeForm 
Modeling→General tab→Default Action on Spline 

 

   Deviation Gauge 

What is it? 

The Deviation Gauge command has the following enhancements: 

• The Absolute Value option lets you control values visible in the label. 

• The Dynamic Label option lets you see the deviation at the location of a handle, as you drag it 

across the selected source geometry. 

• A color legend is available in the graphics window to show the difference between minimum and 

maximum deviations. 

• Color mapping between a facet body and a face appear on the face. 

• Results of the deviation analysis are visible in the dialog box, and include the total number of 

samples, the number of samples inside both inner and outer tolerance, and the number of samples 

out of tolerance. 
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   Dynamic Label 

   Color legend 

Where do I find it? 

Application Shape Studio 

Toolbar 
Analyze Shape→Deviation Gauge    

Menu Analysis→Deviation→Gauge 

Location in dialog box Deviation Gauge→Plot group→Absolute Value 

Deviation Gauge→Label group→Dynamic Label 

 

   Section Analysis and Grid Analysis 

What is it? 

The functionality in the Section Analysis command is divided between two separate commands: 

Section Analysis and Grid Analysis. 

   Section Analysis command 

• You can analyze shapes by cutting sections on selected objects.  

• You can control the orientation of the cutting plane. 

• You can create section curves separately, without also having to create section analysis objects. 

• You can specify section placement using these options: 
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– Uniform — Cuts a section based on the number of sections or the spacing between the 

sections.  

– Through Points — Cuts sections through user specified points.  

– Between Points — Cuts sections between user specified points, adjusted for the 

number of sections or the spacing of sections. 

– Interactive — Cuts sections on the selected objects by drawing each section through 

two defining points in the graphics window. Sections are cut in the view direction. 

• The orientation of curvature needles for an Isoparametric section now always measures and 

displays the surface curvature of the selected faces, and not the section curve curvature as in prior 

releases. 

   Grid Analysis command 

• You can analyze shapes by defining a grid to cut sections on selected objects. 

Preferences for the curvature display Needle Direction, Calculation Method, and Scaling Method 

options have been moved from Modeling Preferences to both the Section Analysis and Grid 
Analysis dialog boxes. 

Why should I use it? 

 

Splitting section and grid analysis functionality into separate commands improves their interaction and 

efficiency for Class A workflows. 

Where do I find it? 

Application Shape Studio 

Toolbar 
Analyze Shape→Section Analysis    

Analyze Shape→Grid Analysis    

Menu Analysis→Shape→Section 

Analysis→Shape→Grid Analysis 

 

   X-Form 
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What is it? 

The new simplified X-Form dialog box gives you improved access to frequently used options, and 

supports the following logical top-down workflow. 

1. Select object. 

2. Select poles to edit. 

3. Change object degree. 

4. Select movement method. 

5. Edit poles. 

Other usability improvements include the following: 

• You can now specify movement methods using options in the Move, Rotate, Scale, 
Planarize tabs. 

• The OrientXpress tool is available to enable rapid selection of a movement method from within 

the scene. 

• When you use Move with the Polygon option, polygon vector handles are displayed at each 

surface pole. 

 

Vector handles on poles – dynamically controlled 

• If you reduce the degree or the number of patches of a surface or curve, a temporary on-screen 

display shows the maximum deviation (at the point of instance). 

 

On-screen maximum deviation 
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• A Deselect Poles Automatically check box has been added to the Pole Selection group: 

     – Pole selection is cumulative; any pole selected is added to the previous selected 

pole. This is the default state.  

     – When you select a pole, any other selected poles are automatically deselected.  

• You can use the shortcut menu when you right-click a pole or polylines to: 

   Increase or decrease the U and V degrees. 

  Choose a movement method. 

Where do I find it? 

Application Modeling and Shape Studio 

Toolbar 
(Modeling) Freeform Shape → X-Form     

(Shape Studio) Edit → X-Form      

Menu Edit → Surface → X-Form 

 

   Match Edge 

What is it? 

The Match Edge command has been enhanced to include: 

• The type of Match Edge operation is now calculated based on the selected Reference geometry 

so you don't need to explicitly select a type. 

• Selection of both the Edge to Edit and a single Reference surface will occur automatically 

when the selection cursor crosses both the Edge to Edit and the Reference geometry. 

• A Shape Control tab has been added: 

– You can control the amount of edge match applied to the matching surface using the 

Modification Percentage slider where 0% produces a totally unmatched state and 

100% produces a fully matched state. 

– A Blend check box has been added to activate Blend, Depth and Skew input for 

matching operations. 

• Before and After deviation values are displayed for checking edge matching based on your 

continuity specifications. 

• You can use the Align parameterization option to enable the Edge to Edit surface to adopt to 

the parameterization of the Reference surface pole structure without increasing the degree or 

patches of the surface being matched. 
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Where do I find it? 

Application Modeling and Shape Studio 

Toolbar 
(Modeling) Freeform Shape → Match Edge    

(Shape Studio) Edit → Match Edge      

Menu Edit → Surface →Match Edge  

 

   Non-Proportional Zoom 

What is it? 

The Non-Proportional Zoom command has three main enhancements. 

• You can dynamically designate the Non-Proportional Zoom aspect ratio of the display. 

• You can set a Non-Proportional Zoom and change back and forth between the set Non-

Proportional Zoom and the regular display. 

• The Non-Proportional Zoom Options dialog box is where you can specify the behavior of 

your zoom operation. 

The Analyze Shape toolbar has been updated to address the enhancements. 

   Display Non-Proportional Zoom 

• Clicking this option will display the previously set Non-Proportional Zoom. 

• Clicking this option more than once switches between the currently set Non-Proportional 

Zoom display and the regular display so you can go back and forth between displays. 

• If no Non-Proportional Zoom display has been set, this option is unavailable. 

   Set Non-Proportional Zoom 

• Clicking this option sets a Non-Proportional Zoom of the graphics display. 

• If you click Set Non-Proportional Zoom when Display Non-Proportional Zoom 

is inactive, any previously set Non-Proportional Zoom will be lost. 

• If a set Non-Proportional Zoom is displayed and you click Set Non-Proportional 
Zoom, the existing set Non-Proportional Zoom will be updated. 
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   Non-Proportional Zoom Options 

• Clicking this option opens the Non-Proportional Zoom Options dialog box. 

• In the dialog box, you can specify the Method used for the Non-Proportional Zoom. 

There are two options: 

• Rectangle - The display aspect ratio is defined by dragging an explicit 

rectangle. This functions like previous releases. 

• Dynamic - The aspect ratio is dynamically defined by dragging the cursor. The 

non-proportional zoom is set once the left mouse button is released. 

• Using either method, you can now repeatedly adjust your Non-Proportional 

Zoom designation without leaving the function. 

• In Dynamic mode, you can establish a center for your Non-Proportional Zoom using the 

Anchor Center check box: 

•    Anchor Center 

• The Non-Proportional Zoom will always center on the first click of the 

cursor. 

•    Anchor Center 

• The Non-Proportional Zoom will always center about the center of the 

view. 

• The screen will not pan upon release of the left mouse button.  

• In Dynamic mode, you can use the Sensitivity slider to adjust the exaggeration of the 

Non-Proportional Zoom so larger or smaller zoom operations can be effected with one 

cursor drag. 

 

Why should I use it? 

• To evaluate the curvature flow of surfaces and curves when you edit poles using tools such as X-

form or Studio Spline. 

• To evaluate the curvature flow of surfaces and curves as a part of design quality validation such 

as checking the uniformity of the pole structure of curves, surfaces or sheet bodies. 

Where do I find it? 

Application Modeling and Shape Studio 

Toolbar 
Analyze Shape → Display Non-Proportional Zoom    

Analyze Shape → Set Non-Proportional Zoom    

Analyze Shape → Non-Proportional Zoom Options    
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Menu View → Operation →Display Non-Proportional Zoom 

View → Operation → Set Non-Proportional Zoom 

View → Operation → Non-Proportional Zoom Options 

 

   Edge Symmetry 

What is it? 

The new Edge Symmetry command matches edge geometry and continuity to a centerline plane for use 

in developing surfaces that are symmetrical across a plane. 

• You can define the centerline plane by: 

– Selecting an existing plane. 

– Using one of the principal XYZ planes (XC-ZC is the default). 

– Using basic plane definition methods. 

• You can specify an offset value from the designated plane using the Offset option. 

• You can modify degree and patch parameterization. 

• You can specify the method used for designating edge symmetry matching:  

– Movement – Use to specify if poles will be moved the minimum distance necessary to 

achieve the match (Normal), or if they will be moved using a projection algorithm to 

make the match (Project). 

– Shape Control – Use to control the position of selected poles and rows of poles and 

control the shape-blending factors of Blend, Depth and Skew. 

• You can specify G0, G1, G2, and G3 continuity for edge symmetry matching and check before 

and after deviation values based on your specifications. 

Where do I find it? 

Application Modeling and Shape Studio 

Toolbar 
(Modeling) Freeform Shape → Edge Symmetry    

(Shape Studio) Edit → Edge Symmetry     

Menu Edit → Surface → Edge Symmetry 
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Drafting 

Chinese (GB) and Russian (ESKD) default standards settings 

What is it? 

Two new default standards files are available to configure specific annotation and drafting view 

preferences in accordance with Chinese and Russian drafting standards 

Why should I use it? 

Use either of these standards to automatically configure over 200 annotation and drawing view 

preferences for your PMI and Drafting environments. 

Where do I find it? 

To set the standard for the current NX session 

Application Drafting and PMI 

Menu Tools→Drafting Standard 

 

To set the default standard or create a custom standard 

Menu File→Utilities→Customer Defaults 

Location in dialog box Drafting→General→Standard tab 

 

Weld symbol redesign and single flange JIS support 

What is it? 

The following enhancements are added to the Drafting and PMI weld symbols: 

• The weld symbol is redesigned to display in a more standards-compliant manner. The display is 

based on the text height specified for the symbol.  
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Previous weld symbol 

 

Current weld symbol 

 

All new weld symbols will be created using this standards-compliant arrangement. Existing weld 

symbols will be updated to reflect the standards-compliant arrangement if the 

Preferences→Drafting→General tab→Maintain Object Version On Update option is 

not selected. 

 Caution 

If you do not select the Maintain Object On Update option, all objects in the drawing 

will be updated, not just the weld symbols 

 

• A new Weld Space Factor option provides additional control over the spacing between the 

different components of the weld symbol. 

 

Weld Space Factor = 1 

 

Weld Space Factor = 2 
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• Support for the creation of single flange JIS weld symbols is also provided. 

 

JIS single flange weld symbol 

Where do I find it? 

Create or edit the Weld Space Factor of a weld symbol 

Application Drafting 

Toolbar Annotation→Weld Symbol  

Menu Insert→Symbol→Weld Symbol 

Location in dialog box Settings group 

 

Set the preference and default of the Weld Space Factor for all weld symbols 

Application Drafting 

Toolbar Drafting Preferences→Annotation Preferences  

Menu Preferences→Annotation 

File→Utilities→Customer Defaults 

Location in dialog box Drafting Preferences dialog box →Symbols tab→Weld 

Customer Defaults dialog box 

→Drafting→General→Standard tab→Customize 
Standard→Other Symbols→Weld tab 
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NX Sheet Metal 

   Resize Bend Radius enhancement 

What is it? 

A Fixed Unfolded Length type option is available. Use this option to resize selected bends while 

keeping a specified face or edge stationary. 

Select Face/Edge    is available to specify the stationary edge or face. 

When you create the Fixed Unfolded Length type of Resize Bend Radius feature and change the 

bend radius, the dimensions of the unfolded model remain fixed, but the overall dimensions of the folded 

model change. 

The figure on the right shows the Sheet Metal part after it was resized using the Fixed Unfolded 
Length type. The unfolded length of the Sheet Metal part remains the same, but the overall folded 

dimensions of the part are changed. 

 

Initial bend radius = 3 

 

Modified bend radius = 5 

 

Why should I use it? 

You can depict a bend in various intermediate stages, when you use the Fixed Unfolded Length type 

and resize selected bends in conjunction with the Resize Bend Angle command. 

You can also: 

• Study over-bending and springback effects of selected bends. 

• Perform forming studies on an already-designed Sheet Metal part. 
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Where do I find it? 

Application NX Sheet Metal 

Toolbar 
NX Sheet Metal→Resize Bend Radius    

Menu Insert→Resize→Resize Bend Radius 

Location in dialog box Type group→Fixed Unfolded Length 

Stationary Face/ Edge group→Select Face/Edge    

 

   Rebend enhancement 

What is it? 

When you use the Rebend command, you can specify a face or an edge that remains stationary during 

the rebend operation. 

You can control the positioning of the resultant body after the rebend operation. 

Select Face or Edge    is available to specify the stationary face or edge. 

 

 Selected bend in the flattened Sheet Metal part 

for the rebend operation 

 

 

 Rebend generated without specifying a 

stationary face. The resulting body is 

positioned at its default location. 
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 Rebend generated using a stationary face for 

reference. The positioning of the resulting 

body is changed. 

 

Where do I find it? 

Application NX Sheet Metal, Flexible Printed Circuit Design 

Toolbar 
NX Sheet Metal→Rebend    

Flexible Printed Circuit Design→Rebend    

Menu Insert→Form→Rebend 

Location in dialog box 
Stationary Face or Edge group→Select Face or Edge    
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Chapter 6:  Manufacturing 

Planar Milling 

Overlap Distance 

What is it? 

The Overlap Distance option for the Planar Mill, Planar Profile, Profile 3D and Solid Profile 3D 

operation subtypes has changed. It now affects the current operation rather than the following clean up 

operation. The location of the option has also changed. 

During a sequence of rest milling operations, use the Overlap Distance option to extend the path for 

the current operation so that it overlaps the cut region of another operation. Overlap Distance is only 

available when you use the Use 2D IPW or Use Reference Tool options. 

 

 

Overlap Distance set to zero 

 

Overlap Distance set to a value of 15.00 

 

Why should I use it? 

Using this option helps you eliminate scallops and obtain a full clean up between tool paths. 

Where do I find it? 

Application Manufacturing 

Prerequisite For Planar Mill, Planar Profile, Profile 3D and Solid Profile 3D 

operation subtypes, the In Process Workpiece option must be set 
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to Use 2D IPW or Use Reference Tool. 

Menu Insert→Operation 

Location in dialog box [Planar Milling] operation dialog box→Path Settings 

group→Cutting Parameters   →Containment 
tab→Overlap group 

 

Reference Tool 

What is it? 

The Reference Tool option is now available in the Planar Mill, Planar Profile, Profile 3D and 

Solid Profile 3D operation subtypes. 

Use the Reference Tool option to create a new operation with a smaller tool that references a larger 

tool. The smaller tool only removes material that would  not have been cut by the larger tool. You can 

place the reference tool operation before or after operations with larger tools. 

Place the reference tool operation before operations using the larger tool to first rough cut corners with a 

smaller tool. 

   

The yellow area shows the areas cut with the 

smaller tool. The tool path was contained in those 

areas by the reference tool.  

 

   

The green area shows the areas cut with the larger 

tool. The tool path was previously contained in 

the yellow areas by the reference tool. 
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Place the reference tool operation after operations using the larger tool to cut areas that the larger tool 

could not fit into. 

   

The part has been roughed with a large tool. The 

reference tool operation will remove the 

remaining material. 

 

   

The yellow area shows the areas cut with the 

smaller tool. The tool path was contained in the 

yellow areas by the reference tool. 

 

Why should I use it? 

Using this option helps you eliminate tool motion where there is no material. The tool path can be created 

before or after the roughing paths. 
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Where do I find it? 

Application Manufacturing 

Prerequisite For Planar Mill, Planar Profile, Profile 3D and Solid Profile 3D 

operation subtypes, the In Process Workpiece option must be set 

to Use Reference Tool. 

Menu Insert→Operation 

Location in dialog box [Planar Milling] operation dialog box→Path Settings 

group→Cutting Parameters   →Containment 
tab→Reference Tool  group 

 

Use 2D IPW 

What is it? 

The Use 2D IPW option replaces the Save 2D In Process Workpiece option. 

Use the Use 2D IPW option in Planar Milling to machine only the material that is left on the part in 

subsequent operations. The software tracks the remaining material from one operation to the next. 

When you use this option, the software: 

• Finds uncut material by evaluating previous Planar Milling operations that share the same  part 

geometry. 

• Only recognizes valid Planar Milling operations including Planar Profile, Profile 3D, Solid 
Profile 3D, and Planar Mill. If other operations are found, the software ignores them and uses 

the 2D IPW from the last Planar Milling operation. 

• Supports the use of ball endmills. 

 

  

The first tool path roughs out most of the material. 
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The second tool path removes only the remainder of the material 

recognized in the IPW. 

 

Why should I use it? 

When you use this option, you avoid tool motion where material has been removed by previous 

operations. 

Where do I find it? 

Application Manufacturing 

Prerequisite You must be in a Planar Mill, Planar Profile, Profile 3D or Solid 
Profile 3D operation. 

Menu Insert→Operation 

Location in dialog box [Planar Milling Operation] dialog box→Path Settings 

group→Cutting Parameters   →Containment tab→Blank 

group→In Process Workpiece list→Use 2D IPW 

 

Output Contact/Tracking Data 

What is it? 

The Output Contact/Tracking Data option is now available for Profile 3D and Solid Profile 3D 

operations. 

Use the Output Contact/Tracking Data option to set Contact Contour cutter compensation. When you 

use this option, the cutter compensation is output for several tool contact locations rather than one tool 

end location, for all cutting motions in an NC operation. 

Contact Contour is also referred to as full radius cutter compensation or material edge contouring. Use 

contact contour cutter compensation for tool paths generated at the circumference of the tool radius.  

Why should I use it? 

Use this option when the machine operator will enter the full tool size, instead of the variation from the 

programmed size. 
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Where do I find it? 

Application Manufacturing 

Prerequisite The operation must have a finish pass or profile pass. 

Menu Insert→Operation 

Location in dialog box Profile 3D, Solid Profile 3D operation dialog box→Non Cutting 

Moves   →More tab→Cutter Compensation group 
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ISV 

Automatic Part, Blank, and Check geometry in ISV 

What is it? 

ISV recognizes the Part, Blank and Check Geometry defined for an operation. It is not necessary to 

define the geometry again in the Machine Tool Navigator. 

 

Where do I find it? 

Application Manufacturing 

Prerequisite Operations with defined geometry and generated tool paths.  

A defined machine assembly. 

 

Preview Motion 

What is it? 

Use the Preview Motion command to control the position of each machine axis and view it relative to 

the other axes. 
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Why should I use it? 

You can view the machine tool motion of all axes from one dialog box without simulating the tool path. 

You can also dynamically move each axis between its limits, as you would move an axis on the real 

machine tool. 

Where do I find it? 

Application Manufacturing or Machine Tool Builder 

Prerequisite A defined machine assembly. 

Machine Tool Navigator Right-click in the background→Preview Motion 

 

Synchronization 

What is it? 

You can now view synchronization status in the Channel column of the Operation Navigator. You 

can find program groups with synchronization data, and delete the synchronization, directly from the 

Operation Navigator. 

 

Why should I use it? 

This allows you to remove synchronization without opening the Synchronization Manager. 
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Where do I find it? 

Application Manufacturing 

Prerequisite A Program parent group with synchronization data 

Operation Navigator Right-click the Program group→Toolpath→Synchronize 

Right-click the Program group→Toolpath→Remove 
Synchronization 

 

Post Builder 

Post Builder support for Siemens Sinumerik controllers 

What is it? 

The following template posts support Siemens Sinumerik controllers: 

• Sinumerik_840D supports milling machine with the Sinumerik 840D controller. 

Support includes CYCLE800 and TRANS/AROT coordinate rotation output. To output 

coordinate rotation codes, you must set a proper LOCAL MCS with CSYS Rotation special 

output. 

• Sinumerik_840D_lathe supports 2-axis turning machine with the Sinumerik 840D controller. 

• Sinumerik_828D supports milling machine with the Sinumerik 828D controller. 

• Sinumerik_802D_3axis supports 3-axis milling machine with the Sinumerik 802D controller. 

You can add the following user-defined start events to support the Siemens controllers: 

• Add a start event for the Sinumerik 840D controller to a single milling operation, or to the lowest 

level program group in the Program view of the Operation Navigator. The default parameter 

settings in the Sinumerik 840D start event dialog box are the same as the default settings in the 

Sinumerik 840D template post. 

If you choose Swiveling in the Transformation option of the Sinumerik_840D user-defined 

event, CYCLE800 is output and transformation is turned off (TRAFOFF), otherwise 

TRANS/AROT is output for coordinate rotation. 

For drilling cycles, if the work plane is not the XY plane, coordinate rotation codes could be 

output without the LOCAL MCS setting. 

The Sinumerik 840D user-defined event is available in the Sinumerik_840D template post. 

• Add the DNC Header user-defined event to the top working program group under 

NC_PROGRAM so that the NC file can be accessed by the Siemens MCIS (Motion Control 

Information System). 

The DNC Header user-defined event is available in all milling template posts. 

• Add the Sinumerik Program Control user-defined event to a program group so that you can 

call external subroutines. 
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The Sinumerik Program Control user-defined event is available in the Sinumerik_840D and 

Sinumerik_828D template post. 

 Note 

DNC Header and Sinumerik Program Control user-defined events should not be 

assigned to an operation. 

 

You can set the Sinumerik version in Post Builder with the custom command 

PB_CMD_Sinumerik_Version in Sinumerik_840D postprocessors. 

Sinumerik version 6 and later support CYCLE832 high speed machining G code output. 

 

Where do I find it? 

Post Builder template posts 

Application Post Builder 

Menu File→New 

Location in dialog box Controller group→Library list 

 

 

 

Custom commands 

Application Post Builder 

Location in dialog box Program & Tool Path tab→Custom Command tab 

 

 

 

Sinumerik 840D user-defined events 

Application Manufacturing 

Menu Insert→Operation 

Location in dialog box 
Operation dialog box→Machine Control group→Edit    

(Start of Path Events) 
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Improved Post performance 

What is it? 

You can add the new custom command PB_CMD_activate_Fanuc_turbo_mode to the Start of 

Program event of the Program Start Sequence. This command improves the postprocessing performance 

of Fanuc style posts for four and five-axis machines. 

There are also general improvements to NX Post performance. 

Where do I find it? 

Import the PB_CMD_activate_Fanuc_turbo_mode custom command. 

Application Post Builder 

Location in dialog box Program & Tool Path tab→Custom Command tab→Import 

File location POSTBUILD/pblib/custom_command/pb_cmd_activate_turbo_mode.tcl 

 

 

 

Add the custom command to the Start of Program event. 

Application Post Builder 

Location in dialog box Program & Tool Path tab→Program tab→Program Start 
Sequence marker 
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   Parallel Generate 

What is it? 

Use the Parallel Generate command to generate operations in the background while you continue 

working. Select any number of operations at the same time, and they count as one parallel process. You 

can: 

• Run multiple processes concurrently. 

• Stop parallel processes with the Stop Parallel Generate command. 

 Note 

• You must select all the operations that use an In-Process Workpiece together and submit 

them as one process. 

• The part must remain open in the current session. You can continue to work on it, or work 

on another part, but you cannot close the part. This is different than batch processing, 

which requires you to close the part and wait until the batch processing is complete to open 

the part. 

 

Use the Maximum Concurrent Processes customer default to specify how many processes the 

software can run concurrently. The maximum number is four. 

New operation status indicators include the following: 

•    Pending 

This indicates that the operation is in queue for a scheduled process. The indicator appears when 

the maximum number of concurrent processes is exceeded. 

•    Parallel Generating 

This indicates that the operation is processing in the background. 

 Tip 

When the background processing is complete, the operation status changes to Repost   . There is 

no notification message when the process is complete. 

 

Why should I use it? 

Using the Parallel Generate command helps if: 

• Your computer has multiple cores or processors, and you want to use them to speed up tool path 

processing. 

• Your computer has a slower processor, and you do not want to wait for complex tool paths to 

generate before working on another operation. 

Where do I find it? 

Parallel Generate commands 
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Application Manufacturing 

Toolbar 
Operations→Parallel Generate Tool Path    

Operation Navigator Right-click the selected operations→Parallel Generate/Stop 
Parallel Generate 

 

 

Maximum Concurrent Processes customer default 

Application Manufacturing 

Menu File→Utilities→Customer Defaults 

Location in dialog box Manufacturing→Operation→General tab→Parallel Tool 
Path Generation group 

 

  



78    What's New in NX 7   whatsnew7 0  

Store postprocessor time in Teamcenter 

What is it? 

Machining time calculated by the postprocessor is automatically stored in the  Duration property of an 

Activity in Teamcenter. 

 

Where do I find it? 

Application Manufacturing 

Prerequisite Operations with tool path generated. 

Operation Navigator Right-click the Program group→Tool Path→Synchronize 

Right-click the operation or Program group→Post Process 
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Face Milling-Negative Floor Stock 

What is it? 

You can now specify a negative Final Floor Stock value for the following Face Milling operation 

subtypes: 

   Face Milling Area 

   Face Milling 

   Face Milling Manual 

All moves created on the face cutting planes are moved down by the specified value.

 

Why should I use it? 

Entering a negative Final Floor Stock value is useful when you have to make a minor adjustment for a 

modeled dimension to meet a functional requirement. For example, when you have to shorten the height 

of a face or move a face into the part. 

Where do I find it? 

Application Manufacturing 

Menu Insert→Operation 

Location in dialog box Create Operation dialog box→Operation Subtype 

group→Face Milling Area   /Face Milling   /Face 

Milling Manual    

Face Milling operation dialog box→Path Settings group→Cutting 

Parameters   → Stock tab→Stock group→Final Floor 
Stock 

 

  



80    What's New in NX 7   whatsnew7 0  

Non Cutting Moves Enhancement Smooth Traverse 

What is it? 

A Traverse Type, Smooth option is added to non cutting moves in fixed and variable contouring 

operations. 

 

Traverse Feedrate 

 

 

 

Stepover Feedrate 

 

 

 

 

Why should I use it? 

This traverse type lets the tool merge tangentially from a cut, retract, or approach move, to the next cut, 

engage, or approach move without slowing down.  
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Where do I find it? 

Application Manufacturing 

Dialog Box [Surface Contouring Milling] operation→Non Cutting Moves 

Location in dialog box Transfer/Rapid tab→Between Regions and Within Regions 

group→Traverse Type→Smooth 
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Fill and Silhouette Fill display options 

What is it? 

Fill and Silhouette Fill display options are added to help you view the area cut by the wire.  

 

 

Fill 

 

 

 

Silhouette Fill 

 

 

Why should I use it? 

It can be difficult to see the area being cut when displaying the tool path in a wireframe silhouette. These 

display options shade the actual cut operation, so that you can ensure that all the material within a region 

or boundary is cut. 
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Where do I find it? 

Application Manufacturing 

Location in dialog box Operation dialog box→Tool Path group→Edit Display→Path Display 

 

Preview projects 

What are preview projects? 

What is it? 

Preview projects are intended for production release in the future. 

 

Why should I use it? 

The preview gives you an opportunity to do some real world testing, and then give us some feedback 

before the products are officially released. 

Where do I find it? 

To test preview projects, contact your customer support representative. 

Inspection Programming 

What is it? 

Inspection Programming enables you to quickly and accurately define complete, verifiable machine 

inspection programs for Coordinate Measuring Machines (CMMs). Based on the NX CAM architecture, 

Inspection Programming uses: 

• Part geometry from the NX solid model. 

• Automatic generation of features and tolerance information from NX Product Manufacturing 

Information (PMI). 

• Full machine simulation using NX collision detection. 

 

Why should I use it? 

Because Inspection Programming is fully integrated with NX and PMI, annotations are easily available on 

the CAD model and can encapsulate requirements as well as part information. CMM inspection programs, 

which are stored and maintained in Teamcenter, can be quickly constructed without any required 

programming knowledge. The Inspection Programming preview showcases: 

• Functionality for creating feature, tolerance, and paths manually. 

• Three-axis scanning. 
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• Generic Dimensional Measurement Interface Standard (DMIS) output. 

Inspection Programming aims to eliminate expensive manual inspection gages, reduce tooling costs and 

machine reprogramming time, and better analyze features and tolerances against measured data. 

Where do I find it? 

To test Inspection Programming, contact your customer support representative. 

Wire/EDM No-core Follow Periphery 

What is it? 

You can generate a continuous cut using the Follow Periphery    cut pattern option. You can either 

create a thread hole, or have the system infer it. This cut pattern cuts from the inside out to ensure that all 

material with the boundaries is removed. 

 

Why should I use it? 

Use this option when the Spiral    cut pattern cannot remove all material within the boundaries, or 

give you the desired surface finish. 

Where do I find it? 

Application Manufacturing 

Prerequisite Type must be set to wire_edm in the Create Operation dialog 

box. 

The NOCORE operation subtype must be selected. 

Location in dialog box 
NOCORE→Cut Pattern→Follow Periphery    
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Chapter 7:  Systems Design 

PCB Exchange 

PCB.xchange  application name change 

What is it? 

The PCB.xchange  application is now called PCB Exchange. 

Space Systems Thermal solution 

What is it? 

You can now create a Space Systems Thermal solution from your PCB Exchange model by selecting the 

Space Thermal option in the Create ESC Solution dialog box. 

Why should I use it? 

Use the Space Thermal option when you want to solve a thermal model of your PCB using the Space 
Systems Thermal simulation. 

Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Thermal/Flow Simulation  → Create ESC 
Solution 

Toolbar 
PCB Exchange → Create ESC Solution    

Location in dialog box Output Option group → Write Boundary Conditions list → 

Space Thermal 

 

View or modify a specific NX object 

What is it? 

When you select an NX object, the new Object and Feature commands bring up the dialog box that 

shows the right attributes applied to this object. For example, PCB Exchange brings up the Keep-in 
Area Attributes dialog box if the specified NX object was designed as a keep-in area. 

• The Object command lets you select an NX object from the graphics window. 
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• The Feature command lets you select an NX object from a list in the Feature Selection 

dialog box listing all features in the model. 

If the selected NX object has no PCB attributes, PCB Exchange issues an error message. 

If you select more than one object, PCB Exchange shows the PCB attributes of the first selected object. 

Why should I use it? 

These new commands help you to quickly find what PCB Exchange attributes apply to a specific NX 

object. It is very useful when you have many objects in the model and you don't know what they are. 

Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Edit Attributes  → Object 

PCB Exchange → Edit Attributes  → Feature 

 

PCB Exchange for Zuken 

PCB.xchange + Zuken application name change 

What is it? 

The PCB.xchange + Zuken application is now called PCB Exchange for Zuken. 
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Chapter 8:  Digital Simulation 

Advanced Simulation 

Solver version support 

For each released version of NX, the following tables list the supported solver versions for import, export, 

and the post-processing of results. Note: 

• The version listed in the ―Import ASCII‖ and ―Import Binary‖ rows is the solver version that was 

generally available when the NX version was released. In general, the import of the solver ASCII 

and binary files should be upwards compatible. Therefore, you should be able to import them into 

the most recent version of NX. However, in general: 

– ASCII files are backwards compatible for import into NX. If you import an ASCII file 

from a newer version of the solver than is officially supported, the software simply 

ignores any new fields/options that aren't supported in the current NX release. 

– Binary files are not backwards compatible. For example, you can import a binary file 

created by NX Nastran 5.0 into NX 6.0.2 , but you might not be able to import a binary 

file created by NX Nastran 6.1 into NX 5. 

• The version listed in the ―Export ASCII‖ rows is the solver version that was available when the 

NX version was tested. In general, the exported solver input file is upwards compatible for that 

solver. Backwards compatibility is not guaranteed. For NX Nastran, the Model Setup Check 

function in Advanced Simulation tries to flag potential version incompatibility issues. 

• The version listed in the ―Post-processing Results‖ rows is the version of the solver results that 

was tested in the listed NX version. In general, results from earlier solver versions are also 

supported. 

NX7 

Solver File Type NX 7 

NX Nastran Import ASCII (.dat) 6.1 

Import Binary (.op2) 6.1 

Export ASCII (.dat) 6.1 

Post-processing of Results 6.1 

MSC Nastran Import ASCII (.dat) 2008r1 

Import Binary (.op2) 2008r1 

Export ASCII (.dat) 2008r1 
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Solver File Type NX 7 

Post-processing of Results 2008r1 

Abaqus Import ASCII (.inp) 6.8-1 

Import Binary  N/A 

Export ASCII (.inp) 6.8-1 

Post-processing of Results 6.8-EF2 

ANSYS Import ASCII (PREP7, CDB) 12 

Import Binary (.rst, .rth) 12 

Export ASCII (.inp) 12 

Post-processing of Results 12 

LS-DYNA Import ASCII N/A 

Import Binary N/A 

Export ASCII (.k) 971R3.2.1 

Post-processing of Results N/A 

 

NX 6 releases 

Solver File Type NX 6 NX 6.0.1 NX 6.0.2 NX 6.0.3 

NX Nastran Import ASCII (.dat) 6.0 6.1 6.1 6.1 

Import Binary (.op2) 6.0 6.1 6.1 6.1 

Export ASCII (.dat) 6.0 6.1 6.1 6.1 

Post-processing of 

Results 

6.0 6.0 6.1 6.1 

MSC 
Nastran 

Import ASCII (.dat) 2007r1 2008r1 2008r1 2008r1 

Import Binary (.op2) 2007r1 2008r1 2008r1 2008r1 

Export ASCII (.dat) 2007r1 2008r1 2008r1 2008r1 

Post-processing of 

Results 

2007r1 2008r1 2008r1 2008r1 

Abaqus Import ASCII (.inp) 6.7-1 6.8-1 6.8-1 6.8-1 

Import Binary  N/A N/A N/A N/A 

Export ASCII (.inp) 6.7-1 6.8-1 6.8-1 6.8-1 

Post-processing of 

Results 

6.7-5 6.8-1 6.8-3 6.8-EF2 
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Solver File Type NX 6 NX 6.0.1 NX 6.0.2 NX 6.0.3 

ANSYS Import ASCII (PREP7, 

CDB) 

11 11 SP1 11 SP1 11 SP1 

Import Binary (.rst, .rth) 11 11 SP1 11 SP1 11 SP1 

Export ASCII (.inp) 11 11 SP1 11 SP1 11 SP1 

Post-processing of 

Results 

11 SP1 11 SP1 11 SP1 11 SP1 

LS-DYNA Import ASCII N/A N/A N/A N/A 

Import Binary N/A N/A N/A N/A 

Export ASCII (.k) 971R2 971R2 971R3.2.1 971R3.2.1 

Post-processing of 

Results 

N/A N/A N/A N/A 

 

NX 5 releases 

Solver File Type NX 5 NX 5.0.1 NX 5.0.2 NX 5.0.3 NX 5.0.4 NX 5.0.5 NX 5.0.6 

NX Nastran Import ASCII 

(.dat) 

5.0 5.1 5.1 5.1 5.1 5.1 5.1 

Import Binary 

(.op2) 

5.0 5.1 5.1 5.1 5.1 5.1 5.1 

Export ASCII 

(.dat) 

5.0 5.1 5.1 5.1 5.1 5.1 5.1 

Post-processing 

of Results 

5.0 5.0 5.1 5.1 5.1 5.1 6.0 

MSC 
Nastran 

Import ASCII 

(.dat) 

2005 2005 2007 2007 2007 2007 2007r1 

Import Binary 

(.op2) 

2005 2005 2007 2007 2007 2007 2007r1 

Export ASCII 

(.dat) 

2005 2005 2007 2007 2007 2007 2007r1 

Post-processing 

of Results 

2005 2005 2007 2007 2007 2007 2008r1 

Abaqus Import ASCII 

(.inp) 

6.6 6.6 6.7-1 6.7-1 6.7-1 6.7-1 6.7-1 

Import Binary  N/A N/A N/A N/A N/A N/A N/A 

Export ASCII 

(.inp) 

6.6 6.6 6.7-1 6.7-1 6.7-1 6.7-1 6.7-1 
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Solver File Type NX 5 NX 5.0.1 NX 5.0.2 NX 5.0.3 NX 5.0.4 NX 5.0.5 NX 5.0.6 

Post-processing 

of Results 

6.6 6.6 6.7-1 6.7-1 6.7-1 6.7-1 6.8-1 

ANSYS Import ASCII 

(PREP7, CDB) 

10 10 11 11 11 11 11 

Import Binary 

(.rst, .rth) 

10 10 11 11 11 11 11 

Export ASCII 

(.inp) 

10 10 11 11 11 11 11 

Post-processing 

of Results 

10 11 11 11 11 11 11 SP1 

 

NX 4 releases 

Solver File Type NX 4 NX 4.0.1 NX 4.0.2 NX 4.0.3 NX 4.0.4 

NX 
Nastran 

Import ASCII (.dat) 4.0 4.1 4.1 5.0 5.0 

Import Binary (.op2) 4.0 4.1 4.1 4.1 4.1 

Export ASCII (.dat) 4.0 4.1 4.1 5.0 5.0 

Post-processing of 

Results 

4.0 4.1 4.1 5.0 5.0 

MSC 
Nastran 

Import ASCII (.dat) 2005 2005 2005 2005 2005 

Import Binary (.op2) 2005 2005 2005 2005 2005 

Export ASCII (.dat) 2005 2005 2005 2005 2005 

Post-processing of 

Results 

2005 2005 2005 2005 2005 

Abaqus Import ASCII (.inp) 6.5-1 6.5-1 6.5-1 6.6 6.6 

Import Binary  N/A N/A N/A N/A N/A 

Export ASCII (.inp) 6.5-1 6.5-1 6.5-1 6.6 6.6 

Post-processing of 

Results 

6.5-1 6.5-1 6.5-1 6.6 6.6-3 

ANSYS Import ASCII 

(PREP7, CDB) 

8 9 9 10 10 

Import Binary (.rst, 

.rth) 

8 9 9 10 10 

Export ASCII (.inp) 8 9 9 10 10 
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Solver File Type NX 4 NX 4.0.1 NX 4.0.2 NX 4.0.3 NX 4.0.4 

Post-processing of 

Results 

9 9 9 10 10 

 

Gasket analysis support 

What is it? 

For NX Nastran, ANSYS, and Abaqus models, this release includes enhancements that make it possible 

for you to model and analyze gaskets. Gaskets are relatively thin components which you can place 

between two bodies to create a sealing effect and prevent the leakage of fluid. Gaskets can be made of 

many different materials, such as rubber or composites. The gasket material itself is usually under 

compression. 

 

To support gasket modeling, this release includes: 

• For NX Nastran or ANSYS, a new Gasket material type option in the Assign Material dialog 

box. When you select Gasket as the material type, you can then use the new Gasket Material 
dialog box to define all the necessary properties for modeling a gasket material. 

• A new Gasket Results page in the Structural Output Requests dialog box to request the 

output of gasket results for NX Nastran analyses. See **Unsatisfied xref title** for more 

information. 

• For Abaqus, support for several different types of Abaqus gasket elements, as well as support for 

a new Gasket Section type of physical property table and Gasket Behavior material. See 

**Unsatisfied xref title** for a complete list of the supported elements. 
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General gasket modeling process 

Although the details of the process for modeling and analyzing gaskets differ depending on your specified 

solver, the overall process fairly standard. In general, you model a gasket as a very thin solid body that 

lies between two other solid bodies. 

 

You mesh the gasket itself, along with the bodies on either side, with solid elements. Generally, the mesh 

on the gasket is only a single layer of solid elements. To ensure the proper connectivity in a gasket 

analysis, you must ensure that the nodes from the gasket mesh are connected to the nodes in the meshes 

on the surrounding bodies. The specific requirements for how you establish this connection depend on 

your solver. In general, you can either: 

• Ensure that the elements from the gasket mesh share nodes with the elements on the two adjacent 

bodies. In Advanced Simulation, you can use a Glue Coincident type of Mesh Mating 
Condition, for example, to ensure that the nodes are shared. You can also merge nodes between 

the adjacent bodies. 

• Connect the nodes on the gasket mesh to the nodes on the surrounding bodies with constraints, 

such as an MPC type of Manual Coupling. 

General capabilities 

Command Finder for CAE 

What is it? 

Command Finder is a search tool that helps you find a specific NX command associated with the 

words or phrases you enter.  

For this release, Command Finder now supports all commands in the Advanced Simulation and Design 

Simulation applications.  

From the list of commands, you can: 

• Display the command location. 

• Launch the command, if it is available in the current application.  

• Display the Help information for the command.  

For boundary conditions, you can also search on the solver input name, such as PLOAD4 for an NX 

Nastran Pressure load. 
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Use customer defaults for the Command Finder to: 

• Save a cached file of all menu and toolbar commands. 

• Identify a location for a custom list of words and phrases associated with specific commands. 

• Search for a command using a secondary language. 

Where do I find it? 

Command Finder customer defaults 

Menu File→Utilities→Customer Defaults→Gateway→User 
Interface 

Location in dialog box Command Finder tab 

 

Command Finder command 

Application Advanced Simulation or Design Simulation 

Menu Help→Command Finder 

Toolbar 
Standard toolbar→Command Finder     
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Display controls 

Displaying 2D element thickness values 

What is it? 

You can use the new Thickness Information command in the Simulation Navigator to display the 

2D element thickness values in your model. This lets you verify the thickness values the software will 

apply when you either export or solve your model. Advanced Simulation provides you with a variety of 

ways to define the thickness of 2D elements. For example, the thickness values can be derived from the 

thickness of a midsurface or specifically assigned through either Element Associated Data or a 

physical property table. Because of the multitude of methods for specifying element thickness, you need a 

way to verify that those thickness values are defined correctly prior to solving your model. You can also 

use Thickness Information to create a spatial field of the 2D element thickness values. 

Creating a display of element thickness values 

Thickness Information creates a color-coded line display that shows the general statistical distribution 

of the thickness values across your 2D mesh. The following example shows a turbine blade model (A) 

which we used to create and mesh a midsurface (B). (C) shows the thickness display for the 2D elements 

on that midsurface. 

   

• The lines represent the actual thickness values of the elements. The software draws those lines 

along each element's normal at the element's center of gravity. You can use the Line Scale 

option in the Thickness Information dialog box to control the overall length of the lines. 

• The colors represent the range of thickness values across the model. These colors let you visually 

verify that the thickness values are properly distributed across the mesh. You can use options in 

the Thickness Information dialog box to control the colors the software assigns to each 

thickness range. 

– Mid Range Thickness elements have a thickness that is within one standard deviation 

(σ) either above or below the mean thickness value for the mesh. 

– Max Range Thickness elements have a thickness that is greater than one standard 

deviation above the mean thickness value for the mesh. 
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– Min Range Thickness elements have a thickness that is less than one standard 

deviation below the mean thickness value for the mesh. 

– Zero Thickness elements do not have an assigned thickness value. 

You can use a thickness display to quickly identify: 

• Any sudden changes in color that may indicate incorrectly assigned thickness values. 

• Elements that do not have an assigned thickness. 

Creating fields from element thickness displays 

You can also use the Thickness Information command to create a spatial field of thickness values 

from the 2D elements in your model. In the Thickness Information dialog box, when you select the 

Create Field option, the software generates a new field and places it in the Fields node in the 

Simulation Navigator. 

Creating a thickness field can be helpful if you are working with a model in which the thickness of mesh 

is being derived from a midsurface. On a large model, the derivation of thickness data from a midsurface 

can be time and resource intensive since the software must recalculate the thickness each time you use 

Thickness Information to generate a display. If you are iterating through the meshing process with 

different element sizes, you can use the new Create Field option to generate a field from the midsurface 

data the first time you use the Thickness Information command. You can edit the Mesh Associated 
Data for that mesh and change the specified Thickness Source from Midsurface to Field. You can 

then select the newly created thickness field. 

The ability to create a thickness field from a display of your 2D element thicknesses also allows you to 

edit or copy that thickness data. You can then reuse that modified data in either the same model or another 

model. For example, you can import a Nastran bulk data file that contains a coarse mesh in which the 

element thickness values are defined directly on the CQUAD4 elements. You can then use the new 

Create Thickness Field capability to generate a thickness field from that data. If you then remesh the 

model with a finer mesh, you can use that thickness field to map the original thickness values to the new 

mesh 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains a 2D mesh 

Simulation Navigator Right-click the appropriate 2D mesh collector or 2D mesh and choose 

Thickness Information 

 

Persistently displaying 2D element thickness 

What is it? 

Use the Display 2D Element Thickness option in the Mesh Display dialog box to display a 

graphical representation of the thickness of the 2D elements in your model. When you select this option, 

the software displays the 2D elements as if they were solid elements. The software continues to display 

the thickness of the elements until you turn this option off. 
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With the Display 2D Element Thickness option, the software displays a thickness for all 2D elements 

in the model, regardless of how the thickness is defined. For example, the software displays element 

thicknesses that are: 

• Derived from a midsurface's thickness 

• Defined in a physical property table 

• Defined as Element Associated Data for selected elements 

• Defined as a field. 

Why should I use it? 

You can create a display of the element thicknesses to verify that the thickness values are defined 

correctly for the model. An element thickness display can also help you locate areas in your model in 

which the 2D elements have no defined thickness values. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains 2D elements with defined thickness 

values. 

Menu Preferences→Mesh Display 

Simulation Navigator In the FEM, right-click the 2D mesh collector or 2D mesh and choose 

Edit Display. Select Display 2D Element Thickness.  

In the Simulation file, right-click the 2D mesh collector or 2D mesh 

and choose Create Display Override or Edit Temporary 
Display. Select Display 2D Element Thickness.  
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Boundary conditions 

Improvements to constraint resolution 

What is it? 

Improvements have been made to the method in which the software handles two constraints defined on 

shared geometry or nodes. Also, for Simulation files created in Advanced Simulation, the constraint 

resolution workflow has been changed so that you are now in control of initiating the resolution. 

Constraints on shared geometry or nodes resolve correctly 

In previous releases, two constraints defined on shared geometry or nodes, regardless of the constrained 

degrees of freedom, were considered to be in conflict. However, in some cases, the degrees of freedom 

affected by two intersecting constraints are not actually in conflict, as shown in the example below. 

 

Edge indicated by (1) is shared by both constraints 

User Defined Constraint (blue, defined on outer 

face) 

Pinned constraint (red, defined on inner face) 

DOF1=Free A pinned constraint uses a cylindrical coordinate 

system. 

R and Z directions are fixed 

Theta (rotating) direction is free 

All rotational DOF are also free 

In this example, the Cartesian coordinate system for 

the User Defined constraint is oriented such that the 

Y direction is parallel with the Z direction in the 

cylindrical coordinate system for the Pinned 

constraint. 

DOF2=Fixed 

DOF3=Free 

DOF4=Free 

DOF5=Free 

DOF6=Free 

 

In previous releases, the software resolved the above condition using incorrect degrees of freedom. In this 

release, the software resolves this condition using a new constraint resolution rule: Ignore Conflict. 
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With this rule, the software applies the degrees of freedom values for both constraints to the common 

nodes. 

You can also apply the new Ignore Conflict rule to other resolved constraint objects if you want the 

degrees of freedom of all the intersecting constraints to be taken into account for the common geometry 

or nodes. 

The Ignore Conflict rule is used only when the intersecting constraints are both defined on the same 

type of object (for example, two edges, two faces, or two constraints on the same point). For other types 

of intersecting constraints (such as a face constraint and an edge constraint that share an edge or node), 

the appropriate resolution rule, such as Use Object Precedence, will be applied. 

New workflow for resolving constraints 

In Advanced Simulation, when the software detects a constraint conflict, it no longer initiates the 

constraint resolution automatically. Instead, icons now appear in the Simulation Navigator next to the 

conflicting constraints to indicate the conflict, as shown in the example below. 

 

This feature alerts you to conflicting constraints and gives you control over resolving them appropriately. 

To resolve the constraints, do one of the following: 

• In the Advanced Simulation toolbar, click Update Finite Element Model   . 

 Note 

This button also updates any pending mesh updates. 

 

• Right-click the solution node and choose Resolve Constraints. 

• Use the Exclude option in the constraint dialog box to exclude the overlapping geometry and 

avoid the intersecting constraint. 

As in previous releases, a Resolved Constraint Group node that contains the resolved constraint 

objects appears in the Simulation Navigator. 
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Enforced Displacement Constraints now available in axisymmetric structural solutions 

What is it? 

If Abaqus, ANSYS, or Nastran is your specified solver, you can now use the Enforced Displacement 
Constraint command in Axisymmetric Structural type solutions. You can use Enforced 
Displacement Constraint to apply a known displacement to your model. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with Axisymmetric Structural as the 

selected analysis type and Abaqus, ANSYS, NX Nastran, or MSC 

Nastran as the specified solver. 

Toolbar Advanced Simulation→Enforced Displacement Constraint 

   

 

Nastran 

Bolt pre-loads now supported for Response Simulation analyses 

What is it? 

You can use the Bolt Pre-Load command to to apply a pre-load to a bolt modeled with CBAR or 

CBEAM type beam elements in a Response Simulation (SEMODES 103 - Response Simulation) 

analysis. Bolt pre-loads are only supported in the first two subcases in a Response Simulation: 

• Static Offset 

• Stress Stiffening 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with NX Nastran as the specified solver and 

SEMODES 103 - Response Simulation as the solution type and 

with either Subcase - Static Offset or Subcase - Stress 
Stiffening active in the Simulation Navigator 

Toolbar 
Advanced Simulation→Bolt Pre-Load    
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Abaqus 

Bolt pre-loads now supported for solid elements 

What is it? 

In the Abaqus solver environment, you can now define a pre-load on a bolt modeled with solid 

(continuum) elements. In previous releases, you could only define a bolt pre-load on a bolt modeled with 

beam (B31) elements. 

In the Bolt Pre-Load dialog box, use the new Force on 3D Elements option in the Type list to 

define a pre-load on solid elements. With this option, you select either elements or faces that define a pre-

tension section.  

In Abaqus, a pre-tension section is defined as a surface inside the bolt that bisects the bolt. The software 

transmits the specified pre-load force across the pre-tension section by means of a pre-tension node that 

you specify. This pre-tension node must not be attached to any element in your model. 

 Note 

If you do not specify a pre-tension node, the software creates a pre-tension node for you when you 

export or solve your model. 

 

The software applies the load along a vector that is normal to the pre-tension section. The new Section 
Normal option lets you control how the software computes this normal. 

• If you select Average Surface Normal, the software computes an average normal to the 

section that faces away from the underlying continuum elements. 

• If you select User Defined, you can define the vector to specify the normal. This option is 

useful when the direction in which you want to apply the load is different from the average 

normal to the pre-tension section. 

The following graphic shows an example of a bolt created with solid elements. (A) shows the pre-tension 

section, (B) shows the pre-tension node, and (C) shows the normal to the pre-tension section. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Advanced Simulation→Bolt Pre-Load    

 

Initial clearance values for contact and bolt contact analyses 

What is it? 

You can use the new Contact with Clearance and Bolt Contact with Clearance simulation objects 

to define precise initial clearance or overclosure (initial penetration) values for the nodes on the slave 

(dependent) surface in a contact pair. With both Contact with Clearance and Bolt Contact with 
Clearance, the initial clearance or overclosure value you specify overwrites the initial clearance or 

overclosure value that the software calculates at each slave node. 

• Use Contact with Clearance to define initial clearances or overclosures when you model 

contact between two surfaces. 

• Use Bolt Contact with Clearance to define initial clearances or overclosures when you model 

contact between a single-threaded bolt and a bolt hole. 

Contact with clearance for threaded bolts 

The Bolt Contact with Clearance dialog box includes additional Clearance Definition options that 

let you model the thread characteristics of a bolt even if detailed thread geometry is not included in the 

model. These options let you specify details about the bolt threads, including the half thread angle (α), 

pitch (p, or the thread-to-thread distance), and major (d) and mean (md) bolt diameters. You also use the 

Bolt Axis options to define two points (a and b) along the bolt's axis. The software uses these points to 

generate the bolt's contact normal directions. 
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Clearance or overclosure value can be uniform or spatially varying 

In the Contact with Clearance and Bolt Contact with Clearance dialog boxes, you can use the 

Clearance Definition options to define the clearance or overclosure value as either uniform or spatially 

varying for the contact pair. From the Value list: 

• If you select Expression, you can specify a uniform clearance or overclosure value for the 

contact pair. A positive value indicates a clearance value, and a negative value indicates an 

overclosure value. 

• If you select Field, you can specify spatially varying clearances or overclosures. With this 

option, you use a table field to specify the clearance at a single node or set of nodes on the slave 

surface. In the table field, the node ID is the independent variable, while the clearance or 

overclosure value is the dependent variable. You can also specify a Scale Factor to apply to the 

field. 

Contact with clearance is supported only in small-sliding contact analyses 

You can only use the Contact with Clearance or Bolt Contact with Clearance commands when 

you are using the small-sliding contact formulation in your analysis. In Abaqus, you use the *CONTACT 

PAIR keyword to specify the contact formulation. In Advanced Simulation, you use a Contact Pair 

modeling object to specify the parameters for the *CONTACT PAIR keyword: 

1. In the Contact Pair dialog box, select Small from the Sliding Type list to use the small-

sliding formulation instead of the finite-sliding formulation. 

2. In the Contact with Clearance or Bolt Contact with Clearance dialog box, use the 

Contact Pair option to associate the Contact Pair modeling object with the simulation object. 
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Associated Abaqus keywords 

When you export or solve your model, the software uses the options you specify in the Contact with 
Clearance dialog box to define the *CONTACT PAIR and *CLEARANCE keywords in your Abaqus 

input file. For more information, see Adjusting Initial Surface Positions and Specifying Initial Clearances 

in Abaqus/Standard Contact Pairs in the Abaqus Analysis User's Manual and *CLEARANCE and 

*CONTACT PAIR in the Abaqus Keywords Reference Manual. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Advanced Simulation→Contact with Clearance    or Bolt 

Contact with Clearance    

 

New thermal conductance boundary condition 

What is it? 

When you are working with Abaqus as your solver, you can use the new Surface-to-Surface Thermal 
Conductance simulation object to model conductive heat transfer between proximate or contacting 

surfaces. 

In the Surface-to-Surface Thermal Conductance dialog box, you can use the Conductance 
Dependency options to model the conductive heat transfer as a function of: 

• The clearance between the contacting surfaces (Clearance option). 

• The contact pressure at the interface between the contacting surfaces (Pressure option). 

• Both the clearance and the contact pressure (Clearance and Pressure option). 

In Advanced Simulation, you use fields to define how the heat transfer varies with the clearance and/or 

contact pressure. 

When you export or solve your model, the software uses the options you specify in the Surface-to-
Surface Thermal Conductance dialog box to define the *GAP CONDUCTANCE keyword in your 

Abaqus input file. For more information, see Thermal Contact Properties in the Abaqus Analysis User's 

Manual and *GAP CONDUCTANCE in the Abaqus Keywords Reference Manual. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver and 

Thermal as the selected analysis type 

Toolbar Advanced Simulation→Surface-to-Surface Thermal 

Conductance    
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ANSYS 

Solver parameter to group face pressure loads 

What is it? 

A new Create ANSYS components (CM) for similar loads option has been added to the Solver 
Parameters dialog box. When you export or solve your model, this option controls whether the software 

uses the ANSYS CM command to group all elements that have the same face Pressure load into a 

component. 

• If you select this option, the software uses the CM command to group all the elements with the 

same face Pressure load and only writes out a single face pressure (SFE) command in your 

ANSYS input file. 

• If you clear this option, the software writes out individual single face pressure (SFE) commands 

for each element in your ANSYS input file. 

You may want to select the Create ANSYS components (CM) for similar loads option if you plan 

to work with your ANSYS input file outside of Advanced Simulation. For example, if you select this 

option, you can later select the surface pressures by their component name in the ANSYS pre- and post-

processing software. Additionally, the Create ANSYS components (CM) for similar loads option 

creates fewer SFE commands, so you may want to select the option to make manually editing your input 

file easier. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with ANSYS as the specified solver 

Simulation Navigator Right-click a solution→Solver Parameters 

 

New options to control the deletion of loads at the end of a step 

What is it? 

A new Delete load options tab has been added to the Create Solution Step and Edit Solution 
Step dialog boxes. The options on this tab control whether forces and moments, body loads, and element 

body loads are kept or deleted by ANSYS at the end of the current solution step. These options 

correspond to the ANSYS DDELE, FDELE, BFDELE, and BFEDELE commands. 

 Note 

Currently, you can only use these options to delete the loads or constraints on all nodes or elements 

to which they are applied. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Simulation Navigator Either right-click a solution and select Create Step, or right-click the 

appropriate solution step and select Edit Solution Step 

 

Cumulative loading options now preserved on import 

What is it? 

When you import an ANSYS input file into Advanced Simulation, the software now preserves the 

settings of any cumulative option commands (DCUM, FCUM, SFCUM, and BFCUM). In ANSYS, you 

use these commands to specify whether the software should add (ADD), replace (REPL), or ignore 

(IGNO) a repeated load or constraint on a particular degree-of-freedom. In previous releases, the software 

always imported any cumulative option command with a setting of ―replace‖ (REPL), regardless of what 

you actually specified in the input file. Now, the software correctly preserves the specified cumulative 

option setting when you import the file. 

 Note 

Advanced Simulation does not import any cumulative options as a Solution Step attribute. 

Instead, the software converts the load or boundary condition data into an equivalent load or 

boundary condition with the appropriate cumulative option setting. 

 

For example, suppose you have the following constraints on node ID2: 

• Step 1: UX = 1mm, UZ= 1.2mm 

• Step 2: UX = 1.5mm, UY=1 

In step 2 of the analysis, how the software resolves the constraint on node ID2 depends on the setting of 

the DCUM command: 

• If the DCUM option is set to REPL, the resolved constraint for node ID2 is UX = 1.5, UY = 1 

(UZ is removed) 

• If the DCUM option is set to ADD, the resolved constraint for node ID2 is UX = 2.5, UY = 1, UZ 

= 1.2 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Menu File→Import→Simulation 

 

Support for importing loads and constraints from binary files 

What is it? 

When you import an ANSYS binary file into Advanced Simulation, the software now imports any loads 

(forces/moments) and constraints (displacements and temperatures) defined in that file. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Menu File→Import→Simulation 

 

Groups 

Node and element sets replaced by groups 

What is it? 

In this release, node and element sets have been completely replaced by groups. The Sets command has 

been removed from the product. Previously, you could use the Node Set and Element Set capabilities 

to create named collections of either nodes or elements. However, you could only create a set of a 

homogeneous collection of entities, and sets were only supported in a subset of the Advanced Simulation 

commands. Compared to sets, groups: 

• Allow you to create named collections of heterogeneous types of entities. 

• Are supported by a wider array of commands. 

• Offer you greater flexibility and control over how and where they are created. 

Commands now let you select groups instead of sets 

All commands that previously allowed you to select node or element sets now allow you to select groups. 

For example, the Nastran Structural Output Request and Thermal Output Request modeling 

object dialog boxes have been modified to allow you to select groups of nodes or elements on which to 

output results. 
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Migration of existing node and element sets to groups 

If you have a model from a previous release that contains node or element sets, the software automatically 

migrates those sets to groups when you open your model for the first time in this release. 

Nastran SETS now imported as groups 

In previous releases, if you imported a Nastran input file, any SET case control commands were imported 

as either a node set or as an element set. Now, the software imports SETs as groups. For details, see 

Understanding the import of Nastran SETs. 

Grouping enhancements 

What is it? 

This release includes a number of enhancements to the grouping capabilities in Advanced Simulation. 

Access to groups from the Simulation Navigator 

A new Groups folder has been added the Simulation Navigator. The folder allows you to easily view 

and manage all existing groups. In the Groups folder, you can use right-click menu options to: 

• Create new groups. 

• Access the Group Manager dialog box where you can modify existing groups. 

New Add to Group and Remove from Group commands 

New Add to Group    and Remove from Group    commands are now available. You can 

access these commands from either the Group Manager dialog box or the right-click menu when you 

highlight a group in the Simulation Navigator. You can use these commands to quickly: 

• Add new entities to a selected group. 

• Remove selected entities from a selected group. 

Initial support for group labels 

When you create or import a group, Advanced Simulation now assigns a unique label (ID) to that group. 

Currently, you cannot change the label or specify criteria used to initially assign the label. The labels 

appear in the new Label column in the group list in the Group Manager dialog box. Because you can 

have groups defined in both the FEM and Simulation files, or in different FEM files within an assembly 

FEM, the software automatically resolves any conflict between the labels to enforce uniqueness. 

Application Advanced Simulation 

Prerequisite An active FEM, Simulation, or assembly FEM file 

Simulation Navigator Right-click a selected group. 

Menu Format→Group→Manage 
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Fields 

General field enhancements 

What is it? 

This release includes several enhancements to fields. In Advanced Simulation, you use fields to define 

variant functions that specify magnitudes or properties in terms of other variables, such as time. 

Fields now available from the Simulation Navigator 

You can now manage fields from the Simulation Navigator as well as the Part Navigator. You can 

use the new Fields node in the Simulation Navigator to create, plot, edit, export, copy, rename, or 

delete a field. The Fields node is always visible, regardless of which Simulation part or file is currently 

active. Because fields have so many applications in Advanced Simulation, having the Fields node in the 

Simulation Navigator makes it easier for you to work with fields in the context of a CAE analysis. 

Descriptions for fields 

Description boxes are now available in the Formula Field, Table Field, and Linked Field dialog 

boxes. When you create a field, use the Description box to enter a description of the field. 

Default bounds for independent domain variables 

You can now define default bounding ranges for your named independent variables. These bounds are 

then used for all independent variables, so you do not need to define them each time you create a field, 

unless you want to change the default bounds. In the Named Variables dialog box, right-click a 

variable and choose Default Bounds. In the Default Named Variable Bounds dialog box, you can 

define the default Minimum, Maximum, Default value, and the Number of Points.  

Ability to display spatial fields 

What is it? 

You can now create displays of the spatial fields in your model. Spatial fields define how a boundary 

condition or the thickness of elements map to an area of your model. Creating a display of a spatial field 

lets you visually verify that the distribution of the data is correct across the model. 

Controlling the display of fields from the Simulation Navigator 

You can control whether a field is displayed directly from the Simulation Navigator. 

   Fields 

   Temperature 

   Force vs Time Formula 
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You can: 

• Use the check boxes adjacent to individual fields to turn on or off the display of selected fields. 

• Use the check box adjacent to the main Fields node to turn on or off the display of all fields. 

Controlling the appearance of field displays 

You can use the options in the new Field Display Properties dialog box to control how the software 

displays the spatial fields. For example, you can use the Display Type option in the Dependent 
Domain group to control the display of the data in the dependent field. Below, (A) shows a Surface 

type display of a spatial temperature field, while (B) shows a Symbol type display. 

 

The available display options differ depending on whether you are working with the independent domain 

or the dependent domain. They also differ depending upon the type of display you create. For example, if 

you select Surface from the Display Type list in the Dependent Domain group, you can use the 

Offset option to control the degree to which the software offsets the data from the independent domain. 

Below (A) shows a surface with no offset, while (B) shows a surface with a much larger offset. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation or FEM file 

Simulation Navigator Right-click the field in the Fields node→Edit Display 
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Ability to map a field to an isoparametric plane or line 

What is it? 

Two new methods of mapping variable data to a location have been added. You can now map field data to 

an abstract combination of faces or lines in your model. You can then use this field as a boundary 

condition or as a variable thickness on the elements in your mesh. 

Parametric Plane 

Using the new Parametric Plane spatial map type, available with the Parameter Plane spatial 

domain, you can map a field to a 2D arbitrary surface whose principal coordinate directions lie between 

0,0 and 1,1. The coordinate directions are labeled U and V.  

For example, you can use this method to define a varying temperature (for use in a boundary condition) or 

element thickness across a complex surface. 

 

Temperature varying according to parametric plane 

You define the U and V coordinates, which range from 0 to 1, by selecting points or edges in your model. 

You can define the U coordinates and allow the software to infer the V coordinates, or you can define 

both the U and V coordinates explicitly. 
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Example: U coordinates defined by selecting edge (1) and edge (2); V coordinates inferred 

 

Data mapped to U and V coordinates 

You can define the U and V coordinates using one of these methods: 

• Iso Section — You define at least two U ―sections‖ by selecting points or edges in the model 

(the first section you define is 0% and the last one is 100%). The software creates the remaining 

U sections on the surface based on the sections you define. The software then infers the V 

sections from your U sections. This method works well when the geometry is linear in the 

direction of the V sections. 

• Iso Lines — You define both the U and V sections. The definition process is the same as it is for 

the Iso Section mapping, except you define the V sections rather than letting the software infer 

them. This option is necessary when the model contains curved faces in the direction of the V 

sections 

For more information, see Mapping a field to an isoparametric plane. 
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Parametric Line 

Using the Parametric Line spatial map type, you can map variable data to a line. You can select points, 

edges, and curves to define a U section that defines a parametric line in Cartesian space. The software 

uses all objects you select to define a single curve with the starting point mapped to 0% and the end point 

mapped to 100%. This feature is useful for applying variable data spatially along an edge.  

For example, you can use a parametric line field as a spatial scaling factor in a Force load: 

 

This feature is also useful for defining a boundary condition or thickness that is varying in only one 

direction. For example, you can apply the above force distribution across the 2D faces using the same 

parametric line field: 

 

For more information, see Mapping a field to an isoparametric line. 

Where do I find it? 

Parametric Plane 

Application Advanced Simulation 

Prerequisite An active Simulation or FEM file 

Simulation Navigator Right-click the Fields node→New [field type] 

Location in dialog box Domain→Parameter Plane→Spatial 
Map→Type→Parametric Plane 
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Parametric Line 

Application Advanced Simulation 

Prerequisite An active Simulation or FEM file 

Simulation Navigator Right-click the Fields node→New [field type] 

Location in dialog box Domain→Parameter→Spatial Map→Type→Parametric Line 

 

Geometry idealization and abstraction 

Midsurface improvements 

What is it? 

This release includes several improvements to the Midsurface command. 

Improved usability for Midsurface dialog box 

This release includes enhancements to the Midsurface dialog box to improve its usability. 

• In previous releases, the Midsurface dialog box closed automatically after you generated a 

single midsurface. Now, the dialog box remains active until you explicitly close it. 

• If you select the Automatic Progression check box, you can now create midsurfaces on 

multiple bodies without exiting the Midsurface dialog box. If you select Automatic 
Progression, when you generate a midsurface on a body, the software automatically displays 

only the new sheet body in the graphics window. In a model that contains multiple solid bodies, 

this helps you visually distinguish between the bodies that have defined midsurfaces and those 

that do not. You can then more easily select the next solid body on which to create a midsurface. 

Improvements to automatic pairing and overall performance 

When you use the Face Pair method with the Auto Create option, improvements have been made to 

the algorithm the software uses to automatically pair faces. On certain types of parts, the software now 

produces more accurate face pairs as well as more accurately trimmed surfaces. 

Additionally, there are significant performance improvements in the time it takes the software to generate 

a midsurface on certain types of parts. These improvements occur when you create a midsurface with the 

Advanced Creation and Trimming  check box cleared. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active idealized part 

Toolbar 
Advanced Simulation→Midsurface    
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Split Body creates mesh mating conditions 

What is it? 

When you use the Split Body command to divide geometry into multiple bodies, use the new Auto 
Create Mesh Mating Conditions option in the Split Body dialog box to create mesh mating 

conditions between those bodies. With this option, when you switch from the idealized part to the FEM 

file, the software automatically creates a glue coincident mesh mating condition between the bodies. The 

mesh mating condition ensures that the meshes are continuous from one body to the other. Previously, 

you had to manually create mesh mating conditions between any bodies created by the Split Body 

command. 

 Note 

If you use the Split Body command in the Modeling application, the Auto Create Mesh 
Mating Conditions option is called Keep Imprinted Edges. If you select Keep Imprinted 
Edges, the software creates mesh mating conditions between the bodies when you switch to the 

Advanced Simulation application. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite The idealized part active 

Toolbar 
Advanced Simulation→Split Body    

 

Split Edge improvements 

What is it? 

The Split Edge command now includes options that you can use to define the location where the 

software divides the edge. To facilitate these improvements, the Split Edge dialog bar available in 

previous releases has been converted to a new Split Edge dialog box. 

The Type menu lets you select the method to use to split the edge: 

• Use Location on Edge to divide the edge at a point you select. In previous releases, this was 

the only available method for splitting an edge. 

• Use Project Point on Edge to divide the edge by projecting a point onto the edge. The 

software uses a closest point method to project the selected point to the edge. The software splits 

the edge at the location of the projected point. 

• Use Project Point Along a Vector to divide the edge by projecting a point onto the edge 

along a specified vector. The software splits the edge at the location that represents the closest 

point projection of the point along the vector. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file 

Toolbar 
Model Cleanup→Split Edge    

 

Materials 

Support for external material libraries 

What is it? 

The process for using an external, custom material library in NX has been improved. You can now: 

• Maintain two separate custom material libraries. Custom libraries are stored as XML files in the 

MatML schema version 3.1.5. For schema details, see http://www.matml.org. 

• Restrict display and editing access to the two custom libraries independently.  

• Create, edit, or delete your custom library materials directly within NX.  

• Export local materials (materials created in NX and saved with a model) to a custom material 

library.  

• Import material libraries generated from external sources that adhere to the MatML schema. 

The new Material Library Manager dialog box lets you export materials to a custom library and edit or 

delete the custom materials. 

http://www.matml.org/
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Use customer defaults for the Materials function to define the default folder location of the material 

libraries, as well as configure access to each library. 

Why should I use it? 

• Custom material definitions can be used in multiple NX models, and these custom materials are 

preserved when you upgrade to a newer version of NX. 

• Editing your materials in the NX user interface is much easier than editing the phys_material.dat 

file.  

Where do I find it? 

Materials customer defaults 

Menu File→Utilities→Customer Defaults 

Location in dialog box Gateway→General→Materials tab 
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Material Library Manager command 

Application All 

Menu Tools→Material Library Manager 

Simulation Navigator Advanced Simulation toolbar→Material Library Manager 

   

 

Enhancements for isotropic and fluid materials 

What is it? 

As part of the ongoing enhancements to the NX materials capabilities, isotropic and fluid materials now 

support a number of functional enhancements. With these materials, you can now: 

• Enter the value for a material property as an Expression (that is, a formula, function, reference, or 

constant value) or as a Field (a table or formula). 

• Plot tabular material property values using the XY Graphing capability. 

• Specify units for any material property. For example, you can set the units for a stress-strain 

curve. 

• Enter a description for any material. 

• View all material properties in the Information view for a given material. 

In addition, the user interface for creating new isotropic or fluid materials has been improved for better 

usability. 

Orthotropic and anisotropic materials will offer the same capabilities in a future release. 

Where do I find it? 

Application All 

Menu Tools→Material Properties 

Simulation Navigator 
Advanced Simulation toolbar→Material Properties    

 

Material damping support 

What is it? 

Material damping is now supported for relevant Nastran and ANSYS materials. This allows you to 

include structural damping in dynamic analyses. 

• For Nastran, the GE field is now supported for the MAT1, MAT2, MAT3, MAT8, and MAT9 

bulk data entries. 

• For ANSYS, the DAMP option is now supported for the MP command. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part 

Toolbar 
Advanced Simulation→Material Properties    

 

Nastran 

New hyperelastic material models 

What is it? 

This release includes support for new NX Nastran hyperelastic material models. Hyperelastic materials let 

you model materials that are nearly incompressible but which undergo large strains. 

Hyperelastic Material Model Corresponding ANSYS Command 

Arruda-Boyce MATHE bulk data entry with Model field = Aboyce 

Foam MATHE bulk data entry with Model field = Foam 

Mooney-Rivlin MATHE bulk data entry with Model field = Mooney 

Ogden MATHE bulk data entry with Model field = Ogden 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with NX Nastran as the 

specified solver 

Toolbar 
Advanced Simulation→Material Properties    

 

Abaqus 

New hyperelastic material models 
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What is it? 

This release includes support for an expanded range of Abaqus hyperelastic material models, including 

several models in which you can use test data to define certain material properties. This release also 

includes support for a new Gasket Behavior material. 

• Hyperelastic materials let you model materials that are nearly incompressible but which undergo 

large strains. 

• The Abaqus Gasket Behavior material lets you model gasket behavior properties, such as 

elastic properties for the membrane and transverse shear behaviors of a gasket, for gasket 

analyses. 

New materials 

Material Corresponding Keyword 

Arruda-Boyce *HYPERELASTIC keyword with both the ARRUDA-BOCYE 

parameter (constants option) 

Arruda-Boyce Test Data *HYPERELASTIC keyword with the ARRUDA-BOCYE and 

TEST DATA INPUT parameters 

Foam *HYPERFOAM keyword (constants option) 

Foam Test Data *HYPERFOAM keyword with the TEST DATA INPUT 

parameter 

Gasket Behavior *GASKET BEHAVIOR keyword 

Marlow *HYPERELASTIC keyword with the MARLOW parameter 

Mooney-Rivlin *HYPERELASTIC keyword with the MOONEY-RIVLIN 

parameter (constants option) 

Neo Hooke *HYPERELASTIC keyword with the NEO HOOKE parameter 

(constants option) 

Neo Hooke Test Data *HYPERELASTIC keyword with both the NEO HOOKE and 

TEST DATA INPUT parameters 

Ogden *HYPERELASTIC keyword with the OGDEN parameter 

(constants option) 

Ogden Test Data *HYPERELASTIC keyword with the OGDEN and TEST 

DATA INPUT parameters 

Polynomial *HYPERELASTIC keyword with the POLYNOMIAL 

parameter (constants option) 

Reduced Polynomial *HYPERELASTIC keyword with the REDUCED 

POLYNOMIAL parameter (constants option) 

Van Der Waals *HYPERELASTIC keyword with the VAN DER WAALS 

parameter 

Yeoh *HYPERELASTIC keyword with the YEOH parameter 
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(constants option) 

Yeoh Test Data *HYPERELASTIC keyword with both the YEOH and TEST 

DATA INPUT parameters 

 

Defining material constants using test data 

With the test data material types, you can use a field to specify the deformation modes that define the 

material constants with test (experimental) data. 

• Use the UNIAXIAL Tension/Compression option to specify uniaxial test data. This option 

corresponds to the Abaqus *UNIAXIAL TEST DATA keyword. With UNIAXIAL 
Tension/Compression, you define a table field in which you list the material's nominal stress 

(TU) and nominal strain values (εU) on each line. 

• Use the BIAXIAL Tension option to specify biaxial test data. This option corresponds to the 

Abaqus *BIAXIAL TEST DATA keyword. With BIAXIAL Tension, you define a table field in 

which you list the material's nominal stress (TB) and nominal strain values (εB) on each line. 

• Use the PLANAR - Pure Shear option to specify planar (or pure shear) data. This option 

corresponds to the Abaqus *PLANAR TEST DATA keyword. With PLANAR - Pure Shear, 

you define a table field in which you list the material's nominal stress (TS) and nominal strain in 

the direction of loading (εS) on each line. 

• Use the Pure Volumetric Compression option to specify volumetric loading test data to 

include user-defined material compressibility. With Pure Volumetric Compression, you 

define a table field in which you list the material's pressure (p) and the volume ratio, J (current 

volume/original volume) on each line. 

Depending upon the material's type, you can use one or more of these options to define the experimental 

stress-strain data. 

• With the Arruda-Boyce Test Data, Marlow, and Foam Test Data materials, you can only 

use one of the test data options to define the experimental test data. If you use more than one, 

when you export or solve your model, the software only writes out the first applicable test data 

curve. The order in which the software searches for the appropriate test data option depends on 

the material type, as follows: 

– Arruda-Boyce Test Data: BIAXIAL Tension then UNIAXIAL 
Tension/Compression 

– Marlow: BIAXIAL Tension, then PLANAR - Pure Shear, then UNIAXIAL 
Tension/Compression 

– Foam Test Data: PLANAR - Pure Shear, then UNIAXIAL Tension/Compression, 

then Pure Volumetric Compression 

• With the Mooney-Rivlin Test Data, Neo Hooke Test Data, Ogden Test Data, Reduced 
Polynomial, Van Der Waals, and Yeoh Test Data material types, you can use up to four of 

the options to define the experimental test data. If you use more than one, when you export or 

solve your model, the software writes out the test data option in the following order: BIAXIAL 
Tension, then PLANAR - Pure Shear, then UNIAXIAL Tension/Compression, then 

Pure Volumetric Compression. 
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For more information, see: 

• *HYPERELASTIC, *UNIAXIAL TEST DATA, *BIAXIAL TEST DATA, *PLANAR TEST DATA, 

and *VOLUMETRIC TEST DATA in the Abaqus Analysis Keywords Manual. 

• Hyperelastic behavior of rubberlike materials in the Abaqus Analysis User's Manual. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with Abaqus as the specified 

solver 

Toolbar 
Advanced Simulation→Material Properties    

 

ANSYS 

New hyperelastic material models 

What is it? 

This release includes support for a number of new ANSYS hyperelastic material models. Hyperelastic 

materials let you model materials that are nearly incompressible but which undergo large strains. 

Hyperelastic Material Model Corresponding ANSYS Command 

Arruda-Boyce TB command with the HYPER,,,,BOYCE option 

Foam TB command with the HYPER,,,,FOAM or HYPER,,,,BLATZ 

options 

Gent TB command with the HYPER,,,,GENT option 

Mooney-Rivlin TB command with the HYPER,,,,MOONEY option 

Neo Hooke TB command with the HYPER,,,,NEO option 

Ogden TB command with the HYPER,,,,OGDEN option 

Polynomial TB command with the HYPER,,,,POLY option 

Yeoh TB command with the HYPER,,,,YEOH option 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with ANSYS as the specified 

solver 

Toolbar 
Advanced Simulation→Material Properties    
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Meshing 

Newly supported element types 

What is it? 

This release includes support for additional NX Nastran and Abaqus element types. 

New NX Nastran Element Type 

Advanced Simulation now supports the CPYRAM element. For more information, see: 

• **Unsatisfied xref title** for details on how to include pyramid elements in your model. 

• CPYRAM in the NX Nastran Quick Reference Guide 

New Abaqus Element Types 

This release includes support for the following types of Abaqus gasket elements: 

Abaqus Element Description 

GK3D6 6-noded, three-dimensional gasket element 

GK3D6N 6-noded, three-dimensional gasket element with thickness-direction 

behavior only 

GK3D8 8-noded, three-dimensional gasket element 

GK3D8N 8-noded, three-dimensional gasket element with thickness-direction 

behavior only 

 

How you create the gasket elements depends upon the element's type: 

• To create GK3D8 or GK3D8N type elements, use the 3D Swept Mesh command. 

• To create GK3D6 or GK3D6N type elements, first create a 2D mesh of either linear or parabolic 

triangular elements. Then, use the 3D Swept Mesh command to generate the GK3D6 or 

GK3D6N elements.  

For more information on modeling and analyzing gaskets, see **Unsatisfied xref title**. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with the appropriate solver specified 

Toolbar 
Advanced Simulation toolbar→ 3D Tetrahedral Mesh    or 

3D Swept Mesh    

Menu Insert→Mesh→3D Tetrahedral Mesh or 3D Swept Mesh 
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Improved tetrahedral meshing algorithm 

What is it? 

This release includes improvements to the tetrahedral meshing algorithm. The most significant of these is 

how the algorithm manages memory during mesh generation. Specifically: 

• The algorithm no longer has a contiguous memory requirement. Previously, if the memory on 

your machine was fragmented, the meshing algorithm could only utilize the largest contiguous 

free block of memory. Now, the software utilizes all available memory. This means that the 

software can now take advantage of all available smaller blocks of memory on your machine. 

• The algorithm's memory allocation is now tuned for 64-bit precision. Because the algorithm has 

been tuned to take advantage of the increased precision, the overall robustness of the algorithm 

has increased. Previously, the software could allocate an array past the 32-bit limit, but all the 

floating point calculations were still performed with 32-bit floats. 

These improvements are most noticeable when you generate meshes on large models or when you 

iteratively reduce the element size on a smaller model. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file 

Toolbar 
Advanced Simulation→3D Tetrahedral Mesh    

Menu Insert→Mesh→3D Tetrahedral Mesh 

 

Quadrilateral only meshing 

What is it? 

You can use new options in the 2D Mesh, 2D Mapped Mesh, and 3D Swept Mesh dialog boxes to 

create a quadrilateral only mesh. A quadrilateral only mesh is a special class of free mesh that does not 

contain any triangular elements. Quadrilateral only meshes are sometimes necessary in analyses in which 

the presence of triangular elements is considered either undesirable or unacceptable. 

Quadrilateral only 2D free meshes 

Use the new Attempt Quad Only option in the 2D Mesh dialog box to control whether the software 

tries to generate a mesh that contains only quadrilateral elements. With a quadrilateral only mesh: 

• If you select On – Zero Triangles, the software creates a mesh that does not contain any 

triangular elements. With this option, if the software cannot create a mesh with only quadrilateral 

elements, it does not generate a mesh. 

• If you select On – Minimum Triangles, the software creates a mesh that contains, at most, a 

single triangular element per selected face. With this option, the software only inserts a triangle if 

it cannot establish nodal parity (an even number of nodes) along the boundary of the face. 



124    What's New in NX 7   whatsnew7 0  

To create a quadrilateral only mesh, you must first clear the Attempt Free Mapped Mesh check box.  

Quadrilateral only 2D mapped meshes for three-sided faces 

Use the new Quad Only on 3 Sided Faces option in the 2D Mapped Mesh dialog box to create a 

mesh that does not contain any triangular elements on a three-sided face. If you select this option, the 

software tries to generate an all quadrilateral mesh for faces that have only three sides. With this option, if 

the software is unable to maintain nodal parity due to constraints from existing meshes on the surrounding 

faces, it creates a mapped mesh with a single triangular element. In previous releases, if you created a 

mapped mesh on a three-sided face, the mesh always degenerated into triangular elements at a selected 

corner. 

The following graphic shows a mapped mesh generated with the Quad Only on 3 Sided Faces check 

box cleared. Notice how the quadrilateral mesh degenerates into triangular elements at the uppermost 

corner. 

 

This graphic shows a mapped mesh on the same geometry generated with the Quad Only on 3 Sided 
Faces check box selected. This mesh is comprised of only quadrilateral elements. 

 

Quadrilateral only source faces for 3D hexahedral meshes 

Use the new Attempt Quad Only options in the 3D Swept Mesh dialog box to have the software 

generate a quadrilateral only mesh on the source face. Having an all quadrilateral element mesh on the 

source face ensures that the swept mesh through the volume will not contain any wedge elements. 

Use the options in the Attempt Quad Only list to control whether the software creates a mesh on the 

source face that either does not include any triangles or that only contains one triangle. 

With the 2D Mesh dialog box, the Attempt Free Mapped Mesh and Attempt Quad Only options 

are mutually exclusive. However, with the 3D Swept Mesh dialog box, if you select both Attempt 
Free Mapped Mesh and either On – Zero Triangles or On – Minimum Triangles from the 
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Attempt Quad Only list, the software proceeds through the options sequentially. First, it tries to 

generate a free mapped mesh. If that mesh fails, it then tries to create a quadrilateral only mesh. The 

software retains the first successful mesh it generates. 

If the software cannot successfully generate either a quadrilateral only mesh or a free mapped mesh, it 

uses the Paver meshing method to generate a free mesh on the source face. 

The following graphic shows a hexahedral mesh generated with the Attempt Free Mapped Mesh 

check box selected and the Attempt Quad Only option set to Off. Notice that the mesh on the source 

face contains several triangular elements. 

 

This graphic shows a hexahedral mesh on the same part generated with the Attempt Free Mapped 
Mesh check box cleared and the Attempt Quad Only option set to On – Zero Triangles. 

 

New customer defaults 

New customer defaults let you control the default settings for the Attempt Quad Only options in the 

2D Mesh and 3D Swept Mesh dialog boxes and the Quad Only on 3 Sided Faces option in the 2D 
Mapped Mesh dialog box. To set these defaults: 

1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→Meshing. 

3. Click the 2D Free Mesh, 2D Mapped Mesh, or 3D Mapped Mesh page and set the 

appropriate option. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file 

Toolbar 
Advanced Simulation→2D Mesh,   , 2D Mapped Mesh 

  , or 3D Swept Mesh    

Menu Insert→Mesh→2D Mesh, 2D Mapped Mesh, or 3D Swept 
Mesh 

 

Creating a surface coat of 2D elements 

What is it? 

Use the new Surface Coat command to create a surface coating of 2D elements on top of existing 3D 

(solid) elements. You can create a surface coat on either the free faces of selected solid elements or on an 

entire solid mesh. The resulting 2D mesh: 

• Uses the nodes and the connectivity of the solid mesh on which it is defined. 

• Can be linear or parabolic if the solid mesh is parabolic. For example, you can create a surface 

coating of either linear or parabolic quadrilateral elements on a mesh of parabolic quadrilateral 

elements. However, if the solid mesh is linear, then the resulting 2D mesh can only be linear. 

• Is not associated to the underlying 3D mesh. If you delete or modify either the 2D mesh or the 3D 

mesh, the other mesh is unaffected. 

• Is not associated to the underlying geometry. 

There are a number of different reasons why you might want to create a surface coating of 2D elements 

on your model. For example, you can create a surface coating of 2D elements to: 

• Model an actual surface coating on the underlying part. 

• Add mass to your model. 

• Facilitate post-processing in cases, for example, where you are chiefly interested in the stress 

results on the surface of the part. 

• Ensure that loads are correctly transferred between adjacent shell and solid meshes. For example, 

imagine a model that contains a thin rib that intersects the main body of a solid part. The rib is 

meshed with 2D elements, with 6 degrees-of-freedom each, while the part itself is meshed with 

3D elements, with 3 degrees-of-freedom each. Suppose you need to apply a bending load to the 

end of the rib. To ensure that the moments transfer correctly from the 2D elements to the 3D 

elements, you can create a surface coating of 2D elements on the 3D elements that surround the 

location where the rib intersects the part. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains a 3D mesh 

Toolbar 
Element Operations→Surface Coat    

Menu Insert→Element→Surface Coat 

 

Modifying the order of elements in a mesh 

What is it? 

Use the new Element Modify Order command to change the order of all elements in a selected mesh. 

For meshes that are associated to their underlying geometry, Element Modify Order lets you modify 

the element order without regenerating the entire mesh. You can change: 

• A mesh of parabolic elements to a mesh of linear elements. 

• A mesh of linear elements to a mesh of parabolic elements. 

Modifying the order of elements with the Element Modify Order command is faster than changing the 

order of elements by editing an existing mesh. 

In the following graphic, we used Element Modify Order to modify a mesh of linear hexahedral 

elements (A) to a mesh of parabolic hexahedral elements (B). 
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When you use Element Modify Order: 

• The software does not change either the location or label of the corner nodes in the mesh. 

• In a mesh that is associated to the underlying geometry, any midnode that the software inserts 

along an edge or face is associated to that edge or face. 

 Note 

You cannot use Element Modify Order to modify the order of either a pyramid element mesh or 

a hexahedral or tetrahedral mesh that adjoins a pyramid element mesh. 

 

Modifying the Midnode Method for parabolic elements 

For a mesh of parabolic elements, you can also use Element Modify Order to change the specified 

Midnode Method for the mesh. The Midnode Method lets you control how the software projects the 

elements' midnodes onto the geometry. 
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For example, suppose you select Mixed from the Midnode Method list when you create the mesh. 

With the Mixed option, the software projects the midnodes on an element to the geometry unless the 

projection would cause the element's Jacobian value to exceed the Maximum Jacobian threshold 

specified in the 2D Mesh dialog box. You could later use Element Modify Order to change the 

method to either Curved or Linear. However, if you select a parabolic mesh that is not associated to the 

underlying geometry, such as a mesh created with commands on the Element Operations toolbar, you 

can only change the Midnode Method to Linear. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains a 2D or 3D mesh 

Toolbar 
Element Operations→Element Modify Order    

Menu Edit→Element→Modify Order 

 

Varying the thickness of 2D elements 

What is it? 

This release includes several enhancements that allow you to vary the thickness of 2D elements. You can: 

• Use options in the Mesh Associated Data dialog box to vary the thickness of all the 2D 

elements in a mesh. 

• Use options in the Element Associated Data dialog box to vary the thickness values within an 

individual element. 

Improved user interface for defining the source of a 2D element's thickness 

In the Mesh Associated Data dialog box, the Ignore Midsurface Thickness option from previous 

releases has been replaced by the new Thickness Source list. Use the Thickness Source list to 

specify the source of the data the software uses to assign the elements' thickness values. For example, if 

you select Physical Property Table, the software applies the thickness value defined in the associated 

physical property table to the mesh. In contrast, if you select Midsurface, the software applies the 

thickness of the midsurface to the mesh. 

Ability to use fields to vary the thickness of elements across a mesh 

In the Mesh Associated Data dialog box, the Field option in the Thickness Source list lets you use 

a spatial field to vary the thickness of the elements across a mesh. You can use: 

• A formula field to vary the thickness of the elements using an NX expression (mathematical 

function). 

• A table field to vary the thickness of the elements using a table of independent and dependent 

variables. With a table field you can import an external comma separated (.csv) text file that 

defines the appropriate thickness values to use as input for the table. 

The following graphic shows a part with a 2D mesh generated on the part's midsurface. A table field 

defines the thickness of the elements along the top surface. 
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The following table lists the types of elements for each solver for which you can create a spatial field to 

vary the thickness. 

Solver Element Types that Support Thickness Fields 

Nastran CQUAD4, CQUAD8, CQUADR, CTRIA3, CTRIA6, CTRIAR 

Abaqus SHELL63, SHELL93, SHELL181, PLANE42, PLANE82 

ANSYS S3, S3R, STRI3, STRI65, S4, S4R5, S8R, S8R5 

 

Ability to specify different nodal thickness values for a single element 

Use the new Corner Node Thickness options in the Element Associated Data dialog box to 

specify different thickness values for selected corner nodes. Any thickness values you specify with the 

Element Associated Data dialog box take precedence over the thickness value assigned to the overall 

mesh. 

Where do I find it? 

Mesh Associated Data 

Application Advanced Simulation 

Prerequisite An active FEM file 

Menu Tools→Mesh Associated Data 

Simulation Navigator Right-click the appropriate mesh→Edit Mesh Associated Data 
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Element Associated Data 

Application Advanced Simulation 

Prerequisite An active FEM file 

Menu Edit→Element→Modify Associated Data 

Toolbar 
Element Operations→Element Associated Data    

 

New method for orienting 2D element normals 

What is it? 

Use the new 2D Element Normal by Seed option in the Model Check dialog box to orient the 

normals of 2D elements to match the normal of a selected seed element. You can: 

• Change the normals of all connected elements in the mesh to which the seed element belongs. 

• Change the normals of all connected elements in all currently displayed 2D elements. 

With 2D Element Normal by Seed, you select an element whose orientation is in the desired 

direction. When you click either OK or Apply, the software modifies the elements' orientation. 

You can use 2D Element Normal by Seed to quickly modify the normals of elements so that they are 

consistent. Consistent element normals are important, for example, to ensure the proper post-processing 

of element stress and strain results. 

 Note 

If you want your selection to stop at the end of a non-manifold edge, you should first merge any 

coincident nodes before you use the 2D Element Normal by Seed option. To merge coincident 

nodes, select the Nodes option in the Model Check dialog box and then select Merge 
Duplicate Nodes. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains a 2D mesh 

Toolbar 
Advanced Simulation→Finite Element Model Check    

 

Initial pyramid element support for NX Nastran 

What is it? 

This release contains the initial implementation of pyramid element support for NX Nastran models. In 

Advanced Simulation, if you are working in the NX Nastran solver environment, you can now use 

pyramid elements to transition between hexahedral and tetrahedral meshes on adjacent bodies (volumes). 
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You can also import existing NX Nastran models that contain pyramid elements and work with those 

elements in Advanced Simulation. Previously, pyramid elements were only supported in the ANSYS 

solver environment. 

NX Nastran uses the CPYRAM bulk data entry to define the pyramid elements. The CPYRAM element is 

only supported in Advanced Nonlinear (SOL 601 and SOL 701) analyses. A CPYRAM element can have 

5 or 13 nodes. For more information, see CPYRAM in the NX Nastran Quick Reference Guide. 

Creating pyramid elements at hexahedral-tetrahedral interfaces 

When you generate a tetrahedral mesh on a body (volume) that is adjacent to a body with an existing 

hexahedral mesh, you can use the Use Pyramids for Transition option in the 3D Mesh dialog box to 

have the software automatically create transitional pyramid elements between the meshes. For the 

software to create transitional pyramid elements: 

• The adjacent body must have an existing mesh of hexahedral elements. 

• A Glue Coincident type of Mesh Mating Condition must be defined at the interface 

between the two bodies to ensure that the nodes on the adjacent hexahedral and tetrahedral 

meshes match exactly. 

For more information about using pyramid elements with the NX Nastran environment, see Using 

pyramid transitions with NX Nastran in the Advanced Simulation help. 

The following example shows transitional pyramid elements at the interface of hexahedral and tetrahedral 

meshes on a section of a wheel hub. The outer section of the hub is meshed with tetrahedral elements, 

while the inner section is meshed with hexahedral elements. (A) shows the two meshes together, with the 

transitional pyramid elements highlighted in orange. (B) shows a view of just the pyramid elements with 

the tetrahedral elements. 

 



whatsnew7 0   What's New in NX 7    133 

 

Why should I use it? 

Pyramid elements ensure a conforming mesh as they provide a direct transition from hexahedral elements 

to tetrahedral elements. In contrast, interface connection methods rely on either rigid elements or multi-

point constraint equations to connect the nodes. Using pyramid elements to join dissimilar meshes offers 

advantages in greater solution accuracy and reduced solution time compared to rigid elements or multi-

point constraint equations. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with NX Nastran as the specified solver 

Toolbar 
Advanced Simulation→3D Tetrahedral Mesh    

Menu Insert→Mesh→3D Tetrahedral Mesh 

 

New option for retaining free meshes in mapped mesh failures 

What is it? 

In previous releases, if the software was unable to generate a mapped mesh on one or more of the faces 

you selected with the 2D Mapped Mesh command, it generated a free mesh on them instead. Now, you 

can use the new Store Free Mesh if Mapped Mesh Fails option to control whether the software 

retains that free mesh. For example, you may want to clear the Store Free Mesh if Mapped Mesh 
Fails check box when you want to see clearly any faces on which the software failed to generate a 

mapped mesh. 

A new customer default lets you control the default setting for the Store Free Mesh if Mapped Mesh 
Fails option. To access this default: 

1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→Meshing. 

3. Click the 2D Mapped Meshing tab and either select or clear the Keep Free Meshes check 

box. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file 

Toolbar 
Advanced Simulation→2D Mapped Mesh    

 

Improved selection of nodes and elements within a solid mesh 

What is it? 

When you select entities within a solid mesh, you can now control whether the software includes any 

internal nodes and elements in your selection. The Node and Element Display dialog box has a new 

Include Internal Nodes and Elements in Selection option that lets you include nodes and 

elements in the interior of a solid mesh in your selection regardless of whether those internal nodes and 

elements are currently displayed. In previous releases, you could only select internal nodes and elements 

if the Display Internal Edges option in the Mesh Display dialog box was selected.  

The Include Internal Nodes and Elements in Selection option works with all selection operations, 

including area selection, smart selection, and select all. By default, this option is turned on. 

Where do I find it? 

Application Advanced Simulation, Design Simulation 

Prerequisite An active FEM file. 

Menu Preferences→Node and Element Display 

 

Split Shell now splits a single triangle into four 

What is it? 

You can use the new Triangle to 4 Triangles option in the Type menu of the Split Shell dialog box 

to divide a single triangular element into four triangular elements. You can use Triangle to 4 Triangles 

when you need to locally refine a region within a triangular mesh. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file 

Toolbar 
Element Operations→Split Shell    

Menu Edit→Element→Split Shell 

 

Material orientation 

New material orientation definition methods 

What is it? 

New methods have been added for defining material orientation for shell and solid elements in the Mesh 
Associated Data dialog box, for the Nastran and Abaqus solvers. 

• Tangent Curve (Shell or solid elements) — Lets you define the material orientation by 

selecting a curve or edge on your geometry. For each element, the software finds the closest point 

on the selected curve or edge to the element centroid and sets the primary direction of the 

material coordinate system as tangent to that curve or edge. 

In the following example, the material orientation represented by the yellow arrows was defined 

by selecting the edge   . 

 

 Note 

When you define the material orientation for shell elements, you orient only the X-axis and 

Y-axis in the plane of the element. The Z-axis is fixed and is normal to the element. The 

orthogonality of X, Y, and Z means you only need to orient the X-axis. The right-hand rule 

applies. For solid elements, orienting two axes automatically derives the third. 

 

• Vector (Shell or solid elements) — Lets you define the material orientation vector either by 

selecting an edge in the geometry to infer a vector (see first example below) or by using the NX 

vector tools to define the vector (see second example below). 
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Vector inferred from edge (1) 
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Vector specified as X direction 

• Surface Normal (Solid elements only) — Lets you define the material orientation by selecting 

a surface on the geometry. For each element, the software finds the closest point on the face to the 

element centroid and then sets the primary direction as normal to the face at that point.  
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Primary direction normal to selected face (1) 

 Note 

You can view and control the display of the material orientation arrows in the graphics 

window using the Finite Element Model Check command. For more information, see 

**Unsatisfied xref title**. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file. 

Toolbar 
Advanced Simulation toolbar→Mesh Associated Data    

Menu Tools→Mesh Associated Data 

 

View options for material orientation on solid elements 

What is it? 

A new option, 3D Element Material Orientation, has been added to the Model Check dialog box 

that lets you view the material orientation display in the graphics window for solid elements. 

After defining material orientation, you can view the material coordinate system for each element in the 

graphics window. You can view the first, second, and third directions of the material coordinate systems 

independently, or all three simultaneously. You can also choose the colors in which to display the 

directions of the material coordinate systems. 

 

Only first direction shown (first direction is tangent to the curved geometry) 
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Complete coordinate systems shown (green is first direction; red is second direction) 

In addition to using color, you can identify the first, second, and third directions in a material coordinate 

system by looking at the size of the arrow heads. In the following graphic, the first, second, and third 

directions are identified. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains solid elements with material 

orientation defined. 

Toolbar Advanced Simulation toolbar→Finite Element Model Check 

   

Menu Analysis→Finite Element Model Check 
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Assembly FEM 

Map to individual components in a subassembly 

What is it? 

The Unmap command has been renamed to Map at Next Level. 

Within an assembly FEM, you can use the Map at Next Level command to associate a component FEM 

with an individual component in a CAD subassembly without associating it with the entire subassembly.  

This command changes the status of the CAD subassembly to Not Mapped    and the status of the 

components to Ignored   . Then you can right-click an individual component and select Map New or 

Map Existing to associate the component with a component FEM. 

 

(1) Mapped subassembly; (2) Same subassembly after Map at Next Level command; (3) Individual 

component mapped to a FEM 

You can also use the Map Sub Assemblies at Next Level command to perform the same function on 

the top-level CAD assembly. This command changes the status of all CAD subassemblies to Not 
Mapped and the status of all CAD components to Ignored. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active assembly FEM with the assembly loaded 

Simulation Navigator Right-click a CAD assembly node→Map at Next Level 

Right-click the top-level CAD assembly node→Map Sub 
Assemblies at Next Level 
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Usability improvements to Assembly Label Manager 

What is it? 

When defining an assembly FEM, you can specify offsets for the identifier labels the software generates 

for nodes, elements, and coordinate systems across component FEMs. Several usability enhancements 

have been made to the Assembly Label Manager dialog box to make the process of specifying these 

offsets easier. 

There are three methods for specifying how the automatic label offsets are applied: 

• Same Offsets in Component — One value is used for Offset to Nearest. For each 

component, the offset is the same for nodes, elements, and coordinate systems. The software 

calculates the highest-needed offset and applies it uniformly to all offsets within the component. 

The nodes, elements, and coordinate systems start with the same ID number in each component. 

This is a new type. 

• Same Nearest Value for All — One value is used for Offset to Nearest. For each 

component, the offset is calculated independently for nodes, elements, and coordinate systems. 

• Separate Nearest Value for All — Lets you specify different Offset to Nearest values for 

nodes, elements, and coordinate systems. For each component, the offset is calculated 

independently for nodes, elements, and coordinate systems. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active assembly FEM 

Simulation Navigator Right-click the assembly FEM node and choose Assembly Label 
Manager. 

 

Assembly FEM model checks improved 

What is it? 

Features have been added to the Finite Element Model Check dialog box specifically for Assembly 

FEMs.  

Model Setup check 

With an assembly FEM loaded and you open the Model Check dialog box, the following new Model 
Setup options are available. 

Assembly Check 

• Label — Checks for conflicts in node, element, and coordinate system labels across component 

FEMs and reports the label range in which the conflict occurs. 

• Connectivity — Checks for component FEMs that are not connected. 

• Comprehensive — Includes both the Label and Connectivity checks. 

Assembly Load 
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• All Components — Includes all components associated with the assembly FEM in the model 

check, regardless of load status. 

• Fully Loaded Components — Includes only fully loaded components in the model check. 

Duplicate Nodes check and merge 

The Duplicate Nodes check has been added for assembly FEMs. This command works as it does in 

component FEMs. However, it processes only the nodes that were created in the active assembly FEM 

and can merge a node created in the assembly FEM with a node in a component FEM. 

• Show Duplicate Nodes — Displays the duplicate nodes in the active assembly FEM. The 

duplicate nodes are displayed in yellow. 

• Merge Duplicate Nodes — Merges parent nodes in the active assembly FEM with any child 

nodes in the active assembly FEM or in a component FEM.  

 

Duplicate nodes indicated with yellow circles 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active assembly FEM 

Toolbar 
Advanced Simulation→Finite Element Model Check    

Menu Analysis→Finite Element Model Check 

 

Move Component command replaces Reposition Component 

What is it? 

You can change the position of a non-associative component FEM within an assembly FEM. For 

consistency with the Assemblies application, the Reposition Component command has been replaced 

with the standard Move Component command. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active assembly FEM 

Simulation Navigator Right-click a component FEM→Move Component 

 

Nastran environment 

Updates to Strategy Parameters and Contact Parameters modeling objects 

What is it? 

This release includes updates to the NX Nastran Strategy Parameters and Contact Parameters 

modeling objects. 

Strategy Parameters updates 

In the Strategy Parameters dialog box: 

• On the Analysis Options tab, a new Automatic option has been added to the Stiffness 
Matrix Stabilization Factor (MSTAB) list. With the Automatic option, the software 

automatically uses matrix stabilization if the ratio of maximum/minimum diagonal of factorized 

matrix is greater than 1.0E10. 

• On the Contact Control tab, a new Tensile Contact Forces (TNSLCF) option has been 

added. Use this option to indicate whether tensile consistent contact forces on quadratic 3D 

contact segments are allowed. 

See NXSTRAT in the NX Nastran Quick Reference Guide for more information. 

Contact Parameters updates 

In the Contact Parameters dialog box: 

• Use the new Include Shell Element Z-Offset option to control whether the software includes 

any shell element z-offset when determining the contact surfaces. This option corresponds to the 

ZOFFSET field in the BCTPARM Bulk Data entry. 

• Use the new All Contact Elements Can Become Inactive option to control whether all the 

contact elements can become inactive. This option corresponds to the CSTRAT field in the 

BCTPARM Bulk Data entry. 

See BCTPARM in the NX Nastran Quick Reference Guide for more information. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver 
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Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

New hyperelastic material models 

What is it? 

This release includes support for new NX Nastran hyperelastic material models. Hyperelastic materials let 

you model materials that are nearly incompressible but which undergo large strains. 

Hyperelastic Material Model Corresponding ANSYS Command 

Arruda-Boyce MATHE bulk data entry with Model field = Aboyce 

Foam MATHE bulk data entry with Model field = Foam 

Mooney-Rivlin MATHE bulk data entry with Model field = Mooney 

Ogden MATHE bulk data entry with Model field = Ogden 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with NX Nastran as the 

specified solver 

Toolbar 
Advanced Simulation→Material Properties    

 

Changes to the handling of MATS1 data 

What is it? 

When you export or solve a Nastran input file, Advanced Simulation now handles any defined material 

stress-strain (MATS1) data differently than in previous releases. In Advanced Simulation, you use the 

options in the Stress-Strain Related Parameters group in the Isotropic Material dialog box to 

define the stress-strain data.  

These changes are: 

• Depending on the option you select from the Yield Function Criterion (YF) list, you must 

now specify either a value in the Initial Yield Point (LIMIT1) or the Initial Friction Angle 
(LIMIT2) box. 

– If you choose von Mises or Tresca, you must specify an Initial Yield Point 

(LIMIT1) value. In Nastran, LIMIT1 should contain the material's Yield Strength (Ys) 

value. 
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– If you choose Mohr-Coulomb or Drucker-Prager, you must specify an Initial Yield 
Point (LIMIT1) value and an Initial Friction Angle (LIMIT2) value. 

Importantly, none of the materials in the NX material library currently have the LIMIT1 value 

defined. If you need to use a library material in a Nastran analysis, you must make a copy of that 

material and then edit the material to define the Initial Yield Point (LIMIT1) value. 

• Advanced Simulation no longer corrects defined stress-strain curves to meet Nastran 

requirements. Previously, the software verified that your stress-strain curve had its first point at 

(0,0) and its second point at (Ys/E, Ys). If the data did not meet those requirements, the software 

fixed it automatically. Now, Advanced Simulation leaves the stress-strain data as you defined it. 

If the stress-strain data is not defined correctly when you solve your model, Nastran issues a fatal 

error. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with NX Nastran as the 

specified solver 

Toolbar 
Advanced Simulation→Material Properties    

 

Bolt pre-loads now supported for Response Simulation analyses 

What is it? 

You can use the Bolt Pre-Load command to to apply a pre-load to a bolt modeled with CBAR or 

CBEAM type beam elements in a Response Simulation (SEMODES 103 - Response Simulation) 

analysis. Bolt pre-loads are only supported in the first two subcases in a Response Simulation: 

• Static Offset 

• Stress Stiffening 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with NX Nastran as the specified solver and 

SEMODES 103 - Response Simulation as the solution type and 

with either Subcase - Static Offset or Subcase - Stress 
Stiffening active in the Simulation Navigator 

Toolbar 
Advanced Simulation→Bolt Pre-Load    
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New weld-like glue algorithm 

What is it? 

Advanced Simulation now supports the new weld-like glue algorithm that was introduced in the NX 

Nastran 6.1 release. A surface-to-surface glue condition on non-coincident shell or solid faces can 

introduce artificial rotational energy into the solution. Generally, the problem occurs because the spring-

like glue elements do not transfer moments at the glue interface when glued faces are non-coincident 

and/or when loads are not normal to the glued faces. This is particularly noticeable in a normal mode 

solution when modes are found that contain an artificial rotational energy due to the glue condition. The 

new NX Nastran algorithm eliminates this artificial rotational energy.  

In NX Nastran 6.1, two new fields were added to the BGPARM bulk data entry to allow you to specify 

and work with this new algorithm. In Advanced Simulation, the Glue Parameters modeling object has 

been updated to support the new BGPARM fields. In the Glue Parameters dialog box: 

• The Alternate Glue Formulation option corresponds to the new GLUETYPE field on the 

BGPARM bulk data entry. Use this option to control the glue algorithm that NX Nastran uses. 

– Select Weld-Like Connection to use the new weld-like glue algorithm. 

– Select Normal and Tangential Springs to use the original, spring-like glue 

algorithm. 

• The Unitless Scale Factor for the Stiffness option corresponds to the new PENGLUE field 

on the BGPARM bulk data entry. Use this option to specify the penalty factor for the weld-like 

glue algorithm. 

 Note 

With the Normal and Tangential Springs option, use the Penalty Normal 
Direction and Penalty Tangential Direction options to specify the penalty factor. 

 

In most cases, the new weld-like glue algorithm represents the connection stiffness more accurately than 

the spring-like glue algorithm because it transfers moments at the glue interface. 

For more information, see New Weld-Like Glue Method in the NX Nastran 6.1 Release Guide and 

BGPARM in the NX Nastran Quick Reference Guide. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver. 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 
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PBUSH structural damping enhancements 

What is it? 

For NX Nastran models, new options have been added to the Damping tab in the PBUSH physical 

property table dialog box. Use these options to define structural damping for each degree-of-freedom for 

CBUSH elements. The ability to define direction-dependent structural damping for the PBUSH bulk data 

entry was introduced in the NX Nastran 6.1 release. Previously, you could only define a single, structural 

damping value (GE1) that applied to all 6 degrees-of-freedom. 

The new options in the PBUSH  dialog box let you specify separate structural damping values for the X, 

Y, and Z translations and rotations. The values you specify correspond to the GE1, GE2, GE3, GE4, GE5, 

and GE6 fields in the PBUSH bulk data entry. If you define a value for any of the Structural options on 

the Damping tab, you should define a value for all degrees-of-freedom that are critical to the result, 

because a blank field defaults to a value of zero. 

This release also includes support for the new BSHDAMP parameter, which lets you optionally ignore 

any of the GE2-GE6 fields and only use the GE1 field. By default, the software considers the new GE2-

GE6 fields. The new BSHDAMP list in the Solution Parameters dialog box (available from the 

Modeling Objects Manager dialog box) lets you control the setting for this parameter: 

• If you select SAME (PARAM, BSHDAMP=SAME), the software ignores the GE2-GE6 fields and only 

considers the single, structural damping value defined in the GE1 field. This corresponds to the 

behavior available in previous releases. 

• If you select DIFF  (PARAM, BSHDAMP=DIFF), the software considers the GE2-GE6 fields. 

For more information, see the NX Nastran 6.1 Release Guide and PBUSH in the NX Nastran Quick 

Reference Guide. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite A FEM file active with NX Nastran as the specified solver 

Toolbar 
Advanced Simulation→Physical Properties    

Menu Insert→Physical Properties 

 

PSHELL structural damping enhancements 

What is it? 

Beginning with the NX Nastran 6.1 release, the PSHELL bulk data entry supports including the structural 

damping coefficient (GE) on the associated materials: 

• MID1 = membrane material 

• MID2 = bending material 

• MID3 = transverse shear 

• MID4 = membrane-bending coupling 
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Previously, NX Nastran used the structural damping coefficient defined on the MID1 material for all 

materials associated with the PSHELL entry. 

Advanced Simulation now supports the new NX Nastran SHLDAMP parameter. You use the SHDAMP 

parameter to turn the structural damping coefficient capability on and off for a given analysis. The new 

SHLDAMP list in the Solution Parameters dialog box (available from the Modeling Objects 
Manager dialog box) lets you set this parameter. 

• If you select SAME (PARAM, SHLDAMP=SAME), which is the default, the software uses the 

structural damping coefficient (GE) defined on the MID1 material for the PSHELL entry for all 

MIDi materials for that PSHELL. 

• If you select DIFF  (PARAM, SHLDAMP=DIFF), the software uses the structural damping coefficient 

(GE) defined on each MIDi for the PSHELL entry, provided that the GE field is defined for any 

of the MID2, MID3, and/or MID4 materials in at least one PSHELL entry in the input file. With 

this option, if any structural damping coefficient (GE) value is blank, NX Nastran treats it as 

having a value of zero. 

For more information, see the PSHELL Structural Damping in the NX Nastran 6.1 Release Guide and 

SHLDAMP in the NX Nastran Quick Reference Guide. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver. 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

End releases for beam and bar elements 

What is it? 

You can now define end releases (also known as pin flags) at either end of a Nastran CBEAM or CBAR 

element in the Element Associated Data dialog box. Previously, you could define pin flags only at 

the Mesh Associated Data level. 

In a beam, end releases remove connections between a node and selected degrees of freedom. The degrees 

of freedom are defined in the element coordinate system. For the following example, a force is defined on 

the horizontal span. Because end releases are defined at the ends of the bracing beams, the solver does not 

transfer the moment load from the horizontal beam to the bracing beams. The moments are transferred 

across the other elements in the horizontal span. 
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Bridge model. (1) and (2) represent the end releases; force applied to horizontal span 

 

Bridge model; deflected shape with end releases 

 

Bridge model; deflected shape without end releases 

In the Element Associated Data dialog box, under the End Releases group (for End A and or End 

B of the element), you can set DOF1–6 to On to disconnect the following forces: 

• DOF1 — axial force in Plane 1 

• DOF2 — shearing force in Plane 1 

• DOF3 — shearing force in Plane 2  

• DOF4 — axial torque in Plane 2 

• DOF5 — moment in Plane 2 

• DOF6 — moment in Plane 1 

 Note 

Plane 1 is the XY plane formed by the X and Y axes in the element coordinate system. Plane 2 is 

the XZ plane formed by the X and Z axes. 

 



150    What's New in NX 7   whatsnew7 0  

In the previous example, DOF6 is set to On at the ends of the bracing beams (the model is shown in the 

XY plane). 

For more information, see Element associated data overview in the Advanced Simulation help. 

Why should I use it? 

You can define a release at the ends of beam or bar elements to model hinged or pinned connections. 

  



whatsnew7 0   What's New in NX 7    151 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains CBEAM or CBAR elements. 

Toolbar 
Element Operations→Element Associated Data    

Menu Edit→Element→Modify Associated Data 

 

Optional torsional mass moments of inertia for CROD and CBAR elements 

What is it? 

Advanced Simulation now supports the new TORSIN parameter that was introduced in the NX Nastran 

6.1 release. The TORSIN parameter lets you optionally include the torsional mass moment of inertia in 

the CROD and CBAR element mass matrices. By default, NX Nastran does not calculate torsional mass 

for CROD or CBAR elements, though it does for CBEAM elements. This can lead to differences when 

you compare results between equivalent models. 

The new TORSIN box in the Solution Parameters dialog box (available from the Modeling 
Objects Manager dialog box) lets you control the setting for this parameter: 

• If you enter 0, the software does not include the torsional mass moment of inertia for CROD and 

CBAR elements (the default). 

• If you enter 1, the software includes the torsional mass moment of inertia for CROD and CBAR 

elements. 

• If you enter 2, the software includes the torsional mass moment of inertia for CBAR elements 

only. 

• If you enter 3, the software includes the torsional mass moment of inertia for CROD elements 

only. 

For more information, see the NX Nastran 6.1 Release Guide and PBUSH in the NX Nastran Quick 

Reference Guide. 

CBAR axial torsional mass moment of inertia calculation 

NX Nastran calculates the CBAR axial torsional mass moment of inertia similarly to the CBEAM 

element using the equation: 

Ixx = ρL(I1+I2) 

where: 

Ixx = torsional mass moment of inertia 

ρ = density 

L = the length of the element 

I1 and I2 = area moments of inertia 
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CROD axial torsional mass moment of inertia calculation 

NX Nastran calculates the CROD axial torsional mass moment of inertia using the equation: 

Ixx = ρLIx 

where Ix = J = torsional constant. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

Specifying additional keywords and system cells 

What is it? 

A new Additional Keywords option has been added to the nastran Command Keywords options 

on the Solve Options page of the Solver Parameters dialog box. The nastran Command 
Keywords options include a subset of frequently used keywords for the nastran command, such as 

sdirectory and old. You can use the new Additional Keywords option to manually specify any 

additional keywords for the nastran command or any system cells for the NASTRAN executive control 

statement. The ability to manually specify specific keywords or system cells gives you greater control 

over how Nastran solves your model. 

For more information, see the nastran command and the NASTRAN statement in the NX Nastran Quick 

Reference Guide for a complete list of the supported keywords and system cells. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with NX Nastran or MSC Nastran as the 

specified solver 

Simulation Navigator Right-click the Simulation→New Solution, or right-click the current 

solution→Edit Solution 

Menu Insert→Solution 
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Results support enhancements 

Support for nonlinear stress results output 

What is it? 

Use the options on the new Nonlinear Stress tab in the Structural Output Requests dialog box to 

request the output of nonlinear element stresses for SOL 106 (NLSTATIC 106) analyses. These options 

let you control how the software presents the tabular listing of results, the location where the results are 

output, as well as the elements for which the software calculates the stresses. When you create a 

Nonlinear Stress type of output request, the software creates an NLSTRESS Case Control entry in the 

Case Control section of your Nastran input file. 

A new customer default lets you control whether the Enable NLSTRESS Request option on the 

Nonlinear Stress tab is selected by default. To set this default: 

1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→NASTRAN. 

3. Click the Solution tab and either select or clear the Nonlinear Stress option. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran or MSC Nastran 

as the specified solver 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

Shell thickness output for advanced nonlinear analyses 

What is it? 

Use the options on the new Shell Thickness tab in the Structural Output Requests dialog box to 

request the output of shell element thickness values for SOL 601 and 701 (ADVNL 601 and 701) 

analyses. NX Nastran only outputs shell thickness results for large strain analyses (analyses in which you 

include the parameter PARAM,LGSTRN,1). To set this parameter, select the new Large Strains check 

box on the Parameters page of the Create Solution or Edit Solution dialog box. 

When you create a Shell Thickness type of output request, the software creates a SHELLTHK Case 

Control entry in the Case Control section of your Nastran input file. For more information on shell 

thickness results, see SHELLTHK in the NX Nastran Quick Reference Guide. 

A new customer default lets you control whether the Enable SHELLTHK Request option on the 

Nonlinear Stress tab is selected by default. To set this default: 
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1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→NASTRAN. 

3. Click the Solution tab and either select or clear the Shell Thickness option. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver and ADVNL 601,106, ADVNL 601, 129, or ADVNL 701 as 

the solution type 

Simulation Navigator Either right-click a Simulation and select Create Solution, or right-

click the appropriate solution and select Edit Solution 

 

Support for gasket results output 

What is it? 

Use the options on the new Gasket Result tab in the Structural Output Requests dialog box to 

request the output of gasket results for SOL 601 (ADVNL 601,106 and ADVNL 601,129) analyses. 

Gasket results include gasket pressure, gasket closure, plastic gasket closure, gasket yield stress, and 

gasket status. When you create a Gasket Results type of output request, the software creates an 

GKRESULTS Case Control entry in the Case Control section of your Nastran input file. 

A new customer default lets you control whether the Enable GKRESULTS Request option on the 

Gasket Results tab is selected by default. To set this default: 

1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→Nastran. 

3. Click the Solution tab and either select or clear the Gasket Results option. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran as the specified 

solver and ADVNL 601,106 and ADVNL 601,129 as the solution 

type 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 
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Import and export enhancements 

Nastran import and export support enhancements 

What is it? 

This release includes enhancements to the import and export support for Nastran Bulk Data entries and 

Case Control commands. 

Newly supported bulk data entries and case control commands 

Name NX Nastran 

Import/Export 

Support 

MSC Nastran 

Import/Export 

Support 

Notes 

CDAMP3 and 

CDAMP4 

Yes (import 

support only) 

Yes (import 

support only) 

See **Unsatisfied xref title** for more information. 

CELAS3 and 

CELAS4 

Yes (import 

support only) 

Yes (import 

support only) 

See **Unsatisfied xref title** for more information. 

CMASS3 and 

CMASS4 

Yes (import 

support only) 

Yes (import 

support only) 

See **Unsatisfied xref title** for more information. 

CPYRAM Yes No See **Unsatisfied xref title** for more information. 

GKRESULTS (Case 

Control command) 

Yes No See **Unsatisfied xref title** for more information. 

MATG Yes Yes See **Unsatisfied xref title** for more information. 

MATHE Yes No See **Unsatisfied xref title** for more information. 

MATS1 Yes Yes See **Unsatisfied xref title** for more information. 

MEFFMASS (Case 

Control command) 

Yes Yes MEFFMASS is now supported for import into 

Advanced Simulation. 

NLSTRESS (Case 

Control command) 

Yes Yes See **Unsatisfied xref title** for more information. 

SHELLTHK (Case 

Control command) 

Yes No See **Unsatisfied xref title** for more information. 

SUPORT Yes No See **Unsatisfied xref title** for more information. 

USET Yes Yes See **Unsatisfied xref title** for more information. 

USET1 Yes Yes See **Unsatisfied xref title** for more information. 

 

Enhancements for previously supported bulk data entries and case control 
commands 

Name NX Nastran 

Import/Export 

MSC Nastran Newly Supported 

Fields and Other 

Notes 
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Support Import/Export Support Enhancements 

BCRESULTS 

(Case Control 

command) 

Yes No SET, SEPDIS  

BGPARM Yes No GLUETYPE, 

PENGLUE 

See **Unsatisfied xref 

title** for more 

information. 

BLSEG Yes Yes For export, the 

software now supports 

the use of both 

increasing and 

decreasing THRU 

options. 

 

CBAR Yes Yes PA, PB Pin flags are now 

supported as Element 
Associated Data. 

See **Unsatisfied xref 

title** for more 

information. 

MAT1 Yes Yes GE 
• The MCSID 

field is not yet 

supported. 

• See 

**Unsatisfied 

xref title** for 

more 

information. 

MAT2 Yes Yes GE 
• The MCSID 

field is not yet 

supported. 

• See 

**Unsatisfied 

xref title** for 

more 

information. 

MAT3 Yes Yes GE See **Unsatisfied xref 

title** for more 

information. 

MAT8 Yes Yes GE See **Unsatisfied xref 

title** for more 

information. 

MAT9 Yes Yes GE See **Unsatisfied xref 

title** for more 
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information. 

PBUSH Yes Yes GE2–GE6 This release adds 

support for the GE2-

E6 fields for NX 

Nastran. These fields 

were previously 

supported for MSC 

Nastran. See 

**Unsatisfied xref 

title** for more 

information. 

PLOADX1 Yes Yes  For export, the 

software now supports 

time-dependent 

pressure loads. 

TABLES1 Yes Yes  You can now define 

TABLES1 data in the 

context of MATS1 

material data. 

Previously, you could 

only define TABLES1 

data in the context of a 

MATHP type 

material. 

See **Unsatisfied xref 

title** for more 

information. 

 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Nastran parameter support updates 

What is it? 

Support has been added for a number of new NX Nastran and MSC Nastran parameters, and the default 

values of several existing parameters have been changed. When you create a Solution Parameters type 

of Modeling Object, these newly supported parameters now appear in the Solution Parameters 

dialog box. 

For more information on MSC Nastran parameters, see the MSC Nastran Quick Reference Guide. 
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Newly supported parameters 

Name NX Nastran 

Import/Export 

Support 

MSC Nastran 

Import/Export 

Support 

Notes 

ALPHA1FL N/A Yes  

ALPHA2FL N/A Yes  

ARBMASP N/A Yes  

ARBMFEM N/A Yes  

ARBMPS N/A Yes  

ARBMSS N/A Yes  

ARBMSTYP N/A Yes  

AUTOGOUT N/A Yes  

BSHDAMP Yes N/A See **Unsatisfied xref title** for more information. 

CFDIAGP N/A Yes  

CFRANDEL N/A Yes  

CORITAN N/A Yes  

CQC N/A Yes  

DIROUT N/A Yes  

DREPONLY Yes N/A  

DV3PASS N/A Yes  

ENFMETH N/A Yes  

ESLFSAV N/A Yes  

FASTFR N/A Yes  

FULLSEDR N/A Yes  

HTOCITS N/A Yes  

HTOCPRT N/A Yes  

HTOCTOL N/A Yes  

MDOPT14 N/A Yes  

MDOTM N/A Yes  

MDOTMFAC N/A Yes  

MDOF Yes N/A  

MGRID Yes N/A  
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MHRED N/A Yes  

NEWMARK N/A Yes  

OSETELE N/A Yes  

OSETGRD N/A Yes  

PATPLUS N/A Yes  

PERCENT N/A Yes  

RADMOD N/A Yes  

RANCPLX Yes N/A  

ROTSYNC Yes N/A  

RSTTEMP N/A Yes  

SHLDAMP Yes Yes 

(introduced in 

NX 5) 

See **Unsatisfied xref title** for more information. 

SPARSEPH N/A Yes  

SQSETID N/A Yes  

SRCOMPS Yes Yes 

(introduced in 

NX 5) 

SRCOMPS controls the computation and printout of 

ply strength ratios. 

TCHECK N/A Yes  

TDMIN N/A Yes  

TFSTMFAC N/A Yes  

TORSIN Yes N/A See **Unsatisfied xref title** for more information. 

WRH N/A Yes  

ZROVEC N/A Yes  

 

NX Nastran Parameters with updated default values 

Parameter New Default Value Previous Default Value 

BOLTFACT 1.0E7 1.0E6 

K6ROT 100.0 0.0 and 100 

SUBID 1 0 
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MSC Nastran Parameters with updated default values 

Parameter New Default Value Previous Default Value 

DESPCH1 0 6 

ERROR -1 0 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran or MSC Nastran 

specified as the solver 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

Nastran system cell support enhancements 

What is it? 

This release includes enhanced support for Nastran system cells. System cells are Executive System 

operational parameters specified by the NASTRAN statement. These enhancements include: 

• Import support for NX Nastran and MSC Nastran system cells. When you import a Nastran input 

file, Advanced Simulation now imports any system cell settings defined in that file. In previous 

releases, Advanced Simulation did not import any system cells specified in your Nastran input 

file. 

• Support for new NX Nastran and MSC Nastran system cells, as well as updates to currently 

supported system cells. When you create a System Cells type of Modeling Object, these 

newly supported system cells now appear in the System Cells dialog box.  

NX Nastran system cell support updates 

System Cell Name Notes 

206 DCMPSEQ Default value = 4 

210 None  

252 None  

357 RSEQCONT  

370 QRMETH Acceptable values: 3 or 5 

404 None  

413 OP2FMT  
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415 OP4FMT  

416 INP4FMT  

424 SPCHOL Acceptable values: 4 or 5 

444 TEMPWARN  

461 None  

462 None  

463 None  

464 None  

 

For more information about these system cells, see the NX Nastran Quick Reference Guide. 

MSC Nastran system cell support updates 

System Cell Name Notes 

205 None  

219 None  

220 None  

221 None  

274 DBCFACT  

311 TBCMAG  

408 DEF_DENS  

410 DEF_TECO  

411 DEF_TEIJ  

412 DEF_DAMP  

428 None  

431 NONLRGAP The name of the system cell is 

NONLRGAP and not NLRGAP, as 

documented by MSC. 

445 MNLQ4C  
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file with NX Nastran or MSC Nastran 

specified as the solver 

Toolbar 
Advanced Simulation→Modeling Objects    

Menu Insert→Modeling Objects 

 

Extended mesh validity checking available during import 

What is it? 

A new Enable extended data checking option has been added to the Advanced Options group in 

the Import Simulation dialog box. When you import a Nastran .dat or .op2 file, select Enable 
extended data checking to have the software check for the existence of each node on a given element 

in your input file. If any of an element's nodes are missing from the input file, the software: 

• Does not import the element. 

• Issues an error message when it first encounters an element with missing nodes. 

• Clearly lists that the element failed to import in the Analysis of Import report as shown below. 

 

In previous releases, if you imported a Nastran input file in which even a single node was missing, the 

import operation appeared to proceed normally, though the software did not import the mesh. The 

software did not issue any error messages in the import summary, and it created a mesh node in the 

Simulation Navigator. The only indication of a problem was the absence of a displayed model in the 

graphics window. 
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Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Enhanced import support for connection elements 

What is it? 

You can now import the following additional types of Nastran CDAMP, CELEAS, and CMASS 

connection elements from Nastran .dat and .op2 files into Advanced Simulation: 

• CDAMP3 and CDAMP4 

• CELAS3 and CELAS4 

• CMASS3 and CMASS4 

Currently, these types of elements are not directly supported in Advanced Simulation. During the import 

process, the software converts these elements to the most closely related, supported element types, as 

shown in the following table: 

Nastran Element Type Type Converted to During Import 

CDAMP3 CDAMP1 

CDAMP4 CDAMP2 

CELAS3 CELAS1 

CELAS4 CELAS2 

CMASS3 CMASS1 

CMASS4 CMASS2 

 

For more information on these types of elements, see the NX Nastran Quick Reference Guide and the NX 

Nastran Element Library Reference Manual. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Import changes for SPOINT entries 

What is it? 

Nastran uses the SPOINT bulk data entry to define scalar points. Scalar points have a single degree-of-

freedom. In Nastran: 
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• You can explicitly define a scalar point by creating an SPOINT entry in the bulk data section of 

your input file. 

• You can implicitly define a scalar point by referencing the ID of a scalar point on a 

CDAMP1/2/3/4, CMASS1/2/3/4, or CELAS1/2/3/4 element entry. If you specify a scalar point 

on one of these entries, you do not need to include an SPOINT entry in the bulk data section of 

your input file. 

Advanced Simulation now allows you to import implicitly defined SPOINT bulk data entries. If your .dat 

file contains CDAMP1/2/3/4, CMASS1/2/3/4, or CELAS1/2/3/4 elements that reference an SPOINT, the 

software imports that SPOINT as a node, places its location at the origin, and fixes DOF 23456. The 

software gives the new node the same ID as the original SPOINT, and it modifies any element definitions 

that originally referenced the SPOINT to reference the new node instead. If you later export this model 

back to Nastran, the software writes this node out using a Nastran GRID bulk data entry that is fixed in 

DOF 23456. 

For more information on SPOINTs, see the SPOINT in the NX Nastran Quick Reference Guide and 

Understanding Scalar Points in the NX Nastran User's Guide. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Import support for HAT1 beam cross sections 

What is it? 

For the PBARL and PBEAML beam cross section property bulk data entries, you can now import the 

Nastran HAT1 beam cross section type (TYPE field =HAT1). This allows you to import bar and beam 

elements that have a HAT1 type cross section defined in your input file. In previous release, only ROD, 

TUBE, I1, CHAN, BOX, and BAR type sections were supported. 

 Note 

Because the Section dialog box in Advanced Simulation does not support HAT1 as a standard 

beam cross section shape, Advanced Simulation imports HAT1 cross sections as user-defined thin 

walled sections. 

 

When you solve your model, the software computes the following properties for HAT1 cross sections: 

• Area 

• Iz, Iy, Iyz 

• K  

• Yelem and Zelem 

• The X and Y components of stress recovery points C, D, E, and F 
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Definition of HAT1 beam cross section geometry and stress recovery points 

For more information, see PBARL and PBEAML in the NX Nastran Quick Reference Guide. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Additional import support for Response Simulation 

What is it? 

You can now import the following loads and boundary conditions used in SOL 103-Response Simulation 

analyses: 

• Fictitious Support (SUPORT) 

• Enforced Motion Location (USET,U2 and USET1,U2) 

• Nodal Force Location (USET,U3 and USET1,U3) 

For more information, see SUPORT, USET, and USET1 in the NX Nastran Quick Reference Guide. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Abaqus environment 

Abaqus keyword support enhancements 
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What is it? 

This release includes improved import and export support for the following Abaqus keywords: 

Command Supported 

Parameters 

Import 

Support 

Export Support For More Information 

*CLEARANCE  Yes Yes See **Unsatisfied xref 

title** for more 

information. 

*GAP 

CONDUCTANCE 

 Yes Yes See **Unsatisfied xref 

title** for more 

information. 

*GASKET 

BEHAVIOR 

NAME Yes Yes See **Unsatisfied xref 

title** 

*GASKET 

ELASTICITY 

COMPONENT, 

VARIABLE 

Yes Yes See **Unsatisfied xref 

title** 

*GASKET SECTION ELSET, 

BEHAVIOR, 

MATERIAL, 

ORIENTATION, 

STABILIZATION 

STIFFNESS 

Yes Yes See **Unsatisfied xref 

title** 

*GASKET 

THICKNESS 

BEHAVIOR 

DIRECTION, 

TENSILE 

STIFFNESS 

FACTOR, TYPE, 

VARIABLE, 

SLOPE DROP, 

YIELD ONSET 

Yes Yes See **Unsatisfied xref 

title** 

*HYPERELASTIC ARRUDA-

BOYCE, 

MARLOW, 

MOONEY-

RIVLIN, NEO 

HOOKE, 

OGDEN, 

POLYNOMIAL, 

REDUCED 

POLYNOMIAL, 

TEST DATA, 

VAN DER 

WAALS, YEOH 

No Yes See **Unsatisfied xref 

title** 

*HYPERFOAM TEST DATA No Yes See **Unsatisfied xref 

title** 

*INCLUDE INPUT Yes No See **Unsatisfied xref 
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title** 

*OUTPUT/*NODE 

OUTPUT/*ELEMENT 

OUTPUT 

 Yes Yes See **Unsatisfied xref 

title** for more 

information. 

 

Enhancements for previously supported keywords 

Name Newly Supported Parameters Notes 

*ORIENTATION NAME, SYSTEM The *ORIENTATION keyword is 

now supported for import. Previously, 

*ORIENTATION was only supported 

for export. 

See **Unsatisfied xref title** for 

more information. 

*PRE-TENSION 

SECTION 

SURFACE See **Unsatisfied xref title** for 

more information. 

 

Support for new element types 

This release also includes support for several new types of Abaqus elements. See **Unsatisfied xref 

title** for more information. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation or File→Export→Simulation 

 

New hyperelastic material models 

What is it? 

This release includes support for an expanded range of Abaqus hyperelastic material models, including 

several models in which you can use test data to define certain material properties. This release also 

includes support for a new Gasket Behavior material. 

• Hyperelastic materials let you model materials that are nearly incompressible but which undergo 

large strains. 

• The Abaqus Gasket Behavior material lets you model gasket behavior properties, such as 

elastic properties for the membrane and transverse shear behaviors of a gasket, for gasket 

analyses. 
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New materials 

Material Corresponding Keyword 

Arruda-Boyce *HYPERELASTIC keyword with both the ARRUDA-BOCYE 

parameter (constants option) 

Arruda-Boyce Test Data *HYPERELASTIC keyword with the ARRUDA-BOCYE and 

TEST DATA INPUT parameters 

Foam *HYPERFOAM keyword (constants option) 

Foam Test Data *HYPERFOAM keyword with the TEST DATA INPUT 

parameter 

Gasket Behavior *GASKET BEHAVIOR keyword 

Marlow *HYPERELASTIC keyword with the MARLOW parameter 

Mooney-Rivlin *HYPERELASTIC keyword with the MOONEY-RIVLIN 

parameter (constants option) 

Neo Hooke *HYPERELASTIC keyword with the NEO HOOKE parameter 

(constants option) 

Neo Hooke Test Data *HYPERELASTIC keyword with both the NEO HOOKE and 

TEST DATA INPUT parameters 

Ogden *HYPERELASTIC keyword with the OGDEN parameter 

(constants option) 

Ogden Test Data *HYPERELASTIC keyword with the OGDEN and TEST 

DATA INPUT parameters 

Polynomial *HYPERELASTIC keyword with the POLYNOMIAL 

parameter (constants option) 

Reduced Polynomial *HYPERELASTIC keyword with the REDUCED 

POLYNOMIAL parameter (constants option) 

Van Der Waals *HYPERELASTIC keyword with the VAN DER WAALS 

parameter 

Yeoh *HYPERELASTIC keyword with the YEOH parameter 

(constants option) 

Yeoh Test Data *HYPERELASTIC keyword with both the YEOH and TEST 

DATA INPUT parameters 

 

Defining material constants using test data 

With the test data material types, you can use a field to specify the deformation modes that define the 

material constants with test (experimental) data. 
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• Use the UNIAXIAL Tension/Compression option to specify uniaxial test data. This option 

corresponds to the Abaqus *UNIAXIAL TEST DATA keyword. With UNIAXIAL 
Tension/Compression, you define a table field in which you list the material's nominal stress 

(TU) and nominal strain values (εU) on each line. 

• Use the BIAXIAL Tension option to specify biaxial test data. This option corresponds to the 

Abaqus *BIAXIAL TEST DATA keyword. With BIAXIAL Tension, you define a table field in 

which you list the material's nominal stress (TB) and nominal strain values (εB) on each line. 

• Use the PLANAR - Pure Shear option to specify planar (or pure shear) data. This option 

corresponds to the Abaqus *PLANAR TEST DATA keyword. With PLANAR - Pure Shear, 

you define a table field in which you list the material's nominal stress (TS) and nominal strain in 

the direction of loading (εS) on each line. 

• Use the Pure Volumetric Compression option to specify volumetric loading test data to 

include user-defined material compressibility. With Pure Volumetric Compression, you 

define a table field in which you list the material's pressure (p) and the volume ratio, J (current 

volume/original volume) on each line. 

Depending upon the material's type, you can use one or more of these options to define the experimental 

stress-strain data. 

• With the Arruda-Boyce Test Data, Marlow, and Foam Test Data materials, you can only 

use one of the test data options to define the experimental test data. If you use more than one, 

when you export or solve your model, the software only writes out the first applicable test data 

curve. The order in which the software searches for the appropriate test data option depends on 

the material type, as follows: 

– Arruda-Boyce Test Data: BIAXIAL Tension then UNIAXIAL 
Tension/Compression 

– Marlow: BIAXIAL Tension, then PLANAR - Pure Shear, then UNIAXIAL 
Tension/Compression 

– Foam Test Data: PLANAR - Pure Shear, then UNIAXIAL Tension/Compression, 

then Pure Volumetric Compression 

• With the Mooney-Rivlin Test Data, Neo Hooke Test Data, Ogden Test Data, Reduced 
Polynomial, Van Der Waals, and Yeoh Test Data material types, you can use up to four of 

the options to define the experimental test data. If you use more than one, when you export or 

solve your model, the software writes out the test data option in the following order: BIAXIAL 
Tension, then PLANAR - Pure Shear, then UNIAXIAL Tension/Compression, then 

Pure Volumetric Compression. 

For more information, see: 

• *HYPERELASTIC, *UNIAXIAL TEST DATA, *BIAXIAL TEST DATA, *PLANAR TEST DATA, 

and *VOLUMETRIC TEST DATA in the Abaqus Analysis Keywords Manual. 

• Hyperelastic behavior of rubberlike materials in the Abaqus Analysis User's Manual. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with Abaqus as the specified 

solver 

Toolbar 
Advanced Simulation→Material Properties    

 

Including data from an external file in Abaqus input files 

What is it? 

Advanced Simulation now supports the *INCLUDE keyword when you import an Abaqus input file. The 

*INCLUDE keyword lets you specify the name of an external file that contains a portion of your input 

file. The external file can include model definition data, comment lines, or even references to other 

external files. See the Abaqus Analysis User's Manual and Abaqus Keywords Reference Manual for more 

information. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Solver parameter to export group data 

What is it? 

A new Write out group data option has been added to the Solver Parameters dialog box. When you 

export or solve your model, this option controls whether the software exports any groups in your model 

using the Abaqus *NSET and *ELSET commands. 

• If you select this option, the software writes out the group data in your model to the Abaqus input 

file using the *NSET and *ELSET commands. 

• If you clear this option, the software does not write out the group data in your model to the 

Abaqus input file. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Simulation Navigator Right-click a solution→Solver Parameters 
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Bolt pre-loads now supported for solid elements 

What is it? 

In the Abaqus solver environment, you can now define a pre-load on a bolt modeled with solid 

(continuum) elements. In previous releases, you could only define a bolt pre-load on a bolt modeled with 

beam (B31) elements. 

In the Bolt Pre-Load dialog box, use the new Force on 3D Elements option in the Type list to 

define a pre-load on solid elements. With this option, you select either elements or faces that define a pre-

tension section.  

In Abaqus, a pre-tension section is defined as a surface inside the bolt that bisects the bolt. The software 

transmits the specified pre-load force across the pre-tension section by means of a pre-tension node that 

you specify. This pre-tension node must not be attached to any element in your model. 

 Note 

If you do not specify a pre-tension node, the software creates a pre-tension node for you when you 

export or solve your model. 

 

The software applies the load along a vector that is normal to the pre-tension section. The new Section 
Normal option lets you control how the software computes this normal. 

• If you select Average Surface Normal, the software computes an average normal to the 

section that faces away from the underlying continuum elements. 

• If you select User Defined, you can define the vector to specify the normal. This option is 

useful when the direction in which you want to apply the load is different from the average 

normal to the pre-tension section. 

The following graphic shows an example of a bolt created with solid elements. (A) shows the pre-tension 

section, (B) shows the pre-tension node, and (C) shows the normal to the pre-tension section. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Advanced Simulation→Bolt Pre-Load    

 

Initial clearance values for contact and bolt contact analyses 

What is it? 

You can use the new Contact with Clearance and Bolt Contact with Clearance simulation objects 

to define precise initial clearance or overclosure (initial penetration) values for the nodes on the slave 

(dependent) surface in a contact pair. With both Contact with Clearance and Bolt Contact with 
Clearance, the initial clearance or overclosure value you specify overwrites the initial clearance or 

overclosure value that the software calculates at each slave node. 

• Use Contact with Clearance to define initial clearances or overclosures when you model 

contact between two surfaces. 

• Use Bolt Contact with Clearance to define initial clearances or overclosures when you model 

contact between a single-threaded bolt and a bolt hole. 

Contact with clearance for threaded bolts 

The Bolt Contact with Clearance dialog box includes additional Clearance Definition options that 

let you model the thread characteristics of a bolt even if detailed thread geometry is not included in the 

model. These options let you specify details about the bolt threads, including the half thread angle (α), 

pitch (p, or the thread-to-thread distance), and major (d) and mean (md) bolt diameters. You also use the 

Bolt Axis options to define two points (a and b) along the bolt's axis. The software uses these points to 

generate the bolt's contact normal directions. 
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Clearance or overclosure value can be uniform or spatially varying 

In the Contact with Clearance and Bolt Contact with Clearance dialog boxes, you can use the 

Clearance Definition options to define the clearance or overclosure value as either uniform or spatially 

varying for the contact pair. From the Value list: 

• If you select Expression, you can specify a uniform clearance or overclosure value for the 

contact pair. A positive value indicates a clearance value, and a negative value indicates an 

overclosure value. 

• If you select Field, you can specify spatially varying clearances or overclosures. With this 

option, you use a table field to specify the clearance at a single node or set of nodes on the slave 

surface. In the table field, the node ID is the independent variable, while the clearance or 

overclosure value is the dependent variable. You can also specify a Scale Factor to apply to the 

field. 

Contact with clearance is supported only in small-sliding contact analyses 

You can only use the Contact with Clearance or Bolt Contact with Clearance commands when 

you are using the small-sliding contact formulation in your analysis. In Abaqus, you use the *CONTACT 

PAIR keyword to specify the contact formulation. In Advanced Simulation, you use a Contact Pair 

modeling object to specify the parameters for the *CONTACT PAIR keyword: 

1. In the Contact Pair dialog box, select Small from the Sliding Type list to use the small-

sliding formulation instead of the finite-sliding formulation. 

2. In the Contact with Clearance or Bolt Contact with Clearance dialog box, use the 

Contact Pair option to associate the Contact Pair modeling object with the simulation object. 
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Associated Abaqus keywords 

When you export or solve your model, the software uses the options you specify in the Contact with 
Clearance dialog box to define the *CONTACT PAIR and *CLEARANCE keywords in your Abaqus 

input file. For more information, see Adjusting Initial Surface Positions and Specifying Initial Clearances 

in Abaqus/Standard Contact Pairs in the Abaqus Analysis User's Manual and *CLEARANCE and 

*CONTACT PAIR in the Abaqus Keywords Reference Manual. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Advanced Simulation→Contact with Clearance    or Bolt 

Contact with Clearance    

 

New thermal conductance boundary condition 

What is it? 

When you are working with Abaqus as your solver, you can use the new Surface-to-Surface Thermal 
Conductance simulation object to model conductive heat transfer between proximate or contacting 

surfaces. 

In the Surface-to-Surface Thermal Conductance dialog box, you can use the Conductance 
Dependency options to model the conductive heat transfer as a function of: 

• The clearance between the contacting surfaces (Clearance option). 

• The contact pressure at the interface between the contacting surfaces (Pressure option). 

• Both the clearance and the contact pressure (Clearance and Pressure option). 

In Advanced Simulation, you use fields to define how the heat transfer varies with the clearance and/or 

contact pressure. 

When you export or solve your model, the software uses the options you specify in the Surface-to-
Surface Thermal Conductance dialog box to define the *GAP CONDUCTANCE keyword in your 

Abaqus input file. For more information, see Thermal Contact Properties in the Abaqus Analysis User's 

Manual and *GAP CONDUCTANCE in the Abaqus Keywords Reference Manual. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver and 

Thermal as the selected analysis type 

Toolbar Advanced Simulation→Surface-to-Surface Thermal 

Conductance    
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Initial support for Abaqus output database files 

What is it? 

On Windows platforms, this release includes initial support for Abaqus output database files (*.odb) files. 

In this release, you can: 

• Import results into Post-Procressing and create displays. 

• Output results from selected analysis steps to an ODB file. 

In previous releases, Advanced Simulation only supported the Abaqus results file (*.fil). 

Customer default setting necessary to activate ODB support 

ODB file support in Advanced Simulation is controlled through a new ABAQUS File Extension 

customer default. To activate ODB support: 

1. From the File menu, choose Utilities→Customer Defaults. 

2. In the Customer Defaults dialog box, choose Simulation→ABAQUS. 

3. Click the Results File tab and select ODB as the ABAQUS File Extension default. 

The next time you start NX, Advanced Simulation links the Abaqus libraries that are necessary 

for working with ODB files. 

With the ABAQUS File Extension default: 

• If you select FIL, you can only import and work with Abaqus results (*.fil) files. 

• If you select ODB, you can import and work with both Abaqus results (.*fil) files and ODB files. 

Customer default setting also controls default Abaqus result file type 

When you select ODB as the ABAQUS File Extension default, the software also sets your default 

output file type for all Abaqus analyses to ODB. With the ODB default selected: 

• On the Output tab in the Create Solution Step dialog box, the Written to ODB option is 

selected by default. 

• In both the Results node in the Simulation Navigator and in the Post-Processing 
Navigator, the software looks for files in your current directory that have the .odb extension. If 

your directory only contains a FIL file and not an ODB file, the software does not display any 

results. 

 Note 

To display results from a FIL file when ODB is selected as the ABAQUS File 
Extension default, use the File→Import→Simulation command. 
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Supported ODB version 

Advanced Simulation currently supports Abaqus 6.8-EF2 version output database (ODB) files on 

Windows platforms. You can import files in ODB 6.8-EF2 format and earlier. Advanced Simulation 

exports any results to an ODB file in the 6.8-EF2 format. If you try to import an ODB file from an earlier 

version of Abaqus, such as Abaqus 6.7-5 or 6.8-2, NX prompts you to convert the file to the 6.8-EF2 

version. 

Ability to animate across load cases 

What is it? 

For solutions that include multiple load cases, you can now animate the results across the load cases. The 

Animation dialog box includes two options: Result and Iterations. The Iterations option lets you 

specify a Start Load Case, Start Iteration (if the starting load case contains iterations), and End 
Load Case, as well as a Step increment to determine the number of frames in the animation.  

For example, suppose you have three load cases (1, 2, and 3 in the picture below) and you want the 

animation to start at the first load case and end after the last load case. 

 

  



whatsnew7 0   What's New in NX 7    177 

 

In this example, you would choose Load Case 1 as the Start Load Case and Load Case 3 as the 

End Load Case. The following animated picture shows the result. The first and last load cases each 

have one static step and the second load case has 10 iterations. The Step option is set to 1, which means 

the animation includes a frame for each step and iteration between the start and end load case. Therefore, 

the animation contains 12 frames. Note the load case and iteration number indicated by the arrow in the 

picture. 

 

 Note 

In this example, all iterations in Load Case 2 were included automatically because it was not the 

starting or ending load case. You can specify a Start Iteration only if the load case that contains 

iterations is specified as either the Start Load Case or the End Load Case.  

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Post-Processing→Animation    

 

New option to control the import of ELSETs 
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What is it? 

A new option in the Import Simulation dialog box lets you control whether the software imports any 

implicitly defined Abaqus ELSETs in your input file as Advanced Simulation groups. In Abaqus, you can 

implictly define an ELSET by specifying that all elements of a specific type comprise that set. For 

example, the following syntax creates an ELSET named set1 that contains all the C3D4 type elements in 

the model: 

*ELEMENT, TYPE=C3D4, ELSET=set1, 

1,  

2 

In contrast, you create an explicitly defined ELSET by directly listing the elements that form that set. For 

example, the following syntax creates an ELSET named set2 that contains elements 6, 7, 8, 17, and 26: 

*ELSET, NAME=set2 

6,7,8,17,26 

If your input file contains implicitly defined ELSETs, you can use the new Import implict ELSET as 
group option in the Advanced Options group to control how the software imports those sets. 

• If you select Import implicit ELSET as group, the software imports any implicitly defined 

ELSETS in your input file. It uses those ELSETS to create groups. 

• If you clear the Import implicit ELSET as group check box, the software does not import any 

implicitly defined ELSETS as groups. 

Clearing the Import implicit ELSET as group check box can improve the import performance of your 

input file. 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

ANSYS environment 

ANSYS command support enhancements 

What is it? 

This release includes improved import and export support for ANSYS commands. 

Command Supported 

Options or 

Arguments 

Unsupported or 

Partially Supported 

Options 

Location in Advanced 

Simulation User 

Interface 

For More Information 

TB, GASKET MAT, NPTS, 

TBOPT 
• NTEMP is 

not 

supported for 

loading or 

unloading 

Materials dialog box See **Unsatisfied xref 

title** and 

**Unsatisfied xref 

title** 



whatsnew7 0   What's New in NX 7    179 

 

curves 

• EOSOPT is 

currently 

unsupported 

TB, HYPER MAT, NPTS, 

TBOPT* 
• NTEMP and 

EOSOPT are 

currently 

unsupported 

• The 

following 

parameters 

for TBOPT 

are 

supported: 

MOONEY, 

OGDEN, 

BLATZ, 

FOAM, 

BOYCE 

Materials dialog box See **Unsatisfied xref 

title** 

 

Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation or File→Export→Simulation 

 

New hyperelastic material models 

What is it? 

This release includes support for a number of new ANSYS hyperelastic material models. Hyperelastic 

materials let you model materials that are nearly incompressible but which undergo large strains. 

Hyperelastic Material Model Corresponding ANSYS Command 

Arruda-Boyce TB command with the HYPER,,,,BOYCE option 

Foam TB command with the HYPER,,,,FOAM or HYPER,,,,BLATZ 

options 

Gent TB command with the HYPER,,,,GENT option 

Mooney-Rivlin TB command with the HYPER,,,,MOONEY option 

Neo Hooke TB command with the HYPER,,,,NEO option 

Ogden TB command with the HYPER,,,,OGDEN option 

Polynomial TB command with the HYPER,,,,POLY option 
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Yeoh TB command with the HYPER,,,,YEOH option 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM, idealized part, or part with ANSYS as the specified 

solver 

Toolbar 
Advanced Simulation→Material Properties    

 

Solver parameter to group face pressure loads 

What is it? 

A new Create ANSYS components (CM) for similar loads option has been added to the Solver 
Parameters dialog box. When you export or solve your model, this option controls whether the software 

uses the ANSYS CM command to group all elements that have the same face Pressure load into a 

component. 

• If you select this option, the software uses the CM command to group all the elements with the 

same face Pressure load and only writes out a single face pressure (SFE) command in your 

ANSYS input file. 

• If you clear this option, the software writes out individual single face pressure (SFE) commands 

for each element in your ANSYS input file. 

You may want to select the Create ANSYS components (CM) for similar loads option if you plan 

to work with your ANSYS input file outside of Advanced Simulation. For example, if you select this 

option, you can later select the surface pressures by their component name in the ANSYS pre- and post-

processing software. Additionally, the Create ANSYS components (CM) for similar loads option 

creates fewer SFE commands, so you may want to select the option to make manually editing your input 

file easier. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with ANSYS as the specified solver 

Simulation Navigator Right-click a solution→Solver Parameters 

 

New options to control the deletion of loads at the end of a step 
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What is it? 

A new Delete load options tab has been added to the Create Solution Step and Edit Solution 
Step dialog boxes. The options on this tab control whether forces and moments, body loads, and element 

body loads are kept or deleted by ANSYS at the end of the current solution step. These options 

correspond to the ANSYS DDELE, FDELE, BFDELE, and BFEDELE commands. 

 Note 

Currently, you can only use these options to delete the loads or constraints on all nodes or elements 

to which they are applied. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Simulation Navigator Either right-click a solution and select Create Step, or right-click the 

appropriate solution step and select Edit Solution Step 

 

Cumulative loading options now preserved on import 

What is it? 

When you import an ANSYS input file into Advanced Simulation, the software now preserves the 

settings of any cumulative option commands (DCUM, FCUM, SFCUM, and BFCUM). In ANSYS, you 

use these commands to specify whether the software should add (ADD), replace (REPL), or ignore 

(IGNO) a repeated load or constraint on a particular degree-of-freedom. In previous releases, the software 

always imported any cumulative option command with a setting of ―replace‖ (REPL), regardless of what 

you actually specified in the input file. Now, the software correctly preserves the specified cumulative 

option setting when you import the file. 

 Note 

Advanced Simulation does not import any cumulative options as a Solution Step attribute. 

Instead, the software converts the load or boundary condition data into an equivalent load or 

boundary condition with the appropriate cumulative option setting. 

 

For example, suppose you have the following constraints on node ID2: 

• Step 1: UX = 1mm, UZ= 1.2mm 

• Step 2: UX = 1.5mm, UY=1 

In step 2 of the analysis, how the software resolves the constraint on node ID2 depends on the setting of 

the DCUM command: 

• If the DCUM option is set to REPL, the resolved constraint for node ID2 is UX = 1.5, UY = 1 

(UZ is removed) 

• If the DCUM option is set to ADD, the resolved constraint for node ID2 is UX = 2.5, UY = 1, UZ 

= 1.2 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Menu File→Import→Simulation 

 

Support for importing loads and constraints from binary files 

What is it? 

When you import an ANSYS binary file into Advanced Simulation, the software now imports any loads 

(forces/moments) and constraints (displacements and temperatures) defined in that file. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with ANSYS as the specified solver 

Menu File→Import→Simulation 

 

LS-DYNA environment 

LS-DYNA keyword support 

What is it? 

Advanced Simulation now provides export support for the following LS-DYNA keywords: 

Keyword For More Information 

*CONTROL_SHELL See **Unsatisfied xref title** 

*INTEGRATION_SHELL See **Unsatisfied xref title** 

*MAT_COMPOSITE_DAMAGE See **Unsatisfied xref title** 

*PART_COMPOSITE See **Unsatisfied xref title** 

*SET_NODE_LIST See **Unsatisfied xref title** 

*SET_NODE_BEAM See **Unsatisfied xref title** 

*SET_DISCRETE See **Unsatisfied xref title** 

*SET_SHELL_LIST See **Unsatisfied xref title** 

*SET_SOLID See **Unsatisfied xref title** 

*SET_TSHELL See **Unsatisfied xref title** 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with LS-DYNA as the specified solver 

Toolbar File→Export→Simulation 

 

Support for laminates 

What is it? 

You can now use the NX Composite Laminates capabilities to create laminates in an LS-DYNA model. 

Laminate physical properties enhancements 

For LS-DYNA models, two new laminate options have been added to the Type list in the Physical 
Property Tables Manager dialog box: 

• The PART (laminate shell) type for shell elements (*ELEMENT_SHELL). 

• The PART (laminate thick shell) type for solid elements (*ELEMENT_TSHELL). 

Select the appropriate option from the Type menu and then click Create to open the Laminate 
Modeler dialog box. 

In the Laminate Modeler dialog box, you can then use the new Keyword Option menu to select 

either the *PART_COMPOSITE or *INTEGRATION_SHELL keywords to define the laminate 

properties. 

• If you select *PART_COMPOSITE, you do not need to create a SECTION_SHELL type of 

modeling object. When you export or solve your model, the software writes the ply data 

(thicknesses, material IDs, and angle) you define in the Laminate Modeler dialog box out as a 

*PART_COMPOSITE keyword. 

• If you select *INTEGRATION_SHELL, you must create a SECTION_SHELL type of 

modeling object. When you export or solve your model, the software converts ply thicknesses 

that you define in the Laminate Modeler dialog box to weighting factors and writes out an 

*INTEGRATION_SHELL keyword. The number of plies is the number of integration points 

through the thickness. When you export or solve your model, the software writes the ply 

orientation angle to the *SECTION_SHELL keyword. For materials: 

– If you select the Use NX Composite Material option, the software does not write out 

any material information when you export or solve your model. This is because LS-

DYNA composite materials are not currently supported in Advanced Simulation. 

– You can use the LSDYNA Composite Material ID box to specify the ID of an LS-

DYNA composite material that exists outside of NX.  

For more information, see the LS-DYNA Keyword User's Manual.  

Inheriting a laminate from a layup 

Currently, when you inherit a laminate from a layup, only the *PART_COMPOSITE option is supported. 
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Inheriting material orientation from a layup 

For shell (2D) elements, you can specify that they inherit their material orientation from the layup. To do 

this: 

• In the Mesh Associated Data dialog box, select Set Material Orientation from the 

Keyword Option list. 

• From the Material Orientation Definition list, select MCID Inherited from Layup. 

• Click OK. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with LS-DYNA as the specified solver 

 

Export support for groups 

What is it? 

If you create groups in your FEM file, you can now export those groups when you export your model to 

an LS-DYNA keyword file. To facilitate this, the software now exports the following LS-DYNA 

keywords: 

• *SET_NODE_LIST 

• *SET_NODE_BEAM 

• *SET_DISCRETE 

• *SET_SHELL_LIST 

• *SET_SOLID 

• *SET_TSHELL 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with LS-DYNA as the specified solver 

Toolbar File→Export→Simulation 
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Thermal and Flow, Electronic Systems Cooling, and Space Systems 
Thermal 

General capabilities 

3D transitional elements 

What is it? 

When you have both a hexahedral mesh and a tetrahedral mesh, you can specify the use of pyramid 

elements as transitional elements from one mesh to the other as shown in the following figures. 

 

Visible tetrahedral mesh 

 

Invisible tetrahedral mesh 

The purple pyramid elements are the transitional elements between the hexahedral mesh in green and the 

tetrahedral mesh in blue. 

 

To specify the use of pyramid elements, you must select the Transition with Pyramid Elements 

option in the 3D Tetrahedral Mesh dialog box. This option is available only when you have a 

hexahedral mesh present next to the solid body which will be meshed with tetrahedral elements and a 

mesh mating condition between the two bodies. 

Why should I use it? 

Use the pyramid elements for the transition between hexahedral and tetrahedral meshes to improve flow 

results for computational fluid dynamics simulations. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 
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Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Advanced Simulation toolbar →3D Tetrahedral Mesh    

Menu Insert → Mesh → 3D Tetrahedral Mesh 

Location in dialog box Mesh Parameters group → Transition with Pyramid 
Elements 

 

Material orientation vector and element thickness for individual elements 

What is it? 

You can use the Element Associated Data command to define a material orientation vector and 

element thickness for individual elements with the following physical properties:  

•  Thin Shell 

• Multi-layer Uniform Shell with orthotropic material 

This allows you to define material orientation and element thickness that vary across different elements. 

In previous releases, you could only specify a uniform set of properties across an entire mesh. 

You can define material orientation property by specifying one of the following: 

• The Coordinate System — The software uses the X-axis of the selected coordinate system as 

the material orientation vector. The X-axis vector is projected onto the plane of the selected 

element to determine the material orientation. 

• The Vector Projection — The software projects the specified vector onto the plane of the 

selected element to determine the material orientation (the vector becomes the X-axis). 
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You must set the corner node thickness to specify the thickness of the element. This shell thickness 

overrides the thickness defined in the mesh. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file that contains elements for which element 

associated data is supported. 

Toolbar 
Element Operations → Element Associated Data    

Menu Edit →Element →Modify Associated Data 
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Report thermal results on both sides of 2D Shell elements 

What is it? 

You can now specify on which side of 2D shell elements you want to calculate thermal results when using 

a Report simulation object of following types: 

• Per Element 

• Per Region 

• Between Regions 

• Heat Maps 

You can ask for results on the following sides of 2D shell elements: 

• Top and Bottom 

• Top 

• Bottom 

For a Between Regions type of Report, you can separately set the side for elements in the primary 

and secondary regions. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object → Report 

Toolbar 
Advanced Simulation toolbar → Report    
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Group import 

What is it? 

When you import NX THERMAL / FLOW, NX SPACE SYSTEMS THERMAL, NX ELECTRONIC 
SYSTEM COOLING, or IDEAS UNV simulations, the software now also imports any groups 

containing elements and nodes. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or SIM with NX THERMAL / FLOW, NX SPACE 
SYSTEMS THERMAL, or NX ELECTRONIC SYSTEM 
COOLING solver 

Menu File → Import  → Simulation 

 

Thermal Coupling simulation objects name change 

What is it? 

Some simulation objects were renamed: 

Old name New name 

Advanced Thermal Coupling Thermal Coupling — Advanced 

Convection Coupling Thermal Coupling — Convection 

Radiation Thermal Coupling Thermal Coupling — Radiation 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

(Thermal Coupling — 
Radiation only) 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal (Thermal Coupling — 
Radiation only) 

Advanced Thermal 

Coupled Thermal-Flow Thermal-Flow (Thermal 
Coupling — Radiation only) 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container and choose New 
Simulation Object 

Toolbar Advanced Simulation toolbar → Simulation Object Type 

   

 

Dialog box text changes 

What is it? 

The following minor text changes were made in this release: 

Dialog box name Group name Old text New text 

Flow Boundary 
Condition 

Flow Direction and 

Flow Return 

Normal to Tangential 
Velocity Angle 

Normal to Resultant 
Velocity Angle 

Particle Injection Parameters Mass per Seconds Mass per Unit Time 

Thermo-Optical 
Properties — 
Advanced 

Infrared Properties, 

Solar Properties, and 

Non Gray Properties 

Transparency Transmissivity 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar Advanced Simulation toolbar → Simulation Object Type 

   

Advanced Simulation toolbar → Modeling Objects    

 

Orthotropic thermal conductivity in cylindrical or spherical coordinates 

What is it? 

You can now specify orthotropic materials with thermal conductivity defined in cylindrical or spherical 

coordinates. In the 2D and 3D Mesh Collector dialog boxes, when you specify an orthotropic material, 

you have the following choices for the Material Orientation Type: 

• Cartesian to specify that the orthotropic conductivity is defined in Cartesian coordinates. 

• Cylindrical to specify that the orthotropic conductivity is defined in cylindrical coordinates. 

• Spherical to specify that the orthotropic conductivity is are defined in spherical coordinates. 

The following table shows the correspondence between the Thermal Conductivity X, Thermal 
Conductivity Y, and Thermal Conductivity Z values you enter in the Materials dialog box and their 

values in all three coordinate systems: 

Material Orientation 
Type 

Thermal Conductivity 
X 

Thermal Conductivity 
Y 

Thermal Conductivity 
Z 

Cartesian kx ky kz 
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Cylindrical kr kθ kz 

Spherical kr kθ kφ 

 

For 2D mesh collectors, when you select Cylindrical or Spherical as the material orientation type, you 

must also specify the Main Conduction Plane and Direction for the heat transfer. The software 

determines the three components of the thermal conductivity as follows: 

• The software projects on the shell element the main direction vector, and the conductivity in that 

direction is the main direction vector's conductivity. 

• The conductivity in the direction of the element normal is the main conduction plane 

conductivity. 

• The third component of the conductivity is the remaining conductivity and its direction is the 

remaining direction to complete the right-hand side coordinate system. 

For example, suppose you want to model temperature distribution on the following cylindrical object with 

orthotropic thermal conductivity using thin shell elements. You drape the cylinder with a material that has 

the thermal conductivity of 0.1 W/m°C in the radial direction on the dark green surfaces and also in the 

angular direction on the cyan surface (Thermal Conductivity X), that has the thermal conductivity of 

10 W/m°C in the axial direction (Thermal Conductivity Y) and 0.0001 W/m°C in the remaining 

direction (Thermal Conductivity Z).  

You need to create two 2D Mesh Collectors with the Cylindrical option for the Material 
Orientation Type list and: 

• For the mesh collector with cyan color, select the R plane, Theta direction option for the 

Main Conduction Plane and Direction list. 

• For the mesh collector with dark green color, select the Theta plane, R direction option for 

the Main Conduction Plane and Direction list. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Flow Flow 

Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM 

Toolbar 
Advanced Simulation → Mesh Collector    

Menu Insert → Mesh Collector 

Location in dialog box Material group 

 

UNV import of axisymmetric thermal models 

What is it? 

You can now import UNV models that contain axisymmetric elements into a thermal model. 

Previously UNV models containing axisymmetric elements were always imported into an axisymmetric 

thermal model. 

When importing UNV models, if axisymmetric elements are detected, the following message appears in 

the Model Information text box of the Import Options dialog box: 

Axisymmetric elements were detected 

The Set Simulation Analysis Type To list has the following options: 

• Coupled Thermal-Flow (appears for Thermal and Flow or Electronic Systems Cooling) 

• Thermal (appears for Space Systems Thermal) 

• Axisymmetric Thermal 
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If you select Coupled Thermal-Flow or Thermal, the software imports axisymmetric elements as 

normal elements and creates: 

•  A generic entity named Converted_Axi_Shells to reference axisymmetric shell elements. 

•  A generic entity named Converted_Axi_Solids to reference axisymmetric solid elements. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Advanced Simulation toolbar →Modeling Objects    

→Advanced Parameters → Create 

Menu Insert → Modeling Objects → Advanced Parameters → 

Create 

 

Thermal capabilities 

Articulation modeling enhancement 

What is it? 

You now have more flexibility when defining time step options for the articulation movement. You can 

select one of the following four options in the Time Step Option list of the Articulation Parameters 

group on the Transient Setup page of the Create Solution or Edit Solution dialog box: 

• At Constant Time Intervals — you control the starting and ending times for the articulation 

as well as the calculation interval. 

• Total Number — you control the starting and ending times for the articulation as well as the 

number of time steps. 

• At Specified Times — you specify the articulation movement times in a list of the 

Articulation Times dialog box by clicking   . 

• Interval versus Time Table — you specify a table containing the desired calculation intervals 

at specified times. For example: 
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Time Interval 

0.0 1.0 

10.0 2.0 

20.0 3.4 

 

The thermal calculation for the articulation movement is performed at following times: 

0.0 1.0 2.0 3.0 4.0 5.0 6.0 7.0 8.0 9.0 10.0 12.0 14.0 16.0 18.0 20.0 

 

The last row of the table indicates the articulation end time; the calculation interval is a dummy 

number. 

In previous releases, the only available time step control option was At Constant Time Intervals. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Advanced Thermal 

Coupled Thermal-Flow Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the solution node and choose Solve 

Toolbar 
Advanced Simulation toolbar → Solve    → Edit Solution 
Attributes 

 

Hemicube method enhancements 

What is it? 

Two enhancements have been made to the algorithm for the view factor calculation using the Hemicube 

method. The algorithm now includes 

• A more robust algorithm that determines the near and far cutting planes for perspective 

projections in rendering-based view factor calculations. 

• A filtering algorithm that addresses situations where numerical noise could create spurious view 

factors, which, even though very small, could cause enclosure leakages. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Element subdivision in Hemicube view factor calculation 

What is it? 

When you use the Hemicube method to calculate view factors, you can now unconditionally enforce the 

use of elemental subdivisions. 

By default, the element subdivision is performed when one of the view factors seen through: 

• The top viewing plane is greater than 0.03. 

• The side viewing plane is greater than 0.3. 

To ensure that the software always performs the element subdivision, you can set the new ENFORCE 
MESH IN HEMIVIEW advanced parameter. 

 Note 

You set the Element Subdivision parameter in one or more of these places: 

• The Radiation Parameters page of the Solver Parameters dialog box 

• The Radiation simulation object 

• The Radiative Element Subdivision simulation object 

 

Why should I use it? 

Use the new parameter if there are any significant deviations of view factor sums from unity. This option 

ensures higher accuracy of view factor results at the expense of increased computation time. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Thermal 

Advanced Thermal 

Coupled Thermal-Flow Thermal-Flow 

Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Advanced Simulation → Modeling Objects    → 

Advanced Parameters → Create 

Menu Insert → Modeling Objects → Advanced Parameters → 

Create 

 

Enhancements to Thermal Coupling — Convection simulation object 

What is it? 

In this version, there are two new enhancements to the Thermal Coupling — Convection simulation 

object: 

• The Coupling Resolution option to control the accuracy of the coupling is now available for 

all three types: 

– Forced Convection Coupling 

– Free Convection Coupling 

– Across Gap Convection Coupling 

Two different approaches are available: One to One resolution and a series of five resolution 

settings ranging from Coarse to Finest. The Coupling Resolution option gives you greater 

control for the convective thermal coupling calculation. 

• For the Free Convection Coupling type, the Secondary Region is renamed Fluid Ducts. 

The convecting fluid is the fluid in the 1D duct network. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal  Advanced Thermal 

Flow  Advanced Flow 

Coupled Thermal-Flow  Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object → Thermal Coupling — Convection 

Toolbar Advanced Simulation toolbar → Thermal Coupling — 

Convection    

 

Enhancement to Radiative Element Subdivision simulation object 

What is it? 

When selecting elements to which to apply the local Radiative Element Subdivision settings, the 

Element Selection Filtering is enhanced. You can now select from the Filter Type list: 

• 1D Elements (previously available) — lets you select only 1D elements. 

• 2D Elements (previously available) — lets you select only 2D elements. 

• Element Edges (new) — lets you select 1D elements and the edges of 2D elements. 

• Element Faces (new) — lets you select 2D elements and the faces of 3D elements. 

You must first set Type Filter on the Selection bar to Element. 

Why should I use it? 

Use these new options to easily select elements to which you want to apply local element subdivision for 

radiation calculations. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal  Advanced Thermal 

Coupled Thermal-Flow  Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object → Radiative Element Subdivision 

Toolbar Advanced Simulation toolbar → Radiative Element 

Subdivision    

 

Coupling Resolution option 

What is it? 

You can control the accuracy of the coupling using the  Coupling Resolution option. 

The Coupling Resolution option is added to the following simulation objects: 

• Electrical Coupling type of Joule Heating 

• Surface to Surface Contact 

• Thermal Coupling — Advanced 

Two different approaches are available: One to One resolution, and a series of five resolution settings 

ranging from Coarse to Finest. 

• With One to One resolution, the solver calculates a single conductance from each primary 

element to the nearest secondary element. Some inaccuracy may be introduced in the exact 

location of the conductance on the larger surface, but the general trend of in-plane conductance is 

maintained. This is adequate for most applications. 

With One to One resolution, you can improve the coupling's accuracy by: 

– Using a finer mesh on the secondary surface than on the primary surface. 

– Matching the meshes on the two surfaces so that there is a one to one correspondence 

between nodes, and so that each primary element shadows only one secondary element. 

The nodes do not have to match perfectly. 
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• With the settings Coarse through Finest, each primary element is divided into a progressively 

larger number of sub-elements. For each sub-element, an area proportional conductance is created 

to the nearest of the secondary elements. Once conductances from each of the sub-elements are 

calculated, they are merged and parallel conductances are combined. The result is area-

proportional couplings which are distributed among the secondary elements based on element 

overlap. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

(Joule Heating and Surface to 
Surface Contact only) 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Thermal Thermal (Surface to Surface 
Contact only) 

Advanced Thermal 

Coupled Thermal-Flow Thermal-Flow (Surface to 
Surface Contact only) 

Advanced Thermal-Flow 

NX Space Systems Thermal Thermal Space Systems Thermal 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object→ Joule Heating, Surface to Surface Contact, or 

Thermal Coupling — Advanced 

Toolbar 
Advanced Simulation toolbar → Joule Heating   , Surface 

to Surface Contact   , or Thermal Coupling — Advanced 

   

Location in dialog box Additional Parameters group 

 

Only Connect Overlapping Elements option 
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What is it? 

You can establish couplings only along a path that is normal to each primary sub-element using the  Only 
Connect Overlapping Elements option. 

The Only Connect Overlapping Elements option is added to the following simulation objects: 

• Electrical Coupling type of Joule Heating 

• Surface to Surface Contact 

Why should I use it? 

The Only Connect Overlapping Elements option can be useful when some primary elements have 

no overlapping secondary elements. 

• When this option is not selected, the software establishes a conductance from each primary sub-

element to the nearest secondary element as shown in (A) below.  

• When you select this option, the software only establishes couplings along a path that is normal to 

each primary sub-element. No conductance is created for primary sub-elements that have no 

overlapping secondary element, as shown in (B) below. 

Primary elements are shown in blue. 

 

 
Only Connect 
Overlapping 
Elements cleared. 

 
Only Connect 
Overlapping 
Elements selected. 

 

 Note 

Secondary elements with no overlapping primary elements are never connected.  

 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling, 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Thermal Thermal (Surface to Surface 
Contact only) 

Advanced Thermal 

Coupled Thermal-Flow Thermal-Flow (Surface to 
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Surface Contact only) 

Advanced Thermal-Flow 

NX Space Systems Thermal Thermal Space Systems Thermal 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object → Joule Heating or Surface to Surface Contact 

Toolbar 
Advanced Simulation toolbar → Joule Heating    or 

Surface to Surface Contact    

Location in dialog box Additional Parameters group 

 

Duct modeling capabilities 

Duct Opening enhancement 

What is it? 

When you specify external conditions for a Duct Opening type of the Duct Flow Boundary 
Conditions simulation object, you can now specify only the pressure of the fluid or you can also specify 

the temperature of the fluid. In previous versions, you needed to specify both the pressure and the 

temperature at the same time. 

A Temperature check box now appears when you select Specify from the External Conditions list. 

• By selecting the Temperature check box, you specify the Temperature Value at the duct 

opening. 

• By clearing the Temperature check box, the temperature of the fluid at the duct opening is the 

Fluid Temperature value defined in the Ambient Conditions page of the Create Solution or 

the Edit Solution dialog box. 

In both cases, you must specify the Total Pressure — Gauge value for the pressure of the fluid at the 

duct opening. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Advanced Thermal/Flow with 

ESC 

NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Advanced Thermal 
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Flow Advanced Flow 

Coupled Thermal-Flow Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container → New Simulation 
Object →  Duct Flow Boundary Conditions 

Toolbar Advanced Simulation toolbar → Duct Flow Boundary 

Conditions    

 

New results on duct elements 

What is it? 

On duct elements, in addition to the existing results, you can now recover: 

• Density 

• Mass flow 

To recover these results from the analysis, select Densities or Mass Flows in the Duct Flow group of 

the Results Options page of the Create Solution or Edit Solution dialog boxes. 

After solving, in the Post Processing Navigator, a Fluid Density — Elemental and/or Mass 
Flow — Elemental result type appears under the Solution results node as seen in the following graphic. 

  Solution 1NX THERMAL / FLOW, Thermal, Advanced Thermal 

  'Temperature - 'Nodal 

  'Temperature - 'Elemental 

  'Total Heat Load - 'Elemental 

  'Total Heat Flux - 'Elemental 

  'Fluid Density - 'Elemental 

  Scalar 

  'Mass Flow - 'Elemental 

  Scalar 

 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Advanced Thermal/Flow with 

ESC 
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NX Space Systems Thermal Thermal Space Systems Thermal 

NX Thermal and Flow Thermal Advanced Thermal 

Flow Advanced Flow 

Coupled Thermal-Flow Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the solution node and choose Edit Solution 

Toolbar 
Advanced Simulation toolbar → Solve    → Edit Solution 
Attributes 

Menu Analysis → Solve → Edit Solver Attributes 

Location in dialog box Duct Flow group on the Results Options page 

 

Flow capabilities 

Export flow model and boundary conditions to CGNS 

What is it? 

You can export nodes, elements, and the following boundary condition data in the CFD General Notation 

System (CGNS) format: 

• Temperature 

• Inlet information: velocity, mass flow, volume flow, or pressure rise 

• Outlet information: velocity, mass flow, volume flow, or pressure rise 

• Opening information: pressure 

For the element on free faces where you apply boundary conditions, the software creates boundary 

elements with a normal pointing into the fluid. Any pyramid elements are converted to wedge elements. 

CGNS export does not support table data. For temperature, velocity, mass flow, volume flow, or pressure 

varying in time, the software exports the boundary condition into the CGNS format with a value equal to 

0. The software does not export any boundary condition values that are defined with NX spatial fields. 

CGNS is a standard format for recording computational fluid dynamics (CFD) analysis data. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow  Advanced Flow 

Coupled Thermal-Flow  Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Menu File → Export → Simulation 

Location in dialog box File Type list → CGNS 

 

Relaxation factor for turbulence equations 

What is it? 

You can now specify the Turbulence relaxation factor in the Relaxation Factors group on the 3D 

Flow Solver page of the Solver Parameters dialog box. 

The solver applies this relaxation parameter to the turbulence equations when you set one of the following 

two-equation models in the Turbulence Models option on the Solution Details page of the Create 
Solution or Edit Solution dialog boxes: 

• K-Epsilon 

• Shear Stress Transport-SST 

• K-Omega 

The value that you set for the turbulence relaxation factor should always be positive and less than or equal 

to 1. 

Reducing this value slows down the convergence rate and should be used when convergence cannot be 

achieved otherwise. 

Why should I use it? 

This feature is particularly useful when divergence occurs early in the iterative process soon after the 

turbulence equations become active. The main purpose of this relaxation factor is to prevent wrong values 

of k or ε or ω in or near the boundary layer from affecting the other variable. 
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Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow Flow 

 Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the Solution node → Solver Parameters 

Toolbar 
Advanced Simulation → Solve    → Edit Solver 
Parameters 

Menu Analysis → Solve → Edit Solver Parameters 

Location in dialog box Relaxation Factors group on the 3D Flow Solver page 

 

Spectral attenuation report 

What is it? 

When you solve a flow or coupled transient analysis, you can now request the creation of spectral 

attenuation graphs. 

The spectral attenuation, SA, is a function of frequency, f, and is given by this equation: 

 

Where: 

  Pem(f) is the complex number of the fast Fourier transform of the emitted pressure at frequency f. 

  Pre(f) is the complex number of the fast Fourier transform of the received pressure at frequency f. 

  P
*
re(f) is the complex conjugate of Pre(f). 
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In the Between Regions type of Report simulation object, select: 

• The region that has the emitted signal as your Primary Region. 

• The region that has the received signal as your Secondary Region. 

• The Spectral Attenuation check box. 

 Note 

To create a spectral attenuation report, you must select constant time steps, because the software 

calculates the discrete frequencies using the time step value it assumes to be constant. To select 

constant time steps, select Constant from the Time Step Option list on the Transient Setup 

page of the Create Solution or Edit Solution dialog boxes to let the software calculate the 

discrete frequencies. 

 

After the solve, the software saves the following graphs in the run directory: 

• The emitted and received pressures as functions of time in flowsppsig.png. 

• The fast Fourier transform of the emitted and received pressures as functions of frequency in 

flowsppspec.png. 

• The spectral attenuation as a function of frequency in flowspatt.png. 
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The above data is also saved into the GroupReport.htm and GroupReport.csv files. 

Why should I use it? 

You should request the creation of the spectral attenuation report when you want to simulate noise 

reduction or acoustic wave propagation. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow Flow 

 Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the Simulation Object container → New Simulation 
Object → Report 

Toolbar 
Advanced Simulation → Report    

Location in dialog box 3D Flow Data group 

 

Periodic fluid domain mesh 

What is it? 

You can now create periodic fluid domain meshes when applying periodic boundary conditions. 

To create a periodic fluid domain mesh, you need to: 

1. Create a 3D periodic model. 

2. Create a Fluid Domain simulation object. 

3. Create a Periodic Boundary Condition simulation object. 

4. Create meshMatching.dat file in the same folder as the Simulation file with the following format: 

###############################################################################

############ 

# This file should be used to define periodic boundary conditions to the 

mesher.  
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# The format is as follow: 

# 

# Periodicity LBC NAME 

# Trans_x Trans_y Trans_z Axis_x Axis_y Axis_z Center_x Center_y Center_z Theta 

# 

# Where: 

# 

# Trans Translation 

# Axis Axis of rotation 

# Center Center of rotation 

# theta Angle of rotation (degrees)  

# 

###############################################################################

############ 

Periodic Boundary Condition(1) 

0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 

Periodic Boundary Condition(2) 

0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 

Periodic Boundary Condition(3) 

0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0  

The software generates the periodic fluid domain mesh when you solve the model. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow Flow 

 Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the Simulation Object container → New Simulation 
Object → Fluid Domain 

Toolbar 
Advanced Simulation → Fluid Domain    

 

Bivariate fluid properties 
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What is it? 

You can have the following fluid properties varying with both temperature and pressure: 

• Density 

• Specific heats at constant pressure 

• Specific heats at constant volume 

• Dynamic viscosity 

• Conductivity 

• Thermal expansion coefficient 

Use a Generic Entity modeling object to specify bivariate fluid properties. For complete instruction on 

how to specify bivariate fluid properties, see Define a bivariate fluid material property. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow Flow 

 Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Advanced Simulation toolbar → Modeling Object    → 

Generic Entity → Create 

Menu Insert → Modeling Objects → Generic Entity → Create 

 

Convection Properties option 

What is it? 

The behavior of the Convection Properties option has changed. You can now define convection 

properties even when you select the Slip Wall check box in the following dialog boxes: 
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• Flow Surface 

• Flow Blockage 

• Create / Edit Solution 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 

NX Thermal and Flow Flow Flow 

 Advanced Flow 

Coupled Thermal-Flow Thermal-Flow 

 Advanced Thermal-Flow 

 

Where do I find it? 

Simulation objects 

Application Advanced Simulation 

Simulation Navigator Right-click the simulation object container →New Simulation 
Object → Flow Surface / Flow Blockage 

Toolbar 
Advanced Simulation toolbar → Flow Surface    / Flow 

Blockage    

Location in dialog box Flow Surface dialog box → Convection Properties 

Flow Blockage dialog box → Solid Blockage type → 

Convection Properties 

 

Create or edit simulation 

Application Advanced Simulation 

Simulation Navigator 
• Right-click the simulation → New Solution 

• Right-click the solution → Edit Solution 

Location in dialog box 3D Flow page → Default Convection Properties 
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Redlich-Kwong Real Gas Equation of State 

What is it? 

You can now model gases using the Redlich-Kwong Real Gas Equation of State: 

 

where 

• P is the pressure of the gas. 

• T is the temperature of the gas. 

• Vm is the molar volume of the gas. 

• R is the universal gas constant (8.314472 J/(mol·K)). 

The constants a and b are defined as: 

 

 

where 

• PC is the critical pressure of the gas. 

• TC is the critical temperature of the gas. 

You use an Advanced Parameters modeling object to specify the Redlich-Kwong real gas equation of 

state. For complete instructions on how to specify the Redlich-Kwong equation, see Define a gas using 

the Redlich-Kwong equation of state. 

Why should I use it? 

Use the Redlich-Kwong Real Gas Equation of State at high pressure as it is more realistic than the ideal 

gas law. 

The Redlich-Kwong equation should be used when the ratio of the pressure to the critical pressure is less 

than about one-half of the ratio of the temperature to the critical temperature: 

 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Coupled Thermal-Flow Electronic Systems Cooling 

Advanced Thermal/Flow with 

ESC 
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NX Thermal and Flow Flow  Advanced Flow 

Coupled Thermal-Flow  Advanced Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Advanced Simulation toolbar →Modeling Objects    

→Advanced Parameters → Create 

Menu Insert → Modeling Objects → Advanced Parameters → 

Create 

 

Mapping capabilities 

Automatic detection of mapping source analysis type 

What is it? 

In the Create Solution dialog box with the Solver list set to NX THERMAL / FLOW or NX 
ELECTRONIC SYSTEMS COOLING, when you select the Mapping from the Analysis Type list, 

the source model analysis type is detected automatically from the BUN file associated with the source 

analysis. 

In the Mapping Details page of the Create Solution or Edit Solution dialog boxes, the Source 
Model Analysis Type field is now non-editable. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Mapping Thermal-Flow 

NX Thermal and Flow Mapping Thermal-Flow 

 

Where do I find it? 

Application Advanced Simulation 

Simulation Navigator Right-click the solution node and choose Edit Solution 

Toolbar 
Advanced Simulation toolbar → Solve    → Edit Solution 
Attributes 

Menu Analysis → Solve → Edit Solver Attributes 

Location in dialog box Data Source and Destination group on the Mapping Details page 
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Automatic creation of mapping solutions 

What is it? 

All Mapping and Axisymmetric Mapping solutions in NX THERMAL / FLOW, NX SPACE 
SYSTEMS THERMAL, and NX ELECTRONIC SYSTEMS COOLING solvers allow you to 

automatically create a complete NX solution with all the appropriate steps, subcases, and loads defined 

for the Nastran, ANSYS, and Abaqus solvers. 

To create complete NX solutions, in the Optional Output page of the Create Solution or Edit 
Solution dialog box, select the Create Nastran Solution, Create Ansys Solution, or Create 
Abaqus Solution check box. 

The mapping solver creates the following NX solutions: 

• SESTATIC 101 — Single Constraint for NX Nastran only 

• Linear Statics for ANSYS 

• General Analysis for Abaqus 

When the Analysis Type is Mapping, the loads the mapping solver creates depends upon the Source 
Model Analysis Type and the setting of the Data to Map option (Mapping Details page of the 

Create Solution and Edit Solution dialog boxes). 

• When the Source Model Analysis Type is Thermal or Coupled and  Data to Map is set to 

Solid Temperatures, the software creates structural Node ID Table Temperature loads. 

• When the Source Model Analysis Type is Flow or Coupled and  Data to Map is set to 

Flow Values, the software creates structural  Node ID Table Force loads. 

When the Analysis Type is Axisymmetric Mapping, the software creates structural Node ID Table 
Temperature loads. 

You can create more than one solution at the same time, such as one for both Nastran and ANSYS. In that 

case, the mapping solver creates one set of loads that are shared between the solutions. 

Why should I use it? 

The automatic creation of mapping solutions for Nastran, ANSYS, and Abaqus simplifies the mapping of 

transient solutions. 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Mapping Thermal-Flow 

NX Space Systems Thermal Mapping Thermal 

NX Thermal and Flow Mapping Thermal-Flow 

Axisymmetric Mapping Thermal 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite Two FEM with models that are geometrically congruent 

Simulation Navigator Right-click the simulation file node → New Solution 

Toolbar 
Advanced Simulation toolbar → Solution    

Menu Insert → Solution 

Location in dialog box Analysis Type  → Mapping or Axisymmetric Mapping 

 

Mapping's element support 

What is it? 

The mapping solver now supports all elements which support temperature and pressure data for the 

following solvers: 

• Nastran 

• ANSYS 

• Abaqus 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Mapping Thermal-Flow 

NX Space Systems Thermal Mapping Thermal 

NX Thermal and Flow Mapping Thermal-Flow 

Axisymmetric Mapping Thermal 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite Two FEM with models that are geometrically congruent 

Simulation Navigator Right-click the simulation file node → New Solution 

Toolbar 
Advanced Simulation toolbar → Solution    

Menu Insert → Solution 

Location in dialog box Analysis Type  → Mapping or Axisymmetric Mapping 
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Axisymmetric to 3D temperature mapping 

What is it? 

You can now map temperature data from an axisymmetric model to a 3D model. 

The following graphic shows: 

• On the left, the temperature on 1D elements that model thermal analysis on an axisymmetric pipe. 

• On the right, the same temperatures mapped on the shell elements of a full pipe. 

 

Supported solvers and analysis types 

Solver Analysis Type Solution Type 

NX Electronic Systems Cooling Mapping Thermal-Flow 

NX Space Systems Thermal Mapping Thermal 

NX Thermal and Flow Mapping Thermal-Flow 

Axisymmetric Mapping Thermal 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite Two FEM with models that are geometrically congruent 
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Simulation Navigator Right-click the simulation file node → New Solution 

Toolbar 
Advanced Simulation toolbar → Solution    

Menu Insert → Solution 

Location in dialog box Analysis Type  → Mapping or Axisymmetric Mapping 

 

Laminate Composites 

Smart selection in draping 

What is it? 

Smart selection methods are now available in draping. Smart selection methods enable you to select 

entities according to specified criteria or entity relations. 

Smart selection methods are available from the following dialog boxes: 

• Ply draping data 

• Layup Offset 

• Laminate Default Orientation 

When selecting entities, you can use the Method list on the Selection bar to select related entities. 

 

The Selection Bar, showing (1) the Type Filter list, (2) the Method list, and (3) the Smart Selector 

Options button 

Why should I use it? 

Smart selection is most useful when working with complex geometry or meshes containing a large 

number of nodes and elements. If you use smart selection when selecting nodes, for example, you can 

easily select a large number of related nodes, either by their underlying polygon geometry features or by 

element tangency or feature angle. When working with models with complex geometry, you can use 

smart selection to quickly select all fillet faces, cylindrical faces, or sliver faces, as well as tangent or 

adjacent faces.  

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with one or more ply-based laminate layups 

defined 

Simulation Navigator 
• Right-click the ply node → Edit 

• Right-click the Layup Offset node → Create a new user 
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defined layup offset rule 

• Right-click the Material Orientation node → Create New 
Orientation 

 

Update icon in Simulation Navigator 

What is it? 

A red update icon    now appears in the Simulation Navigator when either the layup or the ply needs 

to be updated. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with one or more ply-based laminate layups 

defined 

 

Draping solver feedback 

What is it? 

When you update layups or plies for draping, the Information window opens, and as necessary, displays 

the following warning messages: 

• WARNING — Bad continuity detected for ply X. Draping results could be wrong. 

Check element normals, slope continuity and mesh density. 

In the graphics window, the regions with bad continuity between elements are highlighted. 

Element edges and the element normal are shown in yellow. 

 

• WARNING — Flat Pattern of plyX tears or overlaps Y times. 

In the graphics window, the regions where elements tear or overlap are highlighted. Element 

edges are shown in red. 

• WARNING — Flat Pattern of plyX might tear or overlap Y times. 

In the graphics window, the regions where elements might tear or overlap are highlighted. 

Element edges are shown in magenta. 



whatsnew7 0   What's New in NX 7    219 

 

 

The last two warnings are issued when the algorithm detects stretching in fibers, which could indicate that 

the ply cannot conform to the undevelopable faces. In practice, the ply would exhibit gapping or 

wrinkling on the mold. 

Use one of the following remedial actions to improve the draping process: 

• Use a different start point and draping direction. 

• Add a splice in the ply. 

• Introduce cut curves. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with one or more ply-based laminate layups 

defined 

 

List draping results 

What is it? 

You can now export draping information for a given ply to a spreadsheet application or a comma 

separated values (CSV) file using the List Draping Results dialog box. 

For a given ply, the created report contains the draping solver that was used, the starting and lock angles, 

and the number of elements. 

For each element, the report contains: 

• Element ID 

• Shear angle 

• Yarn angle 

• Primary direction 

• Secondary direction 

• Normal direction 

Why should I use it? 

Use this functionality when you want to evaluate the validity of your draping. This is mainly a debugging 

tool. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM file with one or more ply-based laminate layups 

defined 

Simulation Navigator Right-click the ply node → List Draping Results 

 

Envelope results for each element 

What is it? 

When you use the Graphical Post Report command, you can now view the worst ply value at each 

element for: 

• Ply Failure Index 

• Bond Failure Index 

• Ply Stress 

• Ply Strain 

• Ply Safety Margin 

• Bond Safety Margin 

The new ply envelope nodes in the Post Processing Navigator have the same name as existing ply 

envelope nodes. In the existing nodes, you can view the values for each ply separately. In the new nodes, 

you can view the value from the ply with the worst result at each element. 

In the following figure, the new ply envelope nodes are followed by    and the existing ones by   . 

   Laminate Post Report 1 

   Ply Failure Index — Elemental    

   Ply Failure Index Bottom — Elemental 

   Ply Failure Index Top — Elemental 

   Ply Failure Index — Elemental    

   Bond Failure Index — Elemental    

   Bond Failure Index Bottom — Elemental 

   Bond Failure Index Top — Elemental 

   Bond Failure Index — Elemental    

   Ply Stress — Elemental    

   Ply Stress Bottom — Elemental 

   Ply Stress Top — Elemental 
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   Ply Stress — Elemental    

    Ply Strain — Elemental    

    Ply Strain Bottom — Elemental 

    Ply Strain Top — Elemental 

    Ply Strain — Elemental    

   Ply Safety Margin — Elemental    

   Ply Safety Margin Bottom — Elemental 

   Ply Safety Margin Top — Elemental 

   Ply Safety Margin — Elemental   

   Bond Safety Margin — Elemental    

   Bond Safety Margin Bottom — Elemental 

   Bond Safety Margin Top — Elemental 

   Bond Safety Margin — Elemental    

 

Why should I use it? 

The new ply envelope nodes allow you to assess the worst ply results without having to manually scan 

through all the ply results. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite A Simulation file with a laminate model in Nastran, ANSYS, or 

Abaqus solution 

Toolbar 
Laminate → Graphical Post Report    

Menu Insert → Laminate → Graphical Post Report 

Location in Post Processing 
Navigator 

Under the Laminate Post Report node 

 

FE Model Correlation 

What is it? 

FE Model Correlation is a new Advanced Simulation process which you can use to quantify and visualize 

the level of agreement between two sets of modal results by comparing mode shapes and nodal responses. 
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FE Model Correlation can correlate modal results between structural finite element analysis and 

experimental test modal analysis results (test-analysis) or between two sets of structural finite element 

analysis results (analysis-analysis). 

 

7th mode shape of the reference solution 

 

13th mode shape of the work solution 

 

You prepare the finite element model for structural analysis by defining the mesh and material properties. 

Then, you solve the following modal analysis solutions: 

•  NX or MSC Nastran: SEMODES 103 

• ANSYS: Modal  

• ABAQUS: Frequency Perturbation Substep  

With FE Model Correlation, you create a solution with the new solver environment, MODAL TEST 
DATA, and the new solution type, Test Solution. You then import the experimental modal results and 

the test model from NX I-deas Universal (UNV) files into that solution. The test model is disjoint from 

the finite element model. 

FE Model Correlation allows you to: 

• Setup the correlation process. 

• Align test solution with the analysis solution. 

• Pair the test modes with the analysis modes. 

• Obtain correlation metrics. 

Why should I use it? 

FE Model Correlation objectively compares mode shapes and nodal responses to assess the level of 

agreement between experiments and FE results in structural dynamics. 
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Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation file with modal analysis solution 

Menu Insert→Correlation 

 

Import and export 

Import changes for related elements that share a physical property table 

What is it? 

When you import related elements (an element type and its transitional element) that share the same 

physical property table, the software now places them in the same mesh in the Simulation Navigator. 

In previous releases, the software automatically created a separate mesh in the Simulation Navigator 

for every combination of physical property and element type. 

For example, consider the following Nastran .dat file: 

GRID,1,,0.,0.,0. 

GRID,2,,1.,0.,0. 

GRID,3,,1.,1.,0. 

GRID,4,,0.,1.,0. 

CQUAD4,1,1,1,2,3,4 

CTRIA3,2,1,1,2,3 

PSHELL,1,1,.1 

MAT1,1,1.E10,.3 

ENDDATA 

Notice that both the CQUAD4 and CTRIA3 elements reference the same PSHELL bulk data entry. 

Previously, if you imported this file into Advanced Simulation, the software created the following 

structure for the mesh data in the Simulation Navigator: 

   2D Collectors 

   PSHELL_1 

   CQUAD4_1 

   CQUAD3_2 

 

Now, the software combines the CQUAD4 and CTRIA3 elements into the same mesh: 

   2D Collectors 

   PSHELL_1 

   CQUAD4_1 
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Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Simulation 

 

Option to import nodal temperatures as a node ID table 

What is it? 

For Nastran, Abaqus, and ANSYS models, the Import Selective Loads as Field Data customer 

default from previous releases now also controls whether nodal temperatures are imported as node ID 

tables. Whether you import nodal temperatures as loads or as initial conditions, if you select Import 
Selective Loads as Field Data, the software combines all nodal temperature boundary conditions into 

a single node ID table in the Simulation Navigator.  

Previously, the Import Selective Loads as Field Data option only applied to forces and moments. 

Each imported nodal temperature boundary condition was displayed separately. This remains the default 

behavior. 

Why should I use it? 

When you import models with many nodal temperature boundary conditions, the Import Selective 
Loads as Field Data option improves performance and usability. The default method may result in 

slower import processing and require a large amount of scrolling to view all the boundary conditions in 

the Simulation Navigator. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with NX Nastran, MSC Nastran, Abaqus, or 

ANSYS as the specified solver 

Menu File→Utilities→Customer Defaults 

Location in dialog box Simulation→General→Environment tab 

 

Ability to export a subset of your model 

What is it? 

For Nastran, ANSYS, and Abaqus solutions, use the options in the new Subset Export group in the 

Export Simulation dialog box to selectively export portions of your model. You can use these options 

to export: 

• Only the elements currently displayed in your model. 

• Entities in selected groups. 
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Subset export based on the elements currently displayed 

Use the new Visible elements option to export only the elements that are currently displayed in your 

model. This option replaces the Visible meshes option from previous releases. With the Visible 
meshes option, even if only a single element in a mesh was displayed, the software exported all the 

elements in that mesh. 

Subset export based on selected groups 

Use the new Selected groups option to export only the contents of a selected group. If you select 

multiple groups, the software exports all the entities in those groups as well as: 

• Any loads and boundary conditions associated with the nodes and elements in the group. 

• All nodes associated with the elements in that group, even if the nodes themselves are not 

members of the group. 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active FEM or Simulation file in which Nastran, ANSYS, or 

Abaqus is the specified solver 

Menu File→Export→Simulation 

 

NX Open 

Enhanced NX Open support in CAE 

What is it? 

Several JA-based NX Open APIs are now available that let you automate Advanced Simulation 

operations. The following new functions have been added: 

NX Open class New function added 

BaseFEModel Provides access to the Update Finite Element 
Model command. 

SimSolution Provides access to solve a solution or write a solver 

input file. 

SimSolution Provides access to complete edit capability for 

SimSolution properties as well as Solver 

Parameters. 

NodeElementManage Creates a NodesRepositionBuilder object that 

lets you efficiently reposition large numbers of 

nodes. 
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For details about each new function, see the NX Open Reference Guide for the language you are using 

(for example, the NX Open C++ Reference Guide). You can find the NX Open reference guides in the 

NX Help Library under Automation→NX Open. 

NX Open support for reading and displaying solver results 

What is it? 

Using the NX Open interface, you can now write custom automation code for reading and displaying 

solver results in Advanced Simulation. 

Several new NX Open classes have been added to the CAE NameSpace.  

• ResultManager 

• IResult  

• ImportedResult 

• ResultAccess  

• ResultParameters  

• SolutionResult  

Use these general steps for working with these new classes: 

1. Create a Result object from a solution or by opening a result file. 

2. Create a ResultAccess object by providing a Result object and a ResultParameters object.  

ResultAccess holds a state that can be modified using a ResultParameters object. 

ResultParameters is a container of result properties that can be queried, modified, and set to a 

ResultAccess object. 

3. Query file data from the Result object such as number of nodes, elements, load cases, and so on.   

4. Access state data from the ResultAccess object such as minimum and maximum results values, 

min-max locations, and so on.  

For details about each new class, see the NX Open Reference Guide for the language you are using (for 

example, the NX Open C++ Reference Guide). You can find the NX Open reference guides in the NX 

Help Library under Automation→NX Open. 

NX Open support for manual creation of all 3D solid element types 

What is it? 

You can use the new ElemDimTypeAnySolid option in the CAE::ElementCreateBuilder NX Open 

class to create a 3D element of any solid topology supported by your solver. In previous versions, you 

could create only Penta(6) and Hexa(8) elements.  

For details about the new option, see the NX Open Reference Guide for the language you are using (for 

example, the NX Open C++ Reference Guide). You can find the NX Open reference guides in the NX 

Help Library under Automation→NX Open. 



whatsnew7 0   What's New in NX 7    227 

 

Post Processing 

Unaveraged results across feature angle boundaries 

What is it? 

When you analyze elemental or element-nodal results in post-processing and you use the Averaged 

results option, you can now choose not to average the results across nodes at feature angle boundaries in 

your model.  

In the Smooth Plot dialog box, the Averaged option calculates a nodal average across all adjacent 

elements for elemental and element-nodal results. For this release, a new Feature Angles option has 

been added to the averaged-across options.  

When the Feature Angles check box is not selected, the software leaves the results unaveraged across 

feature angles greater than the angle threshold you specify. For example, if you do not want the results 

averaged across feature angles of 45 degrees or greater, enter 45 in the angle threshold box. 

The angle is measured at the free element faces, as shown in the following example.  

 

 Note 

The Include Internal Elements option is unavailable when the Feature Angles check box is 

not selected.  

 

Example 

The following examples illustrate how the stress results remain unaveraged past the hole and slot features 

in this disk part. 
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Stress averaged across feature angles (default setting; Feature Angles check box selected) 

 

Stress unaveraged across feature angles greater than 45 degrees (Feature Angles check box not 

selected) 

About the Identify command 

You use the    Identify command to probe and display nodal information for the post view display. 

When you use the Identify command and the Feature Angles check box is not selected, you may see 
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multiple values on a single node, depending on the number of faces that share this node and the face you 

position the mouse over. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite Simulation file with elemental or element-nodal results. The Include 
Internal Elements option must be turned off. 

Toolbar 
Post Processing→Post View    

Location in dialog box Result (Color Display)→Averaged→Feature Angles 

 

Expanded results support in Post-Processing 

What is it? 

You can now display and analyze results in post-processing for several additional result types and 

element types.  

NX Nastran results 

• Contact gap distance 

• Shell element thickness 

• Gasket Pressure  

• Gasket Closure  

• Plastic Gasket Closure  

• Gasket Status  
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• Gasket Yield Stress  

• 2D axisymmetric contact results  

NX Nastran elements 

• Pyramid elements: CPYRAM 

• Axisymmetric solid elements: CTRAX3, CQUADX4, CTRAX6, and CQUADX8  

NX Response Simulation results 

These Response Simulation contour results types are now supported correctly. In previous versions, all 

possible component results were displayed in the Simulation Navigator even if you had not requested 

certain components. 

• Peak 

• RMS  

• Level Crossing  

NX Laminates results 

• Ply Failure Indices (ANSYS support added) 

• Ply Strength Ratio  

• Bond Strength Ratio  

NX Flow results 

Fluid density is now supported. 

Context highlighting in Post-Processing Navigator 

What is it? 

The active results set that is plotted in the graphics window now displays in blue in the Post-
Processing Navigator.  
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Von Mises stress result plotted in graphics window and displayed in blue in Post-Processing 

Navigator 

If more than one results set is displayed, the Master post view is shown in blue in the navigator. 

Why should I use it? 

When you plot several results sets, the blue color in the Post-Processing Navigator can help you 

distinguish which set is displayed in the graphics window. 

Restarting streamlines at the interface of a disjoint mesh 

What is it? 

If your model contains adjacent fluid meshes that share a common boundary, you can use the Connect 
Disjoint Fluid Mesh option in the Create Solution or Edit Solution dialog box to have the flow 

solver join them during the analysis. If you then create a streamline display of your velocity results for 

that model, you can use the new Attempt Restart in Disjoint Mesh option in the Extraction 
Parameters group of the Seed Set dialog box to control whether the streamline is continuous across 

the interface between the meshes. If you select Attempt Restart in Disjoint Mesh, the software 

creates a continuous streamline across the discontinuous meshes. However, restarting streamlines across 

discontinuous meshes can negatively impact the display performance. You should use caution when 

selecting this option. 
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 Note 

In the Seed Set dialog box, you must select the Attempt Restart in Disjoint Mesh option 

before you select any seed points.   

 

The following graphic shows an example of a streamlines display created on a model that contains a 

disjoint fluid mesh. (A) shows the streamline display with the Attempt Restart in Disjoint Mesh 

cleared, while (B) shows the streamline display with the Attempt Restart in Disjoint Mesh selected. 

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite A solved model with a disjoint fluid mesh, velocity results, and a 

displayed post view 

Post-Processing Navigator Right-click a post view→Create Streamlines 

 

New results display options 

What is it? 

Now, when you create a contour plot, marker plot, or streamline display of your results, new options in 

the Select Results dialog box give you greater control over how the software generates the display.   

Option for averaging results for internal elements 

If you select the Averaged option, you can use the new Include Internal Elements option to control 

whether the software includes the results for internal 3D elements in the averaging calculations. If you 

clear the Include Internal Elements check box, the software only includes elements that have faces on 

the model's surface in averaging calculations.    

The following graphic shows contour plots of elemental stress-nodal results generated with the Include 
Internal Elements check box selected (A) and with the Include Internal Elements check box 

cleared (B).  
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Option for controlling the display of results at midside nodes 

When your mesh includes parabolic elements, use the new Include Midnodes option to control whether 

the software displays results at the midside nodes.    

The following graphic shows contour plots of elemental stress-nodal results generated with the Include 
Midnodes check box selected (A) and with the Include Midnodes check box cleared (B). The 

differences between the displays are very subtle for this model. 



234    What's New in NX 7   whatsnew7 0  

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite A solved model with results and a displayed post view 

Menu Tools→Results→Post View 

Post-Processing Navigator Right-click a post view→Edit 

 

Nastran 

Support for displaying Nastran strain curvature results 

What is it? 

In a Nastran analysis, when you include a Strain type of Structural Output Request with the 

STRCUR option from the Plate Curvature list selected, you can now display those results in post-

processing. In previous releases, although you could request the output of strain curvature results, you 

could not display them.     

Supported strain resultant components for 1D elements 

In the Post-Processing Navigator, you can now create displays of the following strain resultant 

components for 1D elements:    
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• Axial Strain Exx 

• Strain Curvature KXZ and KYZ  

• Twist 

• Shear Strain TXZ and TYZ 

Supported strain resultant components for 2D elements 

In the Post-Processing Navigator, you can now create displays of the following strain resultant 

components for 2D elements:    

• Membrane Strain EXX, EYY, and EXY 

• Strain Curvature KXX, KYY, and KXY 

• Shear Strain TXZ and TYZ 

Where do I find it? 

Application Advanced Simulation 

Prerequisite A solved Nastran model with strain results  

Toolbar 
Post Processing→Post View    

Menu Tools→Results→Post View 

Post-Processing Navigator Right-click the appropriate strain results→Apply 

 

Abaqus 

Ability to animate across load cases 

What is it? 

For solutions that include multiple load cases, you can now animate the results across the load cases. The 

Animation dialog box includes two options: Result and Iterations. The Iterations option lets you 

specify a Start Load Case, Start Iteration (if the starting load case contains iterations), and End 
Load Case, as well as a Step increment to determine the number of frames in the animation.  

For example, suppose you have three load cases (1, 2, and 3 in the picture below) and you want the 

animation to start at the first load case and end after the last load case. 
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In this example, you would choose Load Case 1 as the Start Load Case and Load Case 3 as the 

End Load Case. The following animated picture shows the result. The first and last load cases each 

have one static step and the second load case has 10 iterations. The Step option is set to 1, which means 

the animation includes a frame for each step and iteration between the start and end load case. Therefore, 

the animation contains 12 frames. Note the load case and iteration number indicated by the arrow in the 

picture. 
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 Note 

In this example, all iterations in Load Case 2 were included automatically because it was not the 

starting or ending load case. You can specify a Start Iteration only if the load case that contains 

iterations is specified as either the Start Load Case or the End Load Case.  

 

Where do I find it? 

Application Advanced Simulation 

Prerequisite An active Simulation with Abaqus as the specified solver 

Toolbar 
Post-Processing→Animation    

 

Teamcenter Integration 

Part attributes supported for FEM and Simulation files 

What is it? 

You can now assign Part Name and Part Description attributes to FEM and Simulation files in 

Advanced Simulation (in addition to Part Number, Part Revision, Part Type, and Part Unit of 
Measure attributes).  

When you create a new FEM or Simulation file, you can now click the Attributes button, which opens 

the Define Attributes dialog box. There you can define the Part Name and Part Description 

attributes. You can also assign these attributes by selecting Format→Database Attributes to open the 

Database Attributes dialog box.  
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After initially defining these attributes, you can make changes to them until you save the part.  

Where do I find it? 

Application Advanced Simulation 

Toolbar 
Standard→New   →Simulation tab→Attributes 

Menu File→New→Simulation tab→Attributes 

Format→Database Attributes 

Simulation Navigator Right-click the part file→New FEM→Attributes 

Right-click the FEM file→New Simulation→Attributes 

 

Teamcenter file browser used when importing simulation results files 

What is it? 

You can now import results files associated with Simulation files managed in Teamcenter. In the 

Simulation Navigator, you can now right-click the Simulation file node and choose from two import 

options:  

• Import Local Results — Lets you select a solver results file to import using the native 

operating system file browser. 

• Import Results file from Teamcenter — Lets you select a solver results file to import using 

the Import Results File from Teamcenter dialog box. You can browse your Teamcenter 

database and select a Simulation file. The dialog box provides a view of each file's Teamcenter 

attributes, such as Number, Revision, Description, and so on. Results files stored with that 

Simulation file are displayed in the Choose result file to import list. 

Also, in Advanced Simulation dialog boxes in which you select a simulation results file to import, the file 

system browser that appears is now the Teamcenter file browser.  

For example, you can run a thermal solution to generate results for a temperature preload to a structural 

solution. In the structural solution, you choose Teamcenter as the Source when you define your 

temperature preload. The Teamcenter file browser appears, where you can browse your Teamcenter 

database and select the Simulation dataset that contains the results. The dialog box provides a view of 

each file's Teamcenter attributes, such as Number, Revision, Description, and so on. Results files stored 

with that Simulation dataset are displayed in the list. 
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Where do I find it? 

Application Advanced Simulation 

Menu File→Import→Results file from Teamcenter 

Simulation Navigator Right-click the Simulation file node→Import Results file from 
Teamcenter 

 

Assign a Teamcenter project to a CAE item 

What is it? 

In the Advanced Simulation application, you can now assign a Simulation file or FEM file to a 

Teamcenter project as you create the file.  

A Projects button has been added to the File New dialog box, Name Parts dialog box, and Save 
Part File As dialog box.  
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The Projects button opens the Assign to Project dialog box, where you can select from a list of 

projects created in Teamcenter. 

Motion Simulation 

RecurDyn Solid 3D Contact 

What is it? 

A new type of 3D Contact has been added for the RecurDyn solver. The Solid contact method 

generates a force between two links when they come into contact. Each link is represented as a single 

solid for contact purposes. This method solves much faster and is more accurate than the existing 

Faceted and Fitted contact methods. 
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You should use the Solid contact method for most contact situations. In general, the Faceted and 

Fitted methods are now useful only for backward compatibility with existing Motion mechanisms. 

For more information, see 3D Contact for solid bodies in the Motion Simulation online Help. 

Where do I find it? 

Application Motion Simulation 

Toolbar 
Motion toolbar→3D Contact    

Menu Insert→Connector→3D Contact 

 

Joint Wizard support for assembly constraints 

What is it? 

The Motion Simulation Joint Wizard now converts assembly constraints (as well as legacy mating 

conditions) to appropriate links and joints automatically. In previous releases, only mating conditions 

were supported. 

The wizard creates the appropriate joint type based on the degrees of freedom in the components 

referenced by the assembly constraint. For example, if the assembly constraint removes five degrees of 

freedom (leaving one rotational degree of freedom), the Joint Wizard creates a revolute joint.  

Translational DOF Rotational DOF Joint to create 

0 0 Fixed 

0 1 Revolute 

1 0 Slider 
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Translational DOF Rotational DOF Joint to create 

1 1 Cylindrical 

2 1 Planar 

0 3 Spherical or AtPoint 

0 2 Universal 

1 3 InLine 

2 3 InPlane 

3 0 Orientation 

3 1 Parallel 

3 2 Perpendicular 

 

The wizard also infers the origin and orientation of the joint based on the geometry referenced by the 

assembly constraint. When you convert a joint from an assembly constraint, the wizard creates a smart 

point for the joint marker origin. This makes the joint position update automatically if the CAD model is 

modified.  

The Joint Wizard runs automatically when you create a new Motion Simulation from an assembly that 

contains either mating conditions or assembly constraints.  

Where do I find it? 

Application Motion Simulation 

Prerequisite Assembly that contains mating conditions or assembly constraints 

 

Driver for Point on Curve constraint 

What is it? 

With the RecurDyn solver, you can now create a motion driver for use with a Point on Curve 

constraint. Use the Driver dialog box to create a Constant, Harmonic, or Function driver 

(Displacement and Velocity data types only) and assign it to the Point on Curve constraint. This 

ability lets you drive the motion of the point on curve tangential to the curve. 
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Also, new Customer Defaults settings have been added to control how NX communicates the curve 

representation to the RecurDyn solver. In most cases, the default setting is recommended. However, if 

you have problems solving the mechanism, you can try changing the new Curve Parameterization 
Method in Customer Defaults, as described in About the Point on Curve method in Customer 

Defaults. 

Where do I find it? 

Application Motion Simulation 

Prerequisite Normal Run solution 

Toolbar 
Motion toolbar→Driver    

Menu Insert→Driver 

 

Quasi Static Articulation option for Adams/Solver 

What is it? 

When using Adams/Solver and running an Articulation solution, you can now choose the algorithm for 

Adams/Solver to use: Quasi Static or Dynamic. 

• Quasi Static — (Default) Use this method for most Articulation simulations. 

• Dynamic — Use this method when your mechanism contains nonlinear attributes such as many 

bushings and/or high damping coefficients.  

 Note 

Generally, with this type of nonlinear mechanism, you should use a Normal Run solution 

instead of Articulation. However, if you must use Articulation, use this Dynamic 

option.  

 

In previous releases, the solver selected the method automatically, but this caused problems when solving 

some mechanisms. 

For detailed information about each algorithm, see your Adams/Solver documentation. 
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To change the Articulation algorithm: 

1. From the File menu, choose Utilities→Customer Defaults.  

2. In the Customer Defaults dialog box, choose Motion→Analysis.    

3. On the Adams page, select the appropriate option. 
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Chapter 9:  NX Analysis 

   Space Finder 

What is it? 

The Space Finder command enhancement lets you: 

• Set a user defined precision for inner volume calculation. 

• Send the results to the Information window. 

Why should I use it? 

Use a user defined precision when other precision options do not produce results with the accuracy you 

expect. 

Where do I find it? 

Menu Analysis → Space Finder 
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Chapter 10:  Product Template Studio 

Product Template Studio enhancements 

What is it? 

The Product Template Studio application now has the ability to: 

• Create templates from FEA context. 

• Create templates from motion studies context. 

• Clone drawings when a template is executed. 

The following objects are now supported in a template: 

• Motion files and objects such as: 

– Joints, links, dampers, couplers 

– Forces 

– Simulations and solutions 

– Animation controls 

– Packaging objects 

– Results 

– Graphs 

• FEM objects such as: 

– Loads 

– Constraints and boundary conditions 

– Simulations and solutions 

– Results 

Why should I use it? 

These enhancements give you the ability to capture and reuse robust practices in motion studies and FEA 

analysis. 
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Where do I find it? 

Application Product Template studio 

Prerequisite You must open a model and select a feature in the Model Explorer 

window. 

Location in dialog box Attributes tab 

 

Knowledge Fusion Visual Rules enhancements 

What is it? 

The Product Template Studio application now allows you to add knowledge fusion visual rules to product 

templates. These rules are decision logics in the following categories: 

• Fetch — Fetch objects such as parts, features, bodies, reference sets and so on. 

• Filter — Filter objects such as parts, features, expressions, geometry and so on. 

• Construct — Create conditional components and decision logic loops. 

• Act — Adds or removes objects such as components, attributes, expressions, layers and so on. 

• Result — Sends the results to the information window or an HTML file which you can author. 

 

Why should I use it? 

Use the knowledge fusion visual rules to visually add knowledge fusion logic to new and existing product 

templates. 

Where do I find it? 

Application Product Template Studio 

Prerequisite You must open a model. 

Location in dialog box User interaction panel 
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Chapter 11:  Flexible Printed Circuit 

Design 

   Rebend enhancement 

What is it? 

When you use the Rebend command, you can specify a stationary face during the rebending operation. 

This command works the same as the Rebend command in NX Sheet Metal. For more information, see 

NX Sheet Metal — Rebend enhancement. 

Where do I find it? 

Application Flexible Printed Circuit Design, NX Sheet Metal 

Toolbar 
Flexible Printed Circuit Design→Rebend    

NX Sheet Metal→Rebend    

Menu Insert→Form→Rebend 
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Chapter 12:  Enhancements in NX 6.0.x 

Maintenance Releases 

Gateway 

Issue Navigator 

What is it? 

Use the Issue Navigator to capture, track, and close issues that arise during your design process. Issues 

can be design problems, workflow problems, or anything else you want to track in NX. 

Before you can use the navigator, you must do the following. See the NX 6.0.3 Help for more 

information. 

• Make sure the Teamcenter Community site where your issues lists are located has at least one 

existing issue list. If not, create the issue lists that you want to use. 

• Set a customer default to specify the URL of the Teamcenter Community site where your issues 

lists are located. You should also specify the other defaults for the Issue Navigator, which 

define navigator columns, filter conditions (if any), email notification for the person assigned to 

fix the issue, and attachment download behavior for native NX. 

• Select the Issue Navigator in the Start menu. 

Consider the following behavior when you create or modify an issue: 

• You must log into the site where your issue lists are located before you can work on any issues in 

native NX, or in Teamcenter Integration when Teamcenter Community is the site. To log in, 

right-click the background or a column heading in the main panel of the navigator. 

 Note 

In NX 6.0.3, the site must be Teamcenter Community. 

 

• You can attach part files, bookmarks, text documents, and other reference information to an issue. 

• You can assign the issue to the person who is responsible for fixing it. Optionally, when you set 

up the navigator, you can specify that it send e-mail notification to the assignee when the issue is 

created, modified, or closed. 
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Simplified representation of the Issue Navigator 

   
Issue Navigator main panel 

   
Issue list 

   
Issue 

In the figure above, an issue node is selected. 

   
Attachments — the icon shows the type of 

attachment. 

In the figure above, the attachments for the selected 

issue are a part and a validation log. 

   
Details panel 
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View types — specifies how the information in the 

details list (item 7) is shown. 

In the figure above, the Thumbnails view type is 

used. 

   
Details list — displays the details of the selected 

issue or issue list, in accordance with the view type. 

In the example, the details list shows thumbnails for 

the attachments. 

 

The server generates a unique ID for each issue. 

You can group or filter issues in the Issue Navigator with the Configure View dialog box. Grouping 

issues makes them appear in the order you want, for example, based on priority. You can also create 

custom filtered views of the Issue Navigator that show only the issues that interest you. 

Closed issues are read-only, and have a lock icon   . 

Why should I use it? 

The Issue Navigator lets you manage user-defined issues and their supporting files in a single location 

in NX. 

Where do I find it? 

Menu Start→All Applications→Issue Navigator 

Resource Bar 

Issue Navigator    

 

Exact lightweight geometry and refile_part utility changes 

What is it? 

The lightweight (faceted) representation format has been enhanced to contain exact surface geometry 

information for faces with analytic surface geometry such as faces with planar, cylindrical, spherical, or 

toroidal surface geometry. 

The software uses the exact geometry information while performing certain operations on faces, edges, 

and vertices of lightweight bodies. This information enables the software to perform the operations on 

lightweight bodies with the same accuracy as on solids. Examples of operations where exact geometry 

information is used include Move Component and many types of measurement. 

If the exact geometry in the part is created or updated in NX 6.0.2 or later, then the exact geometry 

information will be included in the lightweight representation and used by NX where possible. For parts 

with geometry last modified prior to NX 6.0.2, you must regenerate the lightweight representations to 

benefit from the improvements. 

The refile_part and ugmanager_refile utilities have been enhanced to facilitate the regeneration. 
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Switch Description 

regen_lw Regenerates all lightweight representations in the part, in order 

to take advantage of NX 6.0.2 enhancements to the lightweight 

format, such as the embedding of exact surface geometry 

definitions for faces with analytic geometry. 

regen_lw_def_tol Regenerates all lightweight bodies using the current default 

faceting tolerance values. 

 Note 

In Teamcenter Integration, regen_lw_def_tol must be 

used in conjunction with regen_lw to take effect. 
 

 

 

Why should I use it? 

These enhancements enable you to get precise results in some important situations where you would 

previously have gotten approximate results due to the faceted nature of the representations. 

Where do I find it? 

Lightweight representations created or edited in NX 6.0.2 automatically use exact lightweight geometry 

for analytic faces. 

To update other parts to take advantage of the enhanced lightweight representation format, you can run 

the refile_part utility (in native NX) or the ugmanager_refile utility (in Teamcenter Integration), using the 

new switches, from the command line of your operating system. 

See the Utilities and File Management Help and the Teamcenter Integration for NX Help for more 

information. 

Specify geometry layer in JT files 

What is it? 

You can now set customer defaults to specify the layer on which to locate model geometry objects when 

you open a JT file in NX. Geometry objects include solid bodies, sheet bodies, and faceted bodies. 

If you want the geometry to be placed on the work layer, select the Use Work Layer check box. 

If you want the geometry objects to be placed on a different layer, clear the Use Work Layer check box, 

and specify the layer you want in the Model Geometry Layer box. 

 

Why should I use it? 

The ability to control the geometry placement layer in JT files helps you to: 

• Follow your company standards for geometry placement on layers. 

• Place geometry objects on the layer that best suits your design intent. 
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Where do I find it? 

Menu File→Utilities→Customer Defaults 

Location in dialog box Gateway→Extras→JT Files tab 

 

Move Object enhancements 

What is it? 

The Move Object dialog box has the following new options: 

Layer Option list 

• Work moves or copies the selected objects in the current work layer. 

• Original moves or copies the selected objects on their original layer. 

• As Specified moves or copies the selected objects to the specified layer. 

Layer box 

Available only when Layer Option is set to As Specified. 

Lets you specify the layer to which the selected objects are to be moved or copied. 

Associative 

Creates an associative Move Object feature. 

 Note 

The Associative option is not available in Sketcher and Drafting applications. 

 

Why should I use it? 

Use the Associative option to create an associative Move Object feature. 

The layer options let you specify the layer to which the selected objects are to be moved or copied. 

Where do I find it? 

Application Gateway 

Toolbar 
Standard→Move Object    

Menu Edit→Move Object 

Location in dialog box Result group→Layer Option/Layer 

Settings group→Associative 
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Modeling 

Resize Datum Plane 

What is it? 

Use the Resize Datum Plane command to change the width and length of an existing datum plane. 

 

Why should I use it? 

You can change the size of a datum plane, even in large models, without updating the model. Although 

you can also resize a datum plane with the Edit with Rollback command, doing so requires an update 

of the model. 

Where do I find it? 

Application Modeling 

Menu Edit→Feature→Resize Datum Plane 

Graphics window Right-click an existing datum plane→Resize Datum Plane 

 

Convert to Linked Body 

What is it? 

Converts an unparameterized feature to a Linked Body feature. The Linked Body feature is without 

parents and appears in the Part Navigator as a broken link.  

Any dependencies that may exist for the body, edges, and faces of the unparameterized feature are 

transferred to the corresponding body, edges, and faces of the converted Linked Body feature.  

Why should I use it? 

You can use this command any time you need to replace the body of an unparameterized feature with 

another body. You can edit the Linked Body to specify a new parent body of the part, and then use the 

Replacement Assistant to maintain associativity with downstream data. 

This command may also be useful in avoiding phased migration with traditional migration methods. You 

can migrate all parts of an assembly at the same time, including Assembly and Drafting files. 

Where do I find it? 

Application Modeling 

Part Navigator Right-click an unparameterized feature→Convert to Linked Body 
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Retaining imprinted edges in a Split Body 

What is it? 

Keep Imprinted Edges is a new option for the Split Body command that lets you retain the edges 

that mark the intersection between the split bodies. The Advanced Simulation application uses the edges 

to automatically create glue coincident mesh mating conditions between the bodies. 

     The selected solid body in the figure is the target in a Split Body operation. A highlighted 

face plane is the tool that will split the body. 

 

     The result is two solid bodies adjoining each other. 

     If Keep Imprinted Edges was selected during the Split Body operation, hiding the 

cylinder solid body reveals the imprinted edges (top image). 

If Keep Imprinted Edges was not selected, imprinted edges are not present when you hide the 

cylinder (bottom image). 

 Note 

An existing edge can be considered an imprinted edge if it forms part of the intersection between 

faces from the target and the tool.  

When working in Advanced Simulation with an idealized part active, the Split Body option Keep 
Imprinted Edges becomes Auto Create Mesh Mating Conditions. 

 

Why should I use it? 

Use this option to create edges between the bodies generated from a Split Body command, which are 

used in Advanced Simulation to automatically create mesh mating conditions. Mesh mating conditions 
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ensure that meshes are continuous from one body to the other. Previously, you had to manually create 

mesh mating conditions between any bodies created by the Split Body command.  

Where do I find it? 

Application Modeling, Advanced Simulation 

Prerequisite When working in Advanced Simulation, the idealized part must be 

active 

Location in dialog box (From Modeling) 

Settings group→Keep Imprinted Edges 

(From Advanced Simulation) 

Settings group→Auto Create Mesh Mating Conditions 

Menu Insert→Trim→Split Body 

Toolbar 
Modeling→Insert→Trim→Split Body    

 

Synchronous Technology face overflow options 

What is it? 

Synchronous Technology commands now include options to let you control overflow characteristics of 

faces you move, and how they interact with other faces.  

Extend Change 
Face 

Dragging the selected face extends it into or moves it past other faces it encounters.  

 

     Selected face 

Extend Incident 
Face 

Dragging the selected face extends it until it meets a stationary, incident face. The 

selected face then ceases to extend, and the stationary face extends instead. 
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   Incident faces 

Extend Cap 
Face 

Dragging the selected face past an overhanging edge causes it to overflow and cap 

itself (the bottom of the change face in the figure below). 

 

Automatic Dragging the selected face causes either the selected face or an incident face to 

extend, depending on which outcome would result in the least amount of change to 

volume and area. 

 

Why should I use it? 

Use these options to control how a change face overflows stationary or incident faces in solid bodies. 
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Where do I find it? 

Application Modeling 

Location in dialog box Settings group→Overflow Behavior 

Menu Insert→Synchronous Modeling→Move Face/ Offset Region/ 

Replace Face/ Make Coplanar/ Make Coaxial/ Make 
Tangent/ Make Perpendicular/ Make Parallel/ Linear 
Dimension/ Angular Dimension/ Radial Dimension  

Toolbar Synchronous Modeling 

 

Synchronize Views in Replace Feature 

What is it? 

Synchronize Views is a new option in the Replace Feature command. This options synchronizes the 

current and replacement views when you replace a feature. When you rotate, pan, zoom, or apply 

rendering styles in one view, NX automatically synchronizes the other view to match these operations. 

 

Before replacement 

 

 

After replacement 

 

The following animation demonstrates the automatic synchronization of the current view and the 

replacement view as you replace the hole feature from one block to the other. 
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A split screen appears only when: 

1. The selected feature to replace has downstream dependents that appear in the List subgroup 

under the Mapping group. 

2. You select any of the displayed dependents as reference from the List subgroup. 

Why should I use it? 

Use this option to locate objects that you want to replace in one view, while NX automatically tracks your 

movements toward the same location in the other view. This saves mouse clicks and reduces the need to 

repeat the same view manipulations in the other view. 

Where do I find it? 

Application Modeling 

Prerequisite You must select a dependant reference of the selected feature to 

replace from the List subgroup in the Mapping group. 

Toolbar 
Edit Feature→Replace Feature    

Menu Edit→Feature→Replace 

Location in dialog box Settings group→Synchronize Views 
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Assemblies 

Motion envelopes 

What is it? 

The Motion Envelope function, which is used to create a volume of motion for components, has the 

following enhancements: 

• New underlying swept volume generator technology that creates better motion envelopes more 

quickly. This technology is also used by Teamcenter Visualization. 

• A simpler user interface for defining an envelope accuracy in the Custom quality option. 

Beginning in NX 6.0.2, when you set Quality to Custom, the quality is defined using a single 

Envelope Tolerance option, replacing the multiple, less intuitive options of the previous 

releases. 

Use the Envelope Tolerance option to specify the maximum distance between the theoretical 

and actual motion envelopes. Smaller tolerances produce more accurate envelopes, but require 

more time and memory. 

 

Motion envelope of a vise handle ball 

The new swept volume generator has the following requirements: 

• A 3D graphics adapter with 24-bit depth buffer or better (Required) 

• A system with at least 2GB of RAM (Recommended) 

 Note 

The generation of high quality envelopes for complex parts may use a large amount of memory for 

some motion definitions. If you find that you are unable to generate motion envelopes due to 

virtual memory or RAM limits on your computer, you could try using a lower quality setting for 

the motion envelope, or restart NX so the largest amount of memory is available. Alternatively, try 

to create the envelope using a computer with more memory. 

 

The new swept volume generator can make use of multiple CPUs or cores. However, the benefit of 

having more than two cores decreases rapidly, because most of the work is done by the graphics adapter. 

Why should I use it? 

Advantages of creating motion envelopes in NX 6.0.2, compared to earlier releases, include the 

following: 
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• Accuracy — the motion envelope is tighter at all quality levels: low, medium, high, and custom. 

• Performance — the generation of a motion envelope of any quality is much faster. 

• Usability — Custom envelope tolerances are much easier to understand. 

Where do I find it? 

Application Assemblies 

Prerequisite You must be in the assembly sequencing environment, and your 

assembly sequence must include one or more motion steps. 

Toolbar 
Assembly Sequencing and Motion→Motion Envelope    

Menu Tools→Motion Envelope 

 

Variable positioning and Fix constraints 

What is it? 

When variable positioning is used on a component that includes Fix assembly constraints, the inherited 

version of each Fix constraint is now a Bond constraint. 

When you open an assembly that includes Fix constraints inherited by variable positioning applied in an 

earlier release of NX, the higher-level inherited Fix constraints are converted to Bond constraints. 

Why should I use it? 

Inheriting a Fix constraint to a higher-level Fix constraint can cause undesirable behavior such as 

preventing movement of the fixed component's parents in higher-level assemblies. Converting the Fix 

constraint to a Bond constraint at higher levels preserves some of the behavior of the Fix constraint on the 

component. The higher-level Bond constraint connects the fixed component to its parent, which lets the 

component and parent move as a pair, but restricts independent movement of the component. 

Where do I find it? 

Application Assemblies 

Prerequisite You can only use variable positioning on a component that has at least 

two assembly levels above it. This means that the component must 

have at least one parent that has a parent of its own. 

 Note 

The lowest level can be a subassembly if you do not select 

any of its components. 
 

Shortcut menu Assembly Navigator→right-click a component node→Override 
Position 

 



264    What's New in NX 7   whatsnew7 0  

Drafting 

Single Sided arrowhead terminators 

What is it? 

You can now select single sided arrowhead terminators on annotation with leaders. There are four new 

arrowhead types: 

•    — Top Open Arrow 

•    — Bottom Open Arrow 

•    — Top Closed Arrow 

•   — Bottom Closed Arrow 

Why should I use it? 

Use the single sided arrowhead terminators to maintain compliancy with ESKD (Russian) standards or to 

use other annotations (for example, Weld Symbols) that use half arrowheads. 

Where do I find it? 

Application Drafting and PMI 

Prerequisite The single sided arrowhead options are only available in annotation 

command dialog boxes with groups. 

Location in dialog box Leader group→Style sub-group. 

 

ESKD (Russian) standard thread display 

What is it? 

You can select an option to display threads on a drawing in compliance with the ESKD (Russian) 

standard.  

Why should I use it? 

Use the ESKD thread option to maintain compliancy with the ESKD (Russian) standards. 

Where do I find it? 

Application Drafting 

Location in dialog box View Style/View Preferences→Threads 

Customer 
Defaults→Drafting→General→Customize 
Drafting Standard→View→Threads 
tab→Thread Standard 
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Restrict crosshatch angle 

What is it? 

The Assembly Crosshatching and Restrict Crosshatch to +/- 45 degrees options enable you to 

restrict assembly crosshatching angles to plus or minus 45 degrees in section views. 

Why should I use it? 

Use the restricted crosshatch angle to maintain compliancy with the ESKD (Russian) standards. 

Where do I find it? 

Application Drafting 

Location in dialog box Preferences/Style→View→Section 

tab 

Customer 
Defaults→Drafting→View→Hatching 

tab 

 

ESKD (Russian) weld symbols 

What is it? 

New standard for weld symbols that includes additional settings and symbol types required by the ESKD 

(Russian) standards. The additional settings available for ESKD weld symbols are: 

• Weld Line Gap 

• Arrowhead Type 

 Note 

Color, font, and width settings are available for all weld standards. 

 

The additional symbols available for the ESKD weld symbols are: 

• Flush Weld 

• Machining for Graded Junction 

• Intermittent Weld 

• Weld Along Closed Contour 

• Weld Along Open Contour 

New symbols to meet the ESKD (Russian) standards have also been added for: 

• Staggered Weld 

• Field Weld 
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Where do I find it? 

To set the default standard for weld symbols 

Application Drafting or PMI 

Menu File→Utilities→Customer Defaults→ 

Location in dialog box Drafting→General→Standard→Customize Standard→Other 
Symbols →Weld tab→Standards 

 

GB (China) weld symbols 

What is it? 

GB is a new standard for weld symbols that includes additional settings and symbol types required by the 

GB (China) Standard. The additional symbol available for GB weld symbols is: 

• Trilateral Weld 

Where do I find it? 

To set the default standard for weld symbols 

Application Drafting or PMI 

Menu File→Utilities→Customer Defaults 

Location in dialog box Drafting→General→Standard→Customize Standard→Other 
Symbols→ Weld tab→Standards  

 

Detail View color, font, and width 

What is it? 

You can control the color, font and width settings for: 

• Detail view boundary lines. 

• Detail view labels on a parent boundary line. 

The options to do this are available  from Customer Defaults, Preferences, and Style. 
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Detail View with dotted, orange colored boundary and black text 

 

Why should I use it? 

You can use these settings to control how detail views and labels appear on parent boundary lines. 

Where do I find it? 

Drafting Standard Customer Default 

Application Drafting 

Prerequisite Drawing views with standard orientations 

Menu Preferences or Style→View→Detail tab. 

Location in dialog box File→Utilities→Customer 
Defaults→Drafting→General→Standard tab →Drafting 
Standards→View→Detail View tab 

Shortcut menu Graphics window →right-click→Style (on a view boundary) 

 

Narrow Arc Length and Angular Dimensions 

What is it? 

The Narrow formatting option shows the value of a small dimension outside the dimension lines. A label 

shows to which dimension the value applies. Included in the Narrow angle and Narrow arc length 

dimension options is the ability to change the leader attachment location for all Narrow dimensions  

(Linear, Arc Length, and Angular). 
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Narrow angle dimension Narrow arc length dimension 

 

Why should I use it? 

Use the new dimensions to make small arc length and angular dimensions easier to read. 

Where do I find it? 

Application Drafting 

Prerequisite Drawing views with standard orientations 

Menu Preferences→Annotation→Dimensions tab→Narrow 

 

Section Line Style Enhancements 

What is it? 

New Section Line Style controls support the ESKD (Russian) and ISO128 Standards. The ESKD 

Standard includes control for the length of the end line. The ISO128 Standard for section lines has been 

enhanced to include an Invisible font and control over whether the label is displayed on the arrow or at 

the end of the section line. 
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ESKD Section Line ISO128 Section Line 

 

The Invisible font is only available for section line types that support thick ends and breaks.  If you set the 

line font to invisible,  the ends and breaks display, but not the lines between them. 

Why should I use it? 

Use the new Section Line Style controls when support for ESKD or ISO128 is required. 

Where do I find it? 

Preferences Section Line 

Application Drafting 

Prerequisite Drawing views with standard orientations 

Menu Preferences→Section Line 

Shortcut menu Graphics window →right-click→Style (on a section line) 

 

Annotation Style Section Line 

Application Drafting 

Prerequisite Drawing views with standard orientations 

Menu Edit→Annotation Style and select Section Line. 

Shortcut menu Graphics window →right-click→Style (on a section line) 
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PMI 

PMI objects in JT files 

What is it? 

When you open a JT file in NX, the following objects now appear if they were saved in the JT file: 

• Assembly-level PMI and model views from Teamcenter JT files. This includes the display of 

component PMI in assembly model views. 

• PMI locator symbols that were created in I-deas or NX. 

 

Why should I use it? 

JT files that are opened in NX now more closely match their source files. 

Where do I find it? 

Toolbar 
Standard→Open   →select a JT file 

Menu File→Open→select a JT file 

 

Manufacturing 

Face Milling — negative floor stock 

What is it? 

You can now enter a negative value for Final Floor Stock in Face Milling operations. 

In Face Milling operations, the cut region is computed assuming 0.0 floor stock. When you define a 

negative floor stock value, cutting moves created on the faces are moved down into the part by the given 

value. All moves in the cutting plane are pushed down. This includes cutting, first-cut, and step-over 

moves. 
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Why should I use it? 

Enter a negative value to make small adjustments to the cut depth in order to meet a specific requirement, 

such as a particular dimension or tolerance. 

Where do I find it? 

Application Manufacturing 

Toolbar Insert→Face Milling 

Dialog Box Cutting Parameters→Stock tab→Final Floor Stock 

 

Turning cutter compensation 

What is it? 

Cutter compensation (cutcom) options control the cutter radius compensation function of the machine 

controller. The software outputs G41 or G42 code to adjust the tool path left or right, measured relative to 

the tool's direction of motion. 

 

Profile cutting pass without cutter compensation 

There are two types of cutter compensation available: 
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• Fixed tracking point 

• Contact contour 

Fixed tracking point cutter compensation 

If you do not select contact contour cutter compensation, the software generates cutter compensation for 

tool paths using a fixed tracking point on the tool. This method typically requires an offset value that is 

small compared to the radius of the tool. 

No cutter compensation Tool path adjusted to the right Tool path adjusted to the left 

          

   Programmed tool path 

   Tool path adjusted by controller 

   Tool nose radius 

 

 

Contact contour cutter compensation 

Contact Contour is also referred to as full radius cutter compensation or material edge contouring. Use 

contact contour cutter compensation for tool paths generated at the circumference of the tool radius. 

Contact contour cutter compensation: 

• Is activated with the Output Contact/Tracking Data option. 

• Ignores any tracking point. 

• Measures gauge lengths from the center of the active tool nose radius. 

Changing the tool nose radius, such as for a grooving tool, also moves the gauge length measurements to 

the center of the newly active tool nose radius. 

• Typically requires an offset value that is equal to the radius of the tool. 

No cutter compensation Tool path adjusted right to part 

contour 

Tool path adjusted left to part 

contour 
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Contact contour cutter compensation 

         

   Programmed tool path 

   Tool path adjusted by controller 

   Tool nose radius 
 

 

Why should I use it? 

If the NC programmer turns on cutter compensation, the machine operator can adjust the tool path with 

the offset value in the cutter compensation register of the controller. This enables the machine operator to: 

• More closely control cutting dimensions of the part. 

• Compensate for variation in the tool size. 

• Compensate for tool or part deflection. 

Where do I find it? 

Application Manufacturing 

Available for Turning finishing operation and profiling passes in a Turning 

roughing operation 

Location in dialog box 
Operation dialog box→Non Cutting Moves   →More 

page→Cutter Compensation group 

 

Divide by Holder 

What is it? 

Divide by Holder lets you divide a generated tool path where there are holder collisions. When the 

software finds a holder collision, it moves backwards along the tool path to the closest transfer, then 

divides the tool path into two operations at the transfer. The original operation contains collision free tool 

path. The new operation contains the tool path section with holder collisions. 
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Name Path Edit Status 

   CAVITY_MILL    Repost 

 

Operation Navigator before Divide by Holder 

Name Path Edit Status 

   CAVITY_MILL    Repost 

   CAVITY_MILL_DIV_1    Repost 

 

Operation Navigator after Divide by Holder 

You can change the following parameters in the split operation to eliminate holder collisions: 

• Tool 

The tool shape, diameter, corner radius, and taper angle must be the same. 

• Holder 

• Program group 

• Machine Control options 

• Feed rate 

Divide by Holder is useful for: 

• Level based operations. 

• Area milling operations with a Zig or Zig Zag with Lifts cut pattern that generates transfers. 

Divide by Holder does not work if the operation does not have transfers. For example, you 

cannot use Divide by Holder for a Zig Zag cut pattern where the tool enters the cut, zig-zags 

everywhere to machine the part, then retracts. 

Why should I use it? 

You can: 

• Generate operations with holder checking turned off for faster performance, then run Divide by 
Holder to remove holder collisions. 

• Use Divide by Holder when there are changes to the holder information, to correct the tool path 

without regenerating the operation. 

Where do I find it? 

Application Manufacturing 

Shortcut menu Operation Navigator→right-click the operation→Tool 
Path→Divide by Holder 
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Where do I find it? 

Post Builder template posts 

Application Post Builder V 6.2 and V 7.0 

Menu File→New 

Location in dialog box Controller group→Library list 

 

Sinumerik 840D user defined events 

Application Manufacturing 

Menu Insert→Operation 

Location in dialog box 
Operation dialog box→Machine Control group→Edit   (Start 
of Path Events) 

 

NX Sheet Metal 

Tool ID attributes display in the Flat Pattern view 

What is it? 

You can display tool IDs as callouts in the Flat Pattern view or drawing member view if the callout text is 

inserted as a specific attribute (SHEET_METAL_TOOL_ID) on a datum CSYS on a Sheet Metal part. 

The datum CSYS can be placed anywhere on the Sheet Metal part or it can be associated with user 

defined features (UDF) or other Sheet Metal features: for example, Dimple, Louver, or Bead. 

You can also create a tool using UDFs with an associated datum CSYS and insert the attribute, 

SHEET_METAL_TOOL_ID, with the callout text as the attribute value on the datum CSYS. You can 

then place the tool on the Sheet Metal part using a CSYS or other positioning dimensions. The location of 

the CSYS on the UDF is also the location of the tool ID callout. 

In the following example, two UDFs and a Dimple are placed on the Sheet Metal part. The Rectangular 

Tool and Dimple are placed using the CSYS for placement, while the Circular Tool is placed using 

positioning dimensions. 

Each tool has the respective callout text RECTANGULAR_TOOL_30X20, CIRCULAR_TOOL_20, 

and DIMPLE 40X20, inserted as the attribute value for the string attribute 

SHEET_METAL_TOOL_ID. The tool IDs for each tool are displayed in the flat pattern view with a 

marker, a leader, and the tool ID callout. 
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Formed Sheet Metal part with UDFs and a 

Dimple 

Tool IDs displayed in the Flat Pattern view 

 

 

You can modify the tool ID name and control the display of the tool ID using the options in the NX 
Sheet Metal Preferences dialog box. You can also specify customer defaults in Drafting and Sheet 

Metal for the color, type, width, and layer of the tool ID. 

In the Drafting application, you can right-click the tool ID callout, choose Edit, and use the Note dialog 

box to edit the callout. You can edit the tool ID Attribute, tool parameters, and location after you place the 

tool. 

Why should I use it? 

Displaying tool ID attributes as callouts in the flat pattern view help you identify the tools used to create 

sheet metal features. 

You can use the API in your own NX Open programs to extract information like the tool ID, location, 

orientation, and tool parameters if they are inserted as attributes. You can extract tags and the bend radius, 

angle, and neutral factor values associated with flat pattern or flat solid objects. This is helpful in 

manufacturing processes. 

Where do I find it? 

Tool ID callouts must be inserted as attribute values of a specific string type of feature attribute, 

SHEET_METAL_TOOL_ID, on a datum CSYS anywhere on a Sheet Metal part, or can be associated 

with a UDF or other Sheet Metal features. 
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Flat Pattern Display preferences for tool ID attributes 

What is it? 

The following NX Sheet Metal preferences are available for flat pattern display: 

Tool Marker 

Controls the display of the color, font, width, and layer of tool marker objects. 

If you clear the Tool Marker check box, the Marker, Leader, and Tool ID Attribute values in 

the flat pattern display are not available. 

Tool Id 

Displays Tool ID Attribute values as callouts in the flat pattern display. 

 Note 

You can set the default values for the tool ID attributes using the customer default options. For 

more information, see Customer defaults for tool ID attributes. 

 

Where do I find it? 

Application NX Sheet Metal 

Menu Preferences→NX Sheet Metal 

Location in dialog box NX Sheet Metal Preferences dialog box→Flat Pattern Display 

tab→Curves group→Tool Marker check box 

NX Sheet Metal Preferences dialog box→Flat Pattern Display 

tab→New callouts from defaults group→Tool Id check box 

 

Customer defaults for tool ID attributes 

What is it? 

You can set the default values for tool ID attributes using the following customer default options: 

Tool Marker 

• Enabled 

Select this check box to specify if Tool Marker Objects should be created and displayed 

on flat patterns. 

• Color, Font, Width, Layer 

Specifies the color, font, width, and layer for Tool Marker Objects on flat patterns. 
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Custom Callout 7 

• Available 

Select this check box to specify if the callout is available on the Preferences and Style 

dialog boxes for flat patterns. 

• Enabled  

Select this check box to specify if the callout is created on flat patterns. 

• Name, Object Types, Content  

Specifies the name, object types, and content for the Tool Marker Objects. 

Where do I find it? 

Menu File→Utilities→Customer Defaults 

Location in dialog box Customer Defaults dialog box→Sheet 
Metal→Extras→Curves tab→Tool Marker group 

Customer Defaults dialog box→Sheet 
Metal→Extras→Annotations  tab→Custom Callout 7 group 

Customer Defaults dialog box→Drafting→Extras→Flat 
Pattern Curves tab→Tool Marker group 

Customer Defaults dialog box→Drafting→Extras→Flat 
Pattern Annotations  tab→Custom Callout 7 group 

 

Mold and Die Tools 

Progressive Die Wizard 

Progressive Die Wizard uses assembly constraints 

What is it? 

Progressive Die Wizard can create assembly constraints when you: 

• Add insert groups. 

• Add standard parts. 

The use of constraints is automatic when you set your assembly positioning preference to Assembly 
Constraints. 

Why should I use it? 

You should consider using constraints as soon as it is practical because constraints are the current and 

preferred method of positioning components. 
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Where do I find it? 

If your company already works with assembly constraints instead of the legacy mating conditions you 

need take no further action.  

Application Progressive Die Wizard 

Menu Preferences → Assemblies → Assembly Positioning 

Interaction → Assembly Constraints 

Customer Default File → Utilities → Customer Defaults → Assemblies → 

Extras → Assembly Constraints → Positioning → 

Assembly Constraints 

 

Weld Assistant 

Delete in Connected Face Finder 

What is it? 

The Delete option is now available in the Connected Face Finder dialog box. You can delete a weld 

point directly from the Results tree after you run a Connected Face Finder check. 

    Spot Weld (117) 

   Spot Weld (114)  

   Spot Weld (95) 

   Connected Face Set 1 

   Connected Face Set 2 

   Point 9  

   Connected Face Set 1 

   Connected Face Set 2 

   Point 10  

 

Where do I find it? 

Application Modeling 

Prerequisite Run the Connected Face Finder. 

Toolbar Weld Assistant→Connected Face 

Finder    

Menu Insert→Welding→Connected Face 
Finder 

Location in dialog box In the Results tree, right-click a Point 

node→Delete. 

 



280    What's New in NX 7   whatsnew7 0  

Delete in Weld Advisor 

What is it? 

The Delete option is available in the Weld Advisor dialog box. You can delete a weld point directly 

from the Results tree after you run a Weld Advisor check.  

   Point WLD1 

   Point WLD1 

   Point WLD1 

   Point WLD1 

   Point WLD1 

   Point WLD1 

 

 

 

 

Where do I find it? 

Application Modeling 

Prerequisite Run the Weld Advisor. 

Toolbar 
Weld Assistant→Weld Advisor    

Menu Insert→Welding→Weld Advisor 

Location in dialog box In the Results tree, right-click a Point node→Delete. 

 

New Auto Point options 

What is it? 

The Auto Point command has the following new options. 

Maximum Single 
Thickness 

Specifies the maximum single metal thickness for all the selected components. If 

the distance between the top faces of two panels, or sheets, is greater than the 

specified Maximum Single Thickness plus the specified Maximum Face Gap 

distance, weld points are not created at that location. 

Maximum Bend 
Radius 

Specifies the bend radius of a flange. Weld points are not placed on faces with a 

radius smaller than this value.  

Minimum Flange 
Width 

Specifies the minimum flange width. If the opposite sides of a flange are smaller 

than the Minimum Flange Width, weld points are not created on that flange. 
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Where do I find it? 

Application Modeling 

Toolbar 
Weld Assistant→Auto Point    

Menu Insert→Welding→Auto Point 

Location in dialog box Settings group→Maximum Single Thickness/Maximum Bend 
Radius/Minimum Flange Width 

 

Reverse Z Direction in Weld Point 

What is it? 

Reverse Z Direction is a new option in the Weld Point dialog box that is available for all spot welds. 

It lets you reverse the weld CSYS Z vector direction for all welds in the feature set at once, as shown in 

the following animation. 

 

Why should I use it? 

This option is primarily useful when you use sheets instead of solid bodies to represent sheet metal 

panels. With a sheet, it is not easy to determine the inside and outside of a part, and the Z vector of the 

weld CSYS may point in an undesirable direction. With the new Reverse Z Direction option, you can 

have better control over the direction of the weld CSYS. 
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Where do I find it? 

Application Modeling 

Prerequisite Available only when you select the Display CSYS check box in the 

Preview/Edit group.  

Toolbar 
Weld Assistant→Weld Point    

Menu Insert→Welding→Weld Points 

Location in dialog box Preview/Edit group→Reverse Z Direction 

 

Control Direction in Weld Point 

What is it? 

There are now Control Direction options in the Weld Point dialog box that you can use to control the 

Z-axis direction for spot welds. 

Default Specifies the direction of the weld CSYS along the Z-axis using the default 

direction. 

Opposite Specifies the direction of the weld CSYS along the Z-axis using the opposite 

direction. 

 

 Note 

The default Z direction may be different for different solid types. For example, a cylinder's default 

Z direction is opposite of the default Z direction for a measurement vector. 

 

Why should I use it? 

You can use Control Direction options in conjunction with the Reverse Z Direction option for better 

flexibility in defining connections such as self pierce rivets. 

Where do I find it? 

Application Modeling 

Prerequisite Available only when you create Clinch type weld points or custom 

spot welds that use either a cylinder or cone as the display object.  

Toolbar 
Weld Assistant→Weld Point    

Menu Insert→Welding→Weld Point 

Location in dialog box Settings group→Control Direction list→Default/Opposite 
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Ship Design 

Manufacturing features 

   Reference Line 

What is it? 

Reference Line creates a curve lying in a plane parallel to a grid plane at a user-specified offset. 

 Note 

The grid plan is a datum plane created by the Concept module. 

 

Why should I use it? 

Use this line as a point to measure from. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Reference Line    

Menu Insert→Manufacturing→Reference Line 

 

   Marking Line 

What is it? 

Marking Line creates curved geometry showing the location of a profile and/or plate on a section of the 

hull, deck, or bulkhead. 

Why should I use it? 

In the context of a section assembly, it is necessary to indicate the location of profile and plate parts on a 

hull section, deck, and/or bulkhead. To accomplish this, you need to create curved geometry with 

assigned attributes. This geometry and attributes will be part of the output file for the flame cutter. The 

flame cutter will scribe this information on the part. 

  



284    What's New in NX 7   whatsnew7 0  

Where do I find it? 

Application Ship Design 

Toolbar 

Manufacturing→Marking Line    

Menu Insert→Manufacturing→Marking Line 

 

   Plate Preparation 

What is it? 

Plate Preparation flattens non-planar plates and applies a shrink factor to all plates. 

Why should I use it? 

Use Plate Preparation to prepare all plates for manufacturing by flattening the plates and/or adding a 

shrink factor. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Plate Preparation    

Menu Insert→Manufacturing→Plate Preparation 

 

   XML Output 

What is it? 

This function will outputp flame cutter information used for the cutting of parts and scribing information 

on the parts. 

Why should I use it? 

Use this functionality to create an XML file, which is used to generate a file that can be read by the flame 

cutter to manufacture a part. 
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Where do I find it? 

Application Ship Design 

Toolbar 

Manufacturing→XML Output    

Menu Insert→Manufacturing→XML Output 

 

   Material Allowance 

What is it? 

Material Allowance creates attributes on the end faces of profiles. The function creates the attribute 

MK_TYPE and MK_SIZE. 

Why should I use it? 

This allowance is needed to compensate for manufacturing and assembly inaccuracies. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Material Allowance    

Menu Insert→Manufacturing→Material Allowance 

 

   Vent Hole Marking Sketch 

What is it? 

Vent Hole Marking Sketch creates a table showing the location of the ventilation holes on a part. 

Why should I use it? 

Use this function to create a table which shows the X and Y location of each ventilation hole on a part in 

the flattened state. 
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Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Vent Hole Marking Sketch    

Menu Insert→Manufacturing→Vent Hole Marking Sketch 

 

   Knuckled Profile 

What is it? 

Knuckled Profile creates a bend table for profiles that are bent on a brake press. 

Why should I use it? 

In order to manufacture bent profiles from a straight semi-finished material, you need to provide a 

distance measurement from an edge to the bend centerline of each bend. Knuckled Profile provides this 

capability. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Knuckled Profile    

Menu Insert→Manufacturing→Knuckled Profile 

 

   Inverse Bending 

What is it? 

Inverse Bending creates curved geometry on a profile. 

Why should I use it? 

In order to form curved profiles from a straight semi-finished material, it is necessary to mark a curve on 

the profiles. This curve is used as a gauge during the bending process. When the curved line becomes 

straight the profile is in its formed shape. 
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Where do I find it? 

Application Ship Design 

Toolbar 

Manufacturing→Inverse Bending    

Menu Insert→Manufacturing→Inverse Bending 

 

   Profile List 

What is it? 

Profile List generates a Bill of Material (BOM) of all the profiles contained in a distributed assembly. 

Why should I use it? 

Use this to obtain the information needed for the BOM of the profiles contained in a distributed assembly. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Profile List    

Menu Insert→Manufacturing→Profile List 

 

   Weld Preparation 

What is it? 

Weld Preparation adds the needed weld information to a body, by modifying the edge of the body for 

the weld joint type and adding attributes to the body. 

Why should I use it? 

Use this function to define the weld joint type and to modify the size and shape of the body so the flame 

cutter can cut the body to its proper size and shape. 

Where do I find it? 

Application Ship Design 

Toolbar 
Manufacturing→Weld Preparation    

Menu Insert→Manufacturing→Weld Preparation 
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Steel features 

    Profile / Plate 

What is it? 

The following features are merged in the new Profile / Plate feature: 

• Linear Profile 

• Non-Linear Profile 

• Linear Sheet 

• Non-Linear Sheet 

You can now choose one feature to create a profile or plate. You do not need to know if the placement 

face is planar or non-planar. 

 Note 

The former Sheet feature is now called Plate. 

 

Why should I use it? 

This merger allows you to edit the feature and switch the type from a profile to a plate or from a plate to a 

profile. 

Where do I find it? 

Application Ship Design 

Toolbar 

Steel Features→Profile / Plate    

Menu Insert→Steel Features→Profile / Plate 

 

   Endcut 

What is it? 

This option defines an endcut by utilizing the Steel Feature Library function. It also allows you to 

apply a miter to an endcut feature or to the thickness face of a solid body. 

Why should I use it? 

Use this functionality to modify the end condition of any solid body. 
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Where do I find it? 

Application Ship Design 

Toolbar 
Steel Features→Endcut    

Menu Insert→Steel Features→Endcut 

 

   Update Steel Library 

What is it? 

The reading in of a library part is now a separate step and includes endcuts. 

Why should I use it? 

This allows you to read in all of your different library parts before you create a feature and updates the 

library in a part file if the library changes. 

Where do I find it? 

Application Ship Design 

Toolbar 
Steel Features→Update Steel Library    

Menu Insert→Steel Features→Update Steel Library 

 

Teamcenter Integration for NX 

Password option for utilities when running Teamcenter 8 

What is it? 

You can hide the password in a file that contains the password. When you run Teamcenter 8, you can use 

the new password option pf as a command line option instead of p. 

You can use this whenever a password is required. This includes all Teamcenter Integration utilities and 

command line startup of Teamcenter Integration. 

The value for pf is a file name. Teamcenter Integration reads the password in the file and sends the 

extracted password to Teamcenter. 

For example, you can use the following to start Teamcenter Integration: 

  ugraf —pim=yes —u=xyz —pf=mypassword.dat 

It is recommended that you ensure that the file is protected by local machine access controls so that only 

authorized user accounts for certain applications can read the file. 



290    What's New in NX 7   whatsnew7 0  

Why should I use it? 

You can keep passwords more secure by hiding them from unauthorized users. 

Where do I find it? 

Application Teamcenter Integration command line utilities and command line 

startup 

 

Adding item types to File New templates 

What is it? 

You can select from multiple item types for a template when you create a new item. The item types 

available can vary for each template and are provided in the Item Type list. The listed item types can be 

customized for each template. 

The Item Type list can be modified to list several or all valid item types by modifying the template PAX 

files. 

 Note 

Acceptable item types are those that are valid Teamcenter item types. 

 

The following XML element needs to be modified for each template to add additional item types: 

  <ItemType></ItemType> 

The following examples show how to modify the XML element for different scenarios: 

• To display the full list of item types: 

  <ItemType>Any</ItemType> 

• To display the full list of item types, but have an item type preselected and displayed as the 

default: 

  <ItemType>NXPart,Any</ItemType> 

• To display a specific list of item types, include only those that are to be listed: 

  <ItemType>NXPart,NXDrawing,NXSheetmetal</ItemType> 

• To keep the template tied to one item type, include only that one: 

  <ItemType>NXPart</ItemType> 

 Note 

If only one item type is allowed for a template, the Item Type list is not displayed 

in the File New dialog box. 

 

The Item Type list is only shown when you are creating a new item, not when you are creating a non-

master such as a drawing that has a specification relation type. 
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When auto-assign is off, after you assign a number, revision, or item name and the item type is changed, 

all of the fields are cleared. If auto-assign is on and the item type is changed, all of the fields are 

reassigned new numbers and values. This occurs because if you have a naming rule in effect for one item 

type but not another, the values that are current may not be valid. 

For CAM templates (in the Manufacturing tab in the File New dialog box), the list of valid item types 

is defined by the Teamcenter preference NX_supported_operation_types. The functionality for item 

types in CAM templates is the same as other templates, but limited by the types set in the preference. The 

item type default for CAM templates is MENCMachining. 

Why should I use it? 

You can customize new item templates by adding a list of specific item types that you can select. 

Where do I find it? 

Application Teamcenter Integration 

Menu File→New 

Location in dialog box Item Type 

 

Create an alternate representation in model template 

What is it? 

You can use File→New to create a new model as an alternate representation (Alt Rep). On the Model 
tab, select the Alt Rep check box for a model template to create an Alt Rep. The Alt Rep dataset is 

created under an existing Item Revision. 

The value for the Alt Rep dataset name is created using the same method that is used for creating an Alt 

Rep when you perform a Save As operation (<ItemNumber>-<ItemRev>-alt#). 

You cannot create a new item when an Alt Rep is being created. When the Alt Rep check box is selected 

(it is not selected by default), the Item Type list is not available. Also, you cannot create an Alt Rep for 

CAE and CAM items. 

In the modeling PAX file (nxdm_ugs_model_templates.pax), the Alt Rep checkbox is not included by 

default and must be added for modeling templates. Modeling templates are defined as only those 

templates where the class attribute of ObjectData has the value ModelTemplate as in <ObjectData 

class=”ModelTemplate”>. To add the Alt Rep check box to a model template, add the following to the 

PAX file: 

  <ShowAltRep>Yes</ShowAltRep> 
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For example: 

  <PaletteEntry id=”d2”> 

    <References/> 

    <Presentation name=”Model” desription=”NX Example with datum CSYS”> 

        <PreviewImage type=”UGPart” location=”@DB/model-plain–1–mm-

template/A”/> 

    </Presentation> 

    <ObjectData class="ModelTemplate"> 

        <Filename>@DB/model_inch/A</Filename> 

        <Units>English</Units> 

        <ItemType>Item,Part,SpecElement,DMTemplate</ItemType> 

        <RelationType>master</RelationType> 

        <ShowAltRep>Yes</ShowAltRep> 

    <ObjectData> 

</PaletteEntry> 

When you have a part loaded and select the Alt Rep check box, the template switches to non-master 

functionality. The Number, Revision, and Item Name boxes are grayed out, the Dataset Name box is 

displayed, and the Reference Part boxes are populated with values. You can use the Browse button to 

select a different reference part. If a part is not loaded, those boxes are blank and grayed out. You can use 

the Browse button to select a part to reference. 

In addition, the Add master part as a component check box is displayed. If you select this check 

box, the master dataset is added as a component of the newly created Alt Rep. This is shown in the 

Assembly Navigator. 

If you create an Alt Rep and the referenced item does not have a master dataset or a master dataset exists 

without a named reference, when you click OK in the File New dialog box to create the Alt Rep, you are 

prompted to create the master first. 

If you select an existing Alt Rep as the reference part, the corresponding master part is loaded and used as 

the reference part instead. 

A Blank Model template contains the Alt Rep check box by default. A Blank Model template is 

displayed if all of the templates in a PAX file are modeling templates. If the templates in a PAX file are a 

mixture of modeling and other templates, then the blank template is a Blank Gateway template, and the 

Alt Rep check box is not included. 

If you create an Alt Rep in Teamcenter and open it in NX, the model templates that have the Alt Rep 

specification in the PAX file are shown in the File New dialog box. If no templates have the Alt Rep 

specification in the PAX file, then all model templates are shown with the Alt Rep check box displayed 

and the Add master part as a component check box not displayed. You can create the Alt Rep but 

no master dataset can be added as a component. 

Why should I use it? 

You can create an Alt Rep from a new model template. 

Where do I find it? 

Application Teamcenter Integration 

Menu File→New 

Location in dialog box Model tab→Alt Rep check box 
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Storing template PAX files in Teamcenter 

What is it? 

You can store the PAX files used to define the templates in Teamcenter Items and Item Revisions. The 

PAX files stored in Teamcenter are read by Teamcenter Integration during startup to create the templates 

contained in the File New dialog box. 

You define the location of the PAX files with the following Teamcenter preference: 

  TC_NX_FileNewPAXFiles_NX? 

where ? is the version of NX you are running, such as 6 or 7 

  For example, if you are running NX 7: TC_NX_FileNewPAXFiles_NX7 

Valid values: Items or Item Revisions 

  For example: model_1 or model_2/A 

 Note 

Typically there are multiple values, such as one for the model PAX file, one for the 

drawing PAX file, and so on. 

 

This preference is not shipped with Teamcenter; you must add it manually. If the preference is not used, 

Teamcenter Integration defaults to the default location of PAX files used in previous releases of NX, 

which is %UGII_BASE_DIR%\ugii\templates, or as defined by the environment variable 

UGII_TEMPLATE_DIR. 

If only an Item is listed in the preference, the PAX file in the latest Item Revision of that Item is used. 

This is determined by the Latest by Creation Date revision rule. 

To modify the contents of a PAX file, you revise the Item Revision and then change the PAX file dataset 

under the newly created Item Revision. 

It is recommended that you store each PAX file dataset in a separate Item. This method enables each Item 

Revision of the Item to contain the same PAX file with different revisions of the file. Storing multiple 

PAX files in the same Item could cause problems as subsequent Item Revisions could contain different 

PAX files, not just different versions of the same file. 

Why should I use it? 

Managing the PAX files in Teamcenter Items and Item Revisions provides more flexibility and universal 

access to the same PAX files within an installation and allows you to replicate the PAX files in a 

Teamcenter multi-site configuration. 

Where do I find it? 

Application Teamcenter Integration 

Menu File→New 

Location in dialog box Templates in tabs 
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SSL supported in four-tier Teamcenter environment 

What is it? 

Secure Socket Layer (SSL) is now available when you connect to Teamcenter in a four-tier Teamcenter 

environment. SSL is a layer of security provided by web servers and its use is identified by a URL that 

begins with https. 

SSL capability is provided by the use of Teamcenter's Service Oriented Architecture (SOA) as the new 

communications channel with Teamcenter in the four-tier environment. SOA replaces AIWS as the 

communications channel. 

Why should I use it? 

You have a more secure communication method when using TCIN in a four-tier Teamcenter 

environment. 

Where do I find it? 

Application Teamcenter Integration 

The incorporation of Teamcenter's SOA is part of the TCIN 

architecture for this release and is automatically implemented in the 

software. No preferences or options are needed to activate the 

functionality. 

 

Performance improvement for four-tier deployment 

What is it? 

NX four-tier client performance improvements enable NX users from remote divisions and disparate 

locations to work in real-time with regional/global Teamcenter hubs at network latencies as high as 

250ms with four-tier deployments. 

With these improvements, you can significantly reduce your IT costs by consolidating your multi-site 

environments. 

 Note 

This capability is available from NX 6.0.3. 

 

Why should I use it? 

You can work globally more easily and efficiently, and reduce IT costs. 

Where do I find it? 

Application Teamcenter Integration in a four-tier Teamcenter environment. 
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Systems Design 

PCB Exchange 

New drilled holes design features support 

What is it? 

Previously, you could specify  Drilled Hole Attributes only for Simple Hole features you created using 

the Hole command in Modeling. Now you can specify Drilled Hole Attributes also for cylindrical 

holes created using the following Modeling commands: 

• Extrude. The hole must be created by extruding a circular curve using the Subtract Boolean 

option. 

•  Cylinder. The hole must be created by subtracting the cylinder from the board. 

• Instance Feature. The rectangular or circular array of holes is created by copying a previously 

created hole using Hole, Extrude, or Cylinder commands. 

 Note 

If you extrude a curve that is not circular, the Extrude feature is not a drilled hole, but only a 

cutout. 

When importing ECAD model, drilled holes are still created as Simple Hole features. 

 

Where do I find it? 

Application PCB Exchange 

Prerequisite An imported ECAD model or an NX CAD printed circuit assembly 

with holes created in the Modeling application using the Extrude, 

Cylinder, or Instance Feature commands. 

Toolbar 
PCB Exchange toolbar → Drilled Hole Attributes    

 

Merge restricted areas with cutouts into one loop 

What is it? 

You can now merge cutouts of a keep-in, keep-out, or other area region with its outer loop to form one 

loop. PCB Exchange merges loops of restriction areas by introducing a small gap that connects cutouts 

(inner loops) to the outer loop. 
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PCA board 

 
Restricted area (keep-in, keep-out, or other area) in 

blue 

 
Outer loop 

 
2 cutouts (inner loops) 

 
Gaps between the inner and outer loops 

 

To activate this feature the following variables should be set in pcbx_ug_model.ini file: 

• NxWriteMergeAreaLoops = Yes 

• NxWriteMergeAreaGapSize = # where # is the gap size. By default, this value is 1e-3. 

Why should I use it? 

Use this option when your ECAD system does not accept the definition of separate restriction area and 

cutout loops. 
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Where do I find it? 

The pcbx_ug_model.ini file can be found in the: 

• Network Location specified by MAYA_PCB_ENV_DIR 

• Working directory 

• Location specified by MAYA_PCB_DIR 

• NX installation directory 

Display the board coordinate system 

What is it? 

The board coordinate system is now automatically displayed when the Board Attributes dialog box is 

open. 

The board coordinate system is only visible when you use the Board Attributes command. 

Where do I find it? 

Application PCB Exchange 

Prerequisite An imported ECAD model or an NX CAD printed circuit assembly  

Toolbar 
PCB Exchange toolbar → Board Attributes    

 

Override board thickness 

What is it? 

You can now override the board thickness from the ECAD model by selecting the Override Board 
Thickness check box and entering a value in the Board Thickness box in the following dialog boxes: 

• Import ECAD Model 

• Compare and Update PCA  

You can change the default value in the Board Thickness box by modifying the 

NxWriteDefaultBoardThk variable in the pcbx_ug_model.ini file. 

Why should I use it? 

Use this option when the board thickness defined in the ECAD file is not correct. 
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Where do I find it? 

Application PCB Exchange 

Toolbar 
PCB Exchange toolbar → Import ECAD Model    /  

Compare and Update PCA    

 

Specify drilled hole associated part 

What is it? 

The Associated Part option in the Drilled Hole Attributes dialog box is now a list with Intermediate 

Data Format (IDF) accepted choices. In previous releases, this option was a box in which you entered the 

name of the associated part. 

You can now choose the associated part on the board from the Associated Part list. The choices on the  

Associated Part list are: 

• BOARD — The hole is associated to the board part. 

• NOREFDES — The hole is associated to a mechanical component. 

• Specify — The hole is associated to an electrical component. You must specify the name of the 

component in the Specify Part box. 

Where do I find it? 

Application PCB Exchange 

Prerequisite An imported ECAD model or an NX CAD printed circuit assembly 

with drilled holes 

Toolbar 
PCB Exchange toolbar → Drilled Hole Attributes    

 

Default directory for ECAD files 

What is it? 

You can now specify a default directory for ECAD files. 

You can enter the absolute path to the directory in one of the following: 

• The Default ECAD Directory box in the Settings dialog box. 

• The EcadDefaultDir variable in the pcbx_ug.ini file. 

 Note 

The PCB Exchange browser always points to the specified default ECAD directory. If you do not 

specify the default ECAD directory, the PCB Exchange browser points to the last selected 

directory. 
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Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Settings 

Location in dialog box Default ECAD Directory 

 

Directory for new created components 

What is it? 

The Create New Components In option is now available in  the Settings dialog box. It is no longer 

available in the Import ECAD Model and Compare and Update PCA dialog boxes. 

PCB Exchange places files containing new components from the ECAD footprint in the directory you 

specify in the Create New Components In box. 

In the Create New Components In box, you can enter the absolute path to the directory, the 

Teamcenter folder name, or the following reserved keywords: 

• ECAD_FILE_DIR — Use this keyword to place new components in the same directory as the 

ECAD file. 

• NX_PART_DIR — Use this keyword to place new components in the same directory as the NX 

assembly or model file. 

You can also set the directory for new components in the NewComponentDir variable of the pcbx_ug.ini 

file. 

Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Settings 

Location in dialog box Create New Components In 

 

PCA import rules 

What is it? 

You can now setup rules on how NX represents a printed circuit model. Prior to this version, the board 

was always defined in the master geometry of the printed circuit assembly (PCA) part. With these new 

design rules, you can configure PCB Exchange so that the board is imported in a separate part and added 

as an assembly component to the main PCA part. 
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On the PCA page of the PCB Exchange Settings dialog box, you can specify how to: 

• Name the PCA. You can: 

– Use the current NX model name. 

– Use the ECAD model name. 

– Specify a PCA name at import. 

• Group PCA entities. This option creates subassemblies in order to classify the printed circuit 

entities. 

• Import the PCA board, components, and areas. You can import each entity as a master geometry 

of the main PCA part or an assembly component. 

Why should I use it? 

PCA import rules give you more flexibility when importing PCA entities into NX. 

Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Settings 

Location in dialog box PCA page 

 

PCB Exchange Settings dialog box enhancements 

What is it? 

The PCB Exchange Settings dialog box now has the following tabs: 

• General 

• PCA 

• Board 

• Holes 

• Components 

• Keep-ins 

• Keep-outs 

• Other Areas 

• Other Entities 

The settings on these different pages let you specify the most common PCB Exchange work environment 

variables found in pcbx_ug.ini and pcbx_ug_model.ini initialization files. 
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Why should I use it? 

Instead of modifying the initialization options in the pcbx_ug.ini and pcbx_ug_model.ini files and then 

restarting NX in order to have these options take effect, you can now set the most common PCB 

Exchange settings in the improved PCB Exchange Settings dialog box. 

Where do I find it? 

Application PCB Exchange 

Menu PCB Exchange → Settings 

 

Import ECAD model in a part file 

What is it? 

You no longer need to import ECAD models into an NX part file in the No Part state. For example, if you 

have a part file with an electronic enclosure, PCB Exchange allows you to directly import a PCA model 

into this enclosure's part file. 

If the part file contains a valid PCB, in order to avoid confusion, it is strongly recommended that you 

design this PCB as a subassembly. To share it with the imported ECAD model, just make the PCB the 

work part or the displayed part. 

Where do I find it? 

Application PCB Exchange 

Prerequisite A non empty part file 

Toolbar 
PCB Exchange toolbar → Import ECAD Model    

Menu PCB Exchange → Import ECAD Model 

 

ECAD/NX model comparison enhancement 

What is it? 

When comparing the current NX model with an existing ECAD model using the Compare and Update 

PCA    command, you can now preview the detected changes in the graphics window by selecting 

Preview Changes   . 

The following graphic shows the original models and a preview of the detected changes. 
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Original NX model 

 

Original ECAD model 

 

 

Detected changes between NX and ECAD models 

The following changes are detected: 

• Component    is not placed at the same location in the NX model and the ECAD model. 

• Component    is deleted from the NX model. 

• Component    is added to the NX model. 

If you select one of the changed components from the component list under the Components Status 

group, the NX model component and the ECAD model component are highlighted in the graphics 

window. 

Why should I use it? 

The Preview Changes    icon helps you visualize the differences between the NX model and the 

ECAD model. 
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Where do I find it? 

Application PCB Exchange 

Toolbar 
PCB Exchange toolbar → Compare and Update PCA    

Menu PCB Exchange → Compare and Update PCA 

 

Filtering enhancements 

What is it? 

The improved Filters List dialog box contains pre-defined and user-defined filter rules. 

When you import, export, or compare and update ECAD models, you can now select the entities to 

remove in the Filters List dialog box. You can select: 

• Different types of holes. 

• Different types of components. 

• Different types of restriction areas. 

Why should I use it? 

The filter rules are now much easier to use with the improved Filters List dialog box. 

Where do I find it? 

Application PCB Exchange 

Toolbar 
PCB Exchange toolbar → Import ECAD Model    / Export 

ECAD Model    / Compare and Update PCA    

Menu PCB Exchange → Import ECAD Model / Export ECAD Model 
/ Compare and Update PCA 

Location in dialog box In Import Options, Export Options, or Compare Options 

group, select Use Entity Filter /  Use Entity Filter on NX model 
/  Use Entity Filter on ECAD model → Filter List 

 

PCB Exchange for Zuken 

What is it? 

PCB Exchange for Zuken is a new application that lets you import or export PCB assemblies in the 

Zuken's CR5000 native format. 

You import or export Zuken format files the same way you import or export files of other supported 

formats. 
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All functionality previously supported for other file formats  is also supported for the Zuken format. In 

addition, the Zuken format supports the import and export of: 

• Flexible printed circuits 

• Traces 

• Pads 

• Metal masks 

• Resist masks 

On the Other Entities page of the PCB Exchange Settings dialog box, you can specify how to:  

• Import traces, pads, masks, and internal layers from Zuken format files in the Import Rules 

group. 

• Export projection view of the PCB to Zuken format files in the Export Rules group. 

By default, PCB Exchange for Zuken imports and exports to version 10 of the CR5000 application. You 

can change this to version 9 by setting the following environment variable UGII_PCB_CR5000_VERSION to 

9. 

Where do I find it? 

 Note 

When importing PCB assembly from Zuken format files, file type is automatically detected. 

 

To specify Zuken import and export settings 

Application PCB Exchange for Zuken 

Prerequisite An active PCB assembly 

Menu PCB Exchange → Settings 

Location in dialog box Other Entities page 
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Export PCB assembly to Zuken format files 

Application PCB Exchange for Zuken 

Prerequisite An active PCB assembly 

Toolbar 
PCB Exchange toolbar → Export ECAD Model    

Menu PCB Exchange → Export ECAD Model 

Location in dialog box Export Options → File Format → Zuken bmb or Zuken pcb 
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